aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2023-11-01 08:02:04 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2023-11-01 10:58:36 +0000
commit0573da1acf9f483288b969b210833948b7ee2afd (patch)
tree1c85a4f0186623fa934f862259a3fea2d536b85e
parentbf73c9c9d49d5583f97b3fd2f0e6ff7ae5d9184d (diff)
downloadports-0573da1acf9f483288b969b210833948b7ee2afd.tar.gz
ports-0573da1acf9f483288b969b210833948b7ee2afd.zip
www/gitlab-ce: remove ca_root_nss fetch dep for go ports
Thanks to des. Reported by: des Differential Revision: https://reviews.freebsd.org/D42072
-rw-r--r--devel/gitaly/Makefile3
-rw-r--r--devel/gitlab-shell/Makefile3
-rw-r--r--textproc/gitlab-elasticsearch-indexer/Makefile3
-rw-r--r--www/gitlab-workhorse/Makefile3
4 files changed, 4 insertions, 8 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index 5b07ee337c3e..b2e84e3c1aa6 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -39,8 +39,7 @@ GL_ACCOUNT= gitlab-org
# so we download the required go.mod file from gitlab
# lines are taken from go.mk
# ---------------------------
-FETCH_DEPENDS= ${GO_CMD}:${GO_PORT} \
- ca_root_nss>0:security/ca_root_nss
+FETCH_DEPENDS= ${GO_CMD}:${GO_PORT}
MASTER_SITES+= https://gitlab.com/gitlab-org/gitaly/-/raw/v${DISTVERSION}/
DISTFILES+= go.mod
DIST_SUBDIR= go/${PKGORIGIN:S,/,_,g}/${DISTNAME}
diff --git a/devel/gitlab-shell/Makefile b/devel/gitlab-shell/Makefile
index 47acb54aef5d..94580cafea0c 100644
--- a/devel/gitlab-shell/Makefile
+++ b/devel/gitlab-shell/Makefile
@@ -34,8 +34,7 @@ MAKE_ENV+= ${GO_ENV}
# so we download the required go.mod file from gitlab
# lines are taken from go.mk
# ---------------------------
-FETCH_DEPENDS= ${GO_CMD}:${GO_PORT} \
- ca_root_nss>0:security/ca_root_nss
+FETCH_DEPENDS= ${GO_CMD}:${GO_PORT}
MASTER_SITES+= https://gitlab.com/gitlab-org/gitlab-shell/-/raw/v${DISTVERSION}/
DISTFILES+= go.mod
DIST_SUBDIR= go/${PKGORIGIN:S,/,_,g}/${DISTNAME}
diff --git a/textproc/gitlab-elasticsearch-indexer/Makefile b/textproc/gitlab-elasticsearch-indexer/Makefile
index 45202ffdc601..e95cf11e1d64 100644
--- a/textproc/gitlab-elasticsearch-indexer/Makefile
+++ b/textproc/gitlab-elasticsearch-indexer/Makefile
@@ -29,8 +29,7 @@ MAKE_ENV+= ${GO_ENV}
# so we download the required go.mod file from gitlab
# lines are taken from go.mk
# ---------------------------
-FETCH_DEPENDS= ${GO_CMD}:${GO_PORT} \
- ca_root_nss>0:security/ca_root_nss
+FETCH_DEPENDS= ${GO_CMD}:${GO_PORT}
MASTER_SITES+= https://gitlab.com/gitlab-org/gitlab-elasticsearch-indexer/-/raw/v${DISTVERSION}/
DISTFILES+= go.mod
DIST_SUBDIR= go/${PKGORIGIN:S,/,_,g}/${DISTNAME}
diff --git a/www/gitlab-workhorse/Makefile b/www/gitlab-workhorse/Makefile
index 383a108fad7b..91ac2df6c4a9 100644
--- a/www/gitlab-workhorse/Makefile
+++ b/www/gitlab-workhorse/Makefile
@@ -29,8 +29,7 @@ GL_PROJECT= gitlab-foss
# so we download the required go.mod file from gitlab
# lines are taken from go.mk
# ---------------------------
-FETCH_DEPENDS= ${GO_CMD}:${GO_PORT} \
- ca_root_nss>0:security/ca_root_nss
+FETCH_DEPENDS= ${GO_CMD}:${GO_PORT}
MASTER_SITES+= https://gitlab.com/gitlab-org/gitlab-foss/-/raw/v${DISTVERSION}/workhorse/
DISTFILES+= go.mod
DIST_SUBDIR= go/${PKGORIGIN:S,/,_,g}/${DISTNAME}