aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-26 13:13:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-04-26 13:48:51 +0000
commit05ede336183bd9ae9c8a88f2916db26111c83641 (patch)
treefc29e84595a7d94f191f2c1ad4657fb061dc07ea
parente2d0db77c456768daab0dfbda11a58852950f614 (diff)
downloadports-05ede336183bd9ae9c8a88f2916db26111c83641.tar.gz
ports-05ede336183bd9ae9c8a88f2916db26111c83641.zip
textproc/py-sphinx: switch to USES=pytest and document failing tests
Reported by: reprise Approved by: portmgr blanket (no explicit approval requested as the change only affects testing)
-rw-r--r--textproc/py-sphinx/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/textproc/py-sphinx/Makefile b/textproc/py-sphinx/Makefile
index 69e437d5e1f9..5c2c420a0a58 100644
--- a/textproc/py-sphinx/Makefile
+++ b/textproc/py-sphinx/Makefile
@@ -36,12 +36,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinxcontrib-applehelp>=0:textproc/py-sphin
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest4-cov>=0:devel/py-pytest4-cov@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest4>=0:devel/py-pytest4@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}html5lib>=0:www/py-html5lib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typed-ast>=0:devel/py-typed-ast@${PY_FLAVOR} \
cython-${PYTHON_VER}:lang/cython@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.5+ pytest:4
USE_PYTHON= autoplist distutils concurrent
NO_ARCH= yes
@@ -49,7 +48,10 @@ NO_ARCH= yes
# Upstream archive contains files with UTF-8 names (#246618)
EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
-do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs -o addopts= -k 'not test_ext_imgconverter'
+PYTEST_BROKEN_TESTS= test_latex_images \
+ test_ext_imgconverter \
+ test_defaults \
+ test_defaults_json \
+ test_anchors_ignored
.include <bsd.port.mk>