aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-05-15 04:27:31 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-05-15 04:27:31 +0000
commit05f17004e5b6c547b8a47857d035ea236110d2af (patch)
treea26d684dad04d8da062b66a7fce0a84e3509c693
parent5e289e7bfe519853e8b1ca787dd4710967c5f499 (diff)
downloadports-05f17004e5b6c547b8a47857d035ea236110d2af.tar.gz
ports-05f17004e5b6c547b8a47857d035ea236110d2af.zip
devel/upnp: Update to 1.8.4
- Bump revision of consumers for shared library change Changes: http://pupnp.sourceforge.net/ChangeLog PR: 234669 Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch> (maintainer)
Notes
Notes: svn path=/head/; revision=501684
-rw-r--r--devel/upnp/Makefile65
-rw-r--r--devel/upnp/distinfo6
-rw-r--r--devel/upnp/files/patch-libupnp.pc.in11
-rw-r--r--devel/upnp/files/patch-threadutil__inc__ithread.h16
-rw-r--r--devel/upnp/files/patch-upnp-src-inc-uuid.h17
-rw-r--r--devel/upnp/pkg-plist277
-rw-r--r--multimedia/vlc/Makefile2
-rw-r--r--net-p2p/amule-devel/Makefile1
-rw-r--r--net-p2p/amule/Makefile2
9 files changed, 75 insertions, 322 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
index 975d19d3e22e..6cad5db4f1be 100644
--- a/devel/upnp/Makefile
+++ b/devel/upnp/Makefile
@@ -2,44 +2,73 @@
# $FreeBSD$
PORTNAME= upnp
-PORTVERSION= 1.6.25
+DISTVERSIONPREFIX= release-
+DISTVERSION= 1.8.4
PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= SF/p${PORTNAME}/p${PORTNAME}/libUPnP%20${PORTVERSION}
-DISTNAME= lib${PORTNAME}-${PORTVERSION}
MAINTAINER= phascolarctos@protonmail.ch
COMMENT= Universal Plug and Play Software Development Kit
LICENSE= BSD3CLAUSE
-LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cpe libtool pathfix tar:bzip2
+USES= autoreconf cpe libtool pathfix
+USE_GITHUB= yes
+GH_ACCOUNT= mrjimenez
+GH_PROJECT= pupnp
USE_LDCONFIG= yes
-PORTSCOUT= skipv:1.8.3 # released on 2017-11-14; older than 1.6.25
-
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-device \
+ --enable-gena \
+ --enable-soap \
+ --enable-ssdp \
+ --enable-webserver
INSTALL_TARGET= install-strip
TEST_TARGET= check
CPE_VENDOR= libupnp_project
CPE_PRODUCT= libupnp
-PORTDOCS= ixml/*.html upnp/*.html
-
-OPTIONS_DEFINE= DEBUG DOCS IPV6
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= CLIENT DEBUG DOCS EXAMPLES IPV6 LARGEFILE OPENSSL \
+ OPTSSDP POSTWRITE REUSEADDR SCRIPTSUPPORT TCP_BLOCK \
+ TEST TOOLS UNSPECIFIED_SERVER
+OPTIONS_DEFAULT= CLIENT LARGEFILE OPTSSDP REUSEADDR SCRIPTSUPPORT \
+ TCP_BLOCK TOOLS
+OPTIONS_SUB= yes
-DEBUG_CONFIGURE_ENABLE= debug
-DOCS_CONFIGURE_WITH= documentation=${DOCSDIR}
-IPV6_CONFIGURE_ENABLE= ipv6
+CLIENT_DESC= Enable control point code
+LARGEFILE_DESC= Large files support
+OPTSSDP_DESC= Enable optional SSDP headers support
+POSTWRITE_DESC= Write to filesystem on unhandled POST requests
+REUSEADDR_DESC= Bind miniserver socket with reuseaddr
+SCRIPTSUPPORT_DESC= Enable script support for IXML document tree
+TCP_BLOCK_DESC= Enable blocking TCP connections
+TEST_DESC= Perfom a few tests (implies TOOLS)
+TOOLS_DESC= Enable helpers API in upnptools.h
+UNSPECIFIED_SERVER_DESC= Enable unspecified SERVER header
-pre-configure:
- ${REINPLACE_CMD} -e '386s,docs/dist,,' ${WRKSRC}/Makefile.in
+CLIENT_CONFIGURE_ENABLE= client
+DEBUG_CONFIGURE_ENABLE= debug
+EXAMPLES_CONFIGURE_ENABLE= samples
+IPV6_CONFIGURE_ENABLE= ipv6
+LARGEFILE_CONFIGURE_ENABLE= largefile
+OPENSSL_CONFIGURE_ENABLE= open_ssl
+OPENSSL_USES= ssl
+OPENSSL_CFLAGS= -I${OPENSSLINC}
+OPENSSL_LDFLAGS= -L${OPENSSLLIB} -lssl
+OPTSSDP_CONFIGURE_ENABLE= optssdp
+POSTWRITE_CONFIGURE_ENABLE= postwrite
+REUSEADDR_CONFIGURE_ENABLE= reuseaddr
+SCRIPTSUPPORT_CONFIGURE_ENABLE= scriptsupport
+TCP_BLOCK_CONFIGURE_ENABLE= blocking_tcp_connections
+TEST_IMPLIES= TOOLS
+TOOLS_CONFIGURE_ENABLE= tools
+UNSPECIFIED_SERVER_CONFIGURE_ENABLE= unspecified_server
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC}/docs/dist/html && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
- ${RM} -r ${STAGEDIR}${DOCSDIR}/examples
+ ${INSTALL_MAN} ${WRKSRC}/upnp/doc/UPnP_Programming_Guide.pdf \
+ ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/devel/upnp/distinfo b/devel/upnp/distinfo
index 644c74e28f53..0cf45425cff8 100644
--- a/devel/upnp/distinfo
+++ b/devel/upnp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534737656
-SHA256 (libupnp-1.6.25.tar.bz2) = c5a300b86775435c076d58a79cc0d5a977d76027d2a7d721590729b7f369fa43
-SIZE (libupnp-1.6.25.tar.bz2) = 722731
+TIMESTAMP = 1546614165
+SHA256 (mrjimenez-pupnp-release-1.8.4_GH0.tar.gz) = 976c3e4555604cdd8391ed2f359c08c9dead3b6bf131c24ce78e64d6669af2ed
+SIZE (mrjimenez-pupnp-release-1.8.4_GH0.tar.gz) = 783896
diff --git a/devel/upnp/files/patch-libupnp.pc.in b/devel/upnp/files/patch-libupnp.pc.in
deleted file mode 100644
index 45cdb32866e9..000000000000
--- a/devel/upnp/files/patch-libupnp.pc.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- libupnp.pc.in.orig 2010-10-19 17:31:19 UTC
-+++ libupnp.pc.in
-@@ -6,6 +6,6 @@ includedir=@includedir@
- Name: libupnp
- Description: Linux SDK for UPnP Devices
- Version: @VERSION@
--Libs: @PTHREAD_CFLAGS@ @PTHREAD_LIBS@ -L${libdir} -lupnp -lthreadutil -lixml
--Cflags: @PTHREAD_CFLAGS@ -I${includedir}/upnp
-+Libs: -pthread -L${libdir} -lupnp -lthreadutil -lixml @LIBS@
-+Cflags: -I${includedir}/upnp
-
diff --git a/devel/upnp/files/patch-threadutil__inc__ithread.h b/devel/upnp/files/patch-threadutil__inc__ithread.h
deleted file mode 100644
index dbaffe204158..000000000000
--- a/devel/upnp/files/patch-threadutil__inc__ithread.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- threadutil/inc/ithread.h.orig 2013-11-14 17:14:44 UTC
-+++ threadutil/inc/ithread.h
-@@ -50,12 +50,9 @@ extern "C" {
-
- #include <pthread.h>
-
--#if defined(BSD) && !defined(__GNU__)
-- #define PTHREAD_MUTEX_RECURSIVE_NP PTHREAD_MUTEX_RECURSIVE
--#endif
-
-
--#if defined(PTHREAD_MUTEX_RECURSIVE) || defined(__DragonFly__)
-+#if defined(PTHREAD_MUTEX_RECURSIVE) || defined(__DragonFly__) || defined(__FreeBSD__)
- /* This system has SuS2-compliant mutex attributes.
- * E.g. on Cygwin, where we don't have the old nonportable (NP) symbols
- */
diff --git a/devel/upnp/files/patch-upnp-src-inc-uuid.h b/devel/upnp/files/patch-upnp-src-inc-uuid.h
deleted file mode 100644
index afc927549af6..000000000000
--- a/devel/upnp/files/patch-upnp-src-inc-uuid.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- upnp/src/inc/uuid.h.orig 2016-01-07 23:32:52 UTC
-+++ upnp/src/inc/uuid.h
-@@ -22,6 +22,14 @@
-
- #include "sysdep.h"
-
-+#ifdef __FreeBSD__
-+/* Workaround to avoid picking up different uuid_* fns from FreeBSD's libc */
-+#define uuid_create libupnp_uuid_create
-+#define uuid_unpack libupnp_uuid_unpack
-+#define uuid_create_from_name libupnp_uuid_create_from_name
-+#define uuid_compare libupnp_uuid_compare
-+#endif
-+
- /*! . */
- typedef struct _uuid_upnp {
- /*! . */
diff --git a/devel/upnp/pkg-plist b/devel/upnp/pkg-plist
index 29720a32d975..7242af92097b 100644
--- a/devel/upnp/pkg-plist
+++ b/devel/upnp/pkg-plist
@@ -1,7 +1,16 @@
-include/upnp/FreeList.h
-include/upnp/LinkedList.h
-include/upnp/ThreadPool.h
-include/upnp/TimerThread.h
+include/upnp/ActionComplete.h
+include/upnp/ActionRequest.h
+include/upnp/Callback.h
+include/upnp/Discovery.h
+include/upnp/Event.h
+include/upnp/EventSubscribe.h
+include/upnp/FileInfo.h
+include/upnp/StateVarComplete.h
+include/upnp/StateVarRequest.h
+include/upnp/SubscriptionRequest.h
+include/upnp/TemplateInclude.h
+include/upnp/TemplateSource.h
+include/upnp/TemplateUndef.h
include/upnp/UpnpGlobal.h
include/upnp/UpnpInet.h
include/upnp/UpnpIntTypes.h
@@ -11,261 +20,19 @@ include/upnp/UpnpUniStd.h
include/upnp/ithread.h
include/upnp/ixml.h
include/upnp/ixmldebug.h
+include/upnp/list.h
+include/upnp/poison.h
include/upnp/upnp.h
include/upnp/upnpconfig.h
-include/upnp/upnpdebug.h
-include/upnp/upnptools.h
+%%DEBUG%%include/upnp/upnpdebug.h
+%%TOOLS%%include/upnp/upnptools.h
lib/libixml.a
lib/libixml.so
-lib/libixml.so.2
-lib/libixml.so.2.0.8
-lib/libthreadutil.a
-lib/libthreadutil.so
-lib/libthreadutil.so.6
-lib/libthreadutil.so.6.0.4
+lib/libixml.so.10
+lib/libixml.so.10.0.1
lib/libupnp.a
lib/libupnp.so
-lib/libupnp.so.6
-lib/libupnp.so.6.4.1
+lib/libupnp.so.13
+lib/libupnp.so.13.0.0
libdata/pkgconfig/libupnp.pc
-%%PORTDOCS%%%%DOCSDIR%%/AboutCallbacks.html
-%%PORTDOCS%%%%DOCSDIR%%/ConstantsStructuresandTypes.html
-%%PORTDOCS%%%%DOCSDIR%%/Control.html
-%%PORTDOCS%%%%DOCSDIR%%/ControlPointHTTPAPI.html
-%%PORTDOCS%%%%DOCSDIR%%/DOMInterfaces.html
-%%PORTDOCS%%%%DOCSDIR%%/Discovery.html
-%%PORTDOCS%%%%DOCSDIR%%/Errorcodes.html
-%%PORTDOCS%%%%DOCSDIR%%/Eventing.html
-%%PORTDOCS%%%%DOCSDIR%%/General.html
-%%PORTDOCS%%%%DOCSDIR%%/IXMLAPI.html
-%%PORTDOCS%%%%DOCSDIR%%/InitializationandRegistration.html
-%%PORTDOCS%%%%DOCSDIR%%/InterfaceitAttr.html
-%%PORTDOCS%%%%DOCSDIR%%/InterfaceitCDATASection.html
-%%PORTDOCS%%%%DOCSDIR%%/InterfaceitDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/InterfaceitElement.html
-%%PORTDOCS%%%%DOCSDIR%%/InterfaceitNamedNodeMap.html
-%%PORTDOCS%%%%DOCSDIR%%/InterfaceitNode.html
-%%PORTDOCS%%%%DOCSDIR%%/InterfaceitNodeList.html
-%%PORTDOCS%%%%DOCSDIR%%/Introduction.html
-%%PORTDOCS%%%%DOCSDIR%%/License.html
-%%PORTDOCS%%%%DOCSDIR%%/OptionalToolAPIs.html
-%%PORTDOCS%%%%DOCSDIR%%/TheAPI.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNPREG_BUF_DESC.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNPREG_FILENAME_DESC.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNPREG_URL_DESC.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_CONTROL_ACTION_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_CONTROL_ACTION_REQUEST.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_CONTROL_GET_VAR_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_CONTROL_GET_VAR_REQUEST.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_DISCOVERY_ADVERTISEMENT_ALIVE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_DISCOVERY_ADVERTISEMENT_BYEBYE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_DISCOVERY_SEARCH_RESULT.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_DISCOVERY_SEARCH_TIMEOUT.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_EVENT_AUTORENEWAL_FAILED.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_EVENT_RECEIVED.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_EVENT_RENEWAL_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_EVENT_SUBSCRIBE_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_EVENT_SUBSCRIPTION_EXPIRED.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_EVENT_SUBSCRIPTION_REQUEST.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_EVENT_UNSUBSCRIBE_COMPLETE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_ALREADY_REGISTERED-120.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_BAD_HTTPMSG-119.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_BAD_RESPONSE-113.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_CANCELED-210.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_EXT_NOT_XML-504.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_FILE_NOT_FOUND-502.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_FILE_READ_ERROR-503.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_FINISH-116.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INIT-105.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INIT_FAILED-117.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INTERNAL_ERROR-911.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INVALID_ACTION-115.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INVALID_ARGUMENT-501.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INVALID_DESC-107.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INVALID_HANDLE-100.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INVALID_PARAM-101.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INVALID_SERVICE-111.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_INVALID_URL-108.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_LISTEN-206.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_NETWORK_ERROR-200.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_NOTIFY_UNACCEPTED-303.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_NOT_FOUND-507.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_OUTOF_HANDLE-102.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_OUTOF_MEMORY-104.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_OUTOF_SOCKET-205.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_SOCKET_BIND-203.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_SOCKET_CONNECT-204.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_SOCKET_ERROR-208.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_SOCKET_READ-202.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_SOCKET_WRITE-201.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_SUBSCRIBE_UNACCEPTED-301.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_SUCCESS0.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_TIMEDOUT-207.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_E_UNSUBSCRIBE_UNACCEPTED-302.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_S_ALL.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_S_DEVICE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_S_ROOT.html
-%%PORTDOCS%%%%DOCSDIR%%/UPNP_S_SERVICE.html
-%%PORTDOCS%%%%DOCSDIR%%/UPnP_EventType.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpAcceptSubscription.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpAcceptSubscriptionExt.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpAddToAction.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpAddToActionResponse.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpAddToPropertySet.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpAddVirtualDir.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpCancelHttpGet.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpClient_Handle.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpCloseHttpGet.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpCloseHttpPost.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpCreatePropertySet.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpDevice_Handle.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpDownloadUrlItem.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpDownloadXmlDoc.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpEnableWebserver.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpFinish.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpGetErrorMessage.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpGetServerIpAddress.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpGetServerPort.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpGetServiceVarStatus.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpGetServiceVarStatusAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpHttpGetProgress.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpInit.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpIsWebserverEnabled.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpMakeAction.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpMakeActionResponse.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpNotify.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpNotifyExt.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpOpenHttpGet.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpOpenHttpGetEx.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpOpenHttpGetProxy.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpOpenHttpPost.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpReadHttpGet.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpRegisterClient.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpRegisterRootDevice.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpRegisterRootDevice2.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpRemoveAllVirtualDirs.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpRemoveVirtualDir.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpRenewSubscription.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpRenewSubscriptionAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpResolveURL.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSearchAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSendAction.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSendActionAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSendActionEx.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSendActionExAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSendAdvertisement.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSetContentLength.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSetMaxContentLength.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSetMaxSubscriptionTimeOut.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSetMaxSubscriptions.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSetVirtualDirCallbacks.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSetWebServerRootDir.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSubscribe.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpSubscribeAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpUnRegisterClient.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpUnRegisterRootDevice.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpUnSubscribe.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpUnSubscribeAsync.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpVirtualDirCallbacks.html
-%%PORTDOCS%%%%DOCSDIR%%/UpnpWriteHttpPost.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_Action_Request.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_DescType.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_Discovery.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_Event.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_Event_Subscribe.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_FunPtr.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_SID44.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_SType.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_State_Var_Complete.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_State_Var_Request.html
-%%PORTDOCS%%%%DOCSDIR%%/Upnp_Subscription_Request.html
-%%PORTDOCS%%%%DOCSDIR%%/WebServerAPI.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlAttr_free.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlCDATASection_free.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlCDATASection_init.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlCloneDOMString.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createAttributeEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createAttributeNSEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createCDATASection.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createCDATASectionEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createDocumentEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createElement.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createElementEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createElementNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createElementNSEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createTextNode.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_createTextNodeEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_free.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_getElementById.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_getElementsByTagName.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_getElementsByTagNameNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_importNode.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocument_init.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlDocumenttoString.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_free.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_getAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_getAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_getAttributeNode.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_getAttributeNodeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_getElementsByTagName.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_getElementsByTagNameNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_getTagName.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_hasAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_hasAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_init.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_removeAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_removeAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_removeAttributeNode.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_setAttribute.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_setAttributeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_setAttributeNode.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlElement_setAttributeNodeNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlFreeDOMString.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlLoadDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlLoadDocumentEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_free.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_getLength.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_getNamedItem.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_getNamedItemNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_item.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_removeNamedItem.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_removeNamedItemNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_setNamedItem.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNamedNodeMap_setNamedItemNS.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNodeList_free.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNodeList_item.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNodeList_length.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_appendChild.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_cloneNode.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_free.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getAttributes.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getChildNodes.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getFirstChild.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getLastChild.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getLocalName.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getNamespaceURI.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getNextSibling.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getNodeName.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getNodeType.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getNodeValue.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getOwnerDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getParentNode.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getPrefix.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_getPreviousSibling.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_hasAttributes.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_hasChildNodes.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_insertBefore.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_removeChild.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_replaceChild.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNode_setNodeValue.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlNodetoString.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlParseBuffer.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlParseBufferEx.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlPrintDocument.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlPrintNode.html
-%%PORTDOCS%%%%DOCSDIR%%/ixmlRelaxParser.html
-%%PORTDOCS%%%%DOCSDIR%%/toc.html
+%%PORTDOCS%%%%DOCSDIR%%/UPnP_Programming_Guide.pdf
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 88ba2faa82c1..f98ec88f30fe 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vlc
DISTVERSION= 3.0.6
-PORTREVISION= 13
+PORTREVISION= 14
PORTEPOCH= 4
CATEGORIES= multimedia audio ipv6 net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index 65ecdf6a7e2d..83c38990cd82 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= amule
PORTVERSION= 11004
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://amule.sourceforge.net/tarballs/
PKGNAMESUFFIX= -devel
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index 45b984ec0cb7..9667ef5a0857 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -3,7 +3,7 @@
PORTNAME= amule
PORTVERSION= 2.3.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/aMule/${PORTVERSION}
DISTNAME= aMule-${PORTVERSION}