aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-22 15:53:14 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2024-01-22 16:52:30 +0000
commit06183e6c0a5745bc5b9e0f12b33c1417a2553ccb (patch)
tree0724bb101351a2c9fc8550328c613a9800ba95d3
parentff8ebb3e6f3ae385c8410dbc8bdbb0df2ee309e3 (diff)
downloadports-06183e6c0a5745bc5b9e0f12b33c1417a2553ccb.tar.gz
ports-06183e6c0a5745bc5b9e0f12b33c1417a2553ccb.zip
net/http_ping: Sanitize MANPREFIX
Approved by: portmgr (blanket)
-rw-r--r--net/http_ping/Makefile4
-rw-r--r--net/http_ping/files/patch-Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/net/http_ping/Makefile b/net/http_ping/Makefile
index f2333e4afdb7..5d6e8c8dd862 100644
--- a/net/http_ping/Makefile
+++ b/net/http_ping/Makefile
@@ -1,6 +1,6 @@
PORTNAME= http_ping
PORTVERSION= 20050629
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net www
MASTER_SITES= http://www.acme.com/software/${PORTNAME}/
DISTNAME= ${PORTNAME}_29jun2005
@@ -13,6 +13,6 @@ USES= ssl
WRKSRC= ${WRKDIR}/${PORTNAME}
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-PLIST_FILES= bin/http_ping man/man1/http_ping.1.gz
+PLIST_FILES= bin/http_ping share/man/man1/http_ping.1.gz
.include <bsd.port.mk>
diff --git a/net/http_ping/files/patch-Makefile b/net/http_ping/files/patch-Makefile
index bb4254548615..ae1c6f34244d 100644
--- a/net/http_ping/files/patch-Makefile
+++ b/net/http_ping/files/patch-Makefile
@@ -13,7 +13,7 @@
+SSL_INC= -I${OPENSSLINC}
+SSL_LIBS= -L${OPENSSLLIB} -lssl -lcrypto
+BINDIR = ${PREFIX}/bin
-+MANDIR = ${MANPREFIX}/man/man1
++MANDIR = ${PREFIX}/share/man/man1
+CC?= gcc -Wall
+CFLAGS+= -g $(SRANDOM_DEFS) $(SSL_DEFS) $(SSL_INC)
#CFLAGS = -g $(SRANDOM_DEFS) $(SSL_DEFS) $(SSL_INC)