aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2022-04-20 05:34:44 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2022-04-20 05:34:44 +0000
commit0625156b336bacba1e5dc541680af85e97feb0e2 (patch)
treebbe6e0d48a2894e4a2ffba3cd4ba318c2d80cdcb
parent547b8a01c08d0f1ec3edf805b0a4c6a9b42e37a9 (diff)
downloadports-0625156b336bacba1e5dc541680af85e97feb0e2.tar.gz
ports-0625156b336bacba1e5dc541680af85e97feb0e2.zip
mail/sendmail: Fix option SASL and SMTP AUTH
PR: 263287
-rw-r--r--mail/sendmail/Makefile2
-rw-r--r--mail/sendmail/files/patch-zsasl221
2 files changed, 22 insertions, 1 deletions
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index 7c36b1ec32be..f83d376b872a 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sendmail
PORTVERSION= 8.17.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= ftp://ftp.sendmail.org/pub/sendmail/
DISTNAME= ${PORTNAME}.${PORTVERSION}
diff --git a/mail/sendmail/files/patch-zsasl2 b/mail/sendmail/files/patch-zsasl2
new file mode 100644
index 000000000000..2701fc3499cd
--- /dev/null
+++ b/mail/sendmail/files/patch-zsasl2
@@ -0,0 +1,21 @@
+--- sendmail/sendmail.h.orig 2022-04-19 21:07:42 UTC
++++ sendmail/sendmail.h
+@@ -760,7 +760,7 @@ extern bool filesys_free __P((long));
+ # define SASL_IS_AUTH 2 /* authenticated */
+
+ /* SASL options */
+-# define SASL_AUTH_AUTH 0x1000 /* use auth= only if authenticated */
++# define SASL_AUTH_AUTH 0x10000 /* use auth= only if authenticated */
+ # if SASL >= 20101
+ # define SASL_SEC_MASK SASL_SEC_MAXIMUM /* mask for SASL_SEC_* values: sasl.h */
+ # else /* SASL >= 20101 */
+@@ -775,6 +775,9 @@ extern bool filesys_free __P((long));
+ # endif /* SASL_SEC_NOPLAINTEXT & SASL_SEC_MASK) == 0 ... */
+ # endif /* SASL >= 20101 */
+ # define MAXOUTLEN 8192 /* length of output buffer, should be 2^n */
++# if (SASL_AUTH_AUTH & SASL_SEC_MASK) != 0
++# ERROR "change SASL_AUTH_AUTH notify sendmail.org!"
++# endif
+
+ /* functions */
+ extern char *intersect __P((char *, char *, SM_RPOOL_T *));