aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2023-06-29 19:31:36 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2023-06-29 19:37:01 +0000
commit062df5cfbca550365987973693677a138a774587 (patch)
treecdd66b8db096b256fd6e911f0faa3c990ee5bb68
parent5ab3f1019c15b138158370eb5bae8db87d98fecd (diff)
downloadports-062df5cfbca550365987973693677a138a774587.tar.gz
ports-062df5cfbca550365987973693677a138a774587.zip
net/packetdrill: Update to 20230625
And take maintainership. PR: 272283 Approved by: kbowling Sponsored by: Netflix
-rw-r--r--net/packetdrill/Makefile18
-rw-r--r--net/packetdrill/distinfo6
-rw-r--r--net/packetdrill/files/Makefile3
-rw-r--r--net/packetdrill/files/Makefile.inc10
-rw-r--r--net/packetdrill/files/Makefile.libpd28
-rw-r--r--net/packetdrill/files/Makefile.packetdrill3
6 files changed, 13 insertions, 55 deletions
diff --git a/net/packetdrill/Makefile b/net/packetdrill/Makefile
index df35fe7836d2..60b543a119b4 100644
--- a/net/packetdrill/Makefile
+++ b/net/packetdrill/Makefile
@@ -1,8 +1,8 @@
PORTNAME= packetdrill
-PORTVERSION= 0.0.2022032401
+PORTVERSION= 0.0.2023062500
CATEGORIES= net
-MAINTAINER= kbowling@FreeBSD.org
+MAINTAINER= olivier@FreeBSD.org
COMMENT= Network stack testing tool
WWW= https://github.com/freebsd-net/packetdrill
@@ -11,7 +11,7 @@ LICENSE= GPLv2
USES= bison python:run uidfix
USE_GITHUB= yes
GH_ACCOUNT= freebsd-net
-GH_TAGNAME= 9152ae0
+GH_TAGNAME= aebdc35
WRKSRC_SUBDIR= gtests/net/packetdrill
PLIST_FILES= bin/${PORTNAME}
PORTDATA= packetdrill.el packetdrill.vim
@@ -23,12 +23,14 @@ OPTIONS_DEFINE= DOCS EXAMPLES
# XXX Static libraries with PIE are currently unsupported.
MAKE_ARGS+= WITHOUT_PIE=true
+# 'MD5_Init' is deprecated on OpenSSL 3
+CFLAGS+= -Wno-deprecated
+
pre-build:
- ${INSTALL_DATA} ${FILESDIR}/Makefile ${FILESDIR}/Makefile.inc ${WRKSRC}
-.for F in libpd packetdrill
- ${MKDIR} ${WRKSRC}/${F}
- ${INSTALL_DATA} ${FILESDIR}/Makefile.${F} ${WRKSRC}/${F}/Makefile
-.endfor
+ cd ${WRKSRC} && ${LN} Makefile.FreeBSD Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
post-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/net/packetdrill/distinfo b/net/packetdrill/distinfo
index e4881101b258..715bafa0d238 100644
--- a/net/packetdrill/distinfo
+++ b/net/packetdrill/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1648156980
-SHA256 (freebsd-net-packetdrill-0.0.2022032401-9152ae0_GH0.tar.gz) = a2adf619c1ce82e88e469f8daffad4470c4f9fad5c262209bea9df8bfbb1e659
-SIZE (freebsd-net-packetdrill-0.0.2022032401-9152ae0_GH0.tar.gz) = 350573
+TIMESTAMP = 1688051642
+SHA256 (freebsd-net-packetdrill-0.0.2023062500-aebdc35_GH0.tar.gz) = c1f0fa965d345aa6aa3ab81bdd224dddea90ac0bc1fa6458e12af23e48e62d2c
+SIZE (freebsd-net-packetdrill-0.0.2023062500-aebdc35_GH0.tar.gz) = 364128
diff --git a/net/packetdrill/files/Makefile b/net/packetdrill/files/Makefile
deleted file mode 100644
index 95c6ab788859..000000000000
--- a/net/packetdrill/files/Makefile
+++ /dev/null
@@ -1,3 +0,0 @@
-SUBDIR= libpd packetdrill
-
-.include <bsd.subdir.mk>
diff --git a/net/packetdrill/files/Makefile.inc b/net/packetdrill/files/Makefile.inc
deleted file mode 100644
index 943dc478fd6d..000000000000
--- a/net/packetdrill/files/Makefile.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-PREFIX?= /usr/local
-BINDIR?= ${PREFIX}/bin
-
-MAN=
-
-.PATH: ${.CURDIR}/..
-
-CFLAGS+= -I${.CURDIR}/.. -I${.CURDIR}
-LDADD= ${.CURDIR}/../libpd/libpd.a -lprocstat -lutil \
- -lkvm -lelf -lpthread -lpcap
diff --git a/net/packetdrill/files/Makefile.libpd b/net/packetdrill/files/Makefile.libpd
deleted file mode 100644
index 6ab562117780..000000000000
--- a/net/packetdrill/files/Makefile.libpd
+++ /dev/null
@@ -1,28 +0,0 @@
-LIB= pd
-SRCS= checksum.c code.c config.c hash.c hash_map.c ip_address.c \
- ip_prefix.c netdev.c net_utils.c packet.c \
- packet_socket_linux.c packet_socket_pcap.c packet_checksum.c \
- packet_parser.c packet_to_string.c symbols_linux.c \
- symbols_freebsd.c symbols_openbsd.c symbols_netbsd.c \
- gre_packet.c icmp_packet.c ip_packet.c sctp_packet.c \
- tcp_packet.c udp_packet.c udplite_packet.c mpls_packet.c \
- run.c run_command.c run_packet.c run_system_call.c script.c \
- socket.c system.c sctp_chunk_to_string.c sctp_iterator.c \
- tcp_options.c tcp_options_iterator.c tcp_options_to_string.c \
- logging.c types.c lexer.c parser.c fmemopen.c \
- open_memstream.c link_layer.c wire_conn.c wire_protocol.c \
- wire_client.c wire_client_netdev.c wire_server.c \
- wire_server_netdev.c
-
-.PATH: ${.CURDIR}/..
-
-parser.c: parser.y
- bison --output=${.TARGET} --defines=parser.h --report=state ${.IMPSRC}
-
-lexer.c: parser.c
-
-CLEANFILES= parser.h parser.c parser.output lexer.c
-
-install:
-
-.include <bsd.lib.mk>
diff --git a/net/packetdrill/files/Makefile.packetdrill b/net/packetdrill/files/Makefile.packetdrill
deleted file mode 100644
index 5b737137c6a5..000000000000
--- a/net/packetdrill/files/Makefile.packetdrill
+++ /dev/null
@@ -1,3 +0,0 @@
-PROG= packetdrill
-
-.include <bsd.prog.mk>