aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 21:41:37 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 21:42:46 +0000
commit063fe7a48e3c782129e474b804566ed1484ab9da (patch)
treebb8c9b54b2a4fa051ba6545623a090e4f19887a6
parent2f038fd050b7f3003049c0fdd4c6251523e4b25a (diff)
downloadports-063fe7a48e3c782129e474b804566ed1484ab9da.tar.gz
ports-063fe7a48e3c782129e474b804566ed1484ab9da.zip
www/p5-CGI-SpeedyCGI: Fix build with llvm16
- Replace deprecated @exec/@unexec with @postexec/@postunexec Sponsored by: The FreeBSD Foundation
-rw-r--r--www/p5-CGI-SpeedyCGI/Makefile6
-rw-r--r--www/p5-CGI-SpeedyCGI/pkg-plist4
2 files changed, 8 insertions, 2 deletions
diff --git a/www/p5-CGI-SpeedyCGI/Makefile b/www/p5-CGI-SpeedyCGI/Makefile
index b0302a218d73..30c9f3d0d221 100644
--- a/www/p5-CGI-SpeedyCGI/Makefile
+++ b/www/p5-CGI-SpeedyCGI/Makefile
@@ -23,6 +23,12 @@ OPTIONS_SUB= yes
APACHE_USES= apache
APACHE_CONFIGURE_ENV_OFF= WITHOUT_APACHE=yes
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/__inline__//g' \
${WRKSRC}/src/speedy_inc.h
diff --git a/www/p5-CGI-SpeedyCGI/pkg-plist b/www/p5-CGI-SpeedyCGI/pkg-plist
index 78972b3fea5b..319060ba8904 100644
--- a/www/p5-CGI-SpeedyCGI/pkg-plist
+++ b/www/p5-CGI-SpeedyCGI/pkg-plist
@@ -4,5 +4,5 @@ bin/speedy_dump
bin/speedy_suidperl
%%SITE_PERL%%/CGI/SpeedyCGI.pm
%%APACHE%%%%APACHEMODDIR%%/mod_speedycgi.so
-%%APACHE%%@exec %D/sbin/apxs -e -a -n speedycgi %D/%F
-%%APACHE%%@unexec %D/sbin/apxs -e -A -n speedycgi %D/%F
+%%APACHE%%@postexec %D/sbin/apxs -e -a -n speedycgi %D/%F
+%%APACHE%%@postunexec %D/sbin/apxs -e -A -n speedycgi %D/%F