aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2023-11-15 17:14:37 +0000
committerMathieu Arnold <mat@FreeBSD.org>2023-11-15 17:38:29 +0000
commit064028917d02d66074c0c7c6c2d434f11425765c (patch)
tree61c9b1b3b7acaba32bbbba0169876da82d87dce6
parent0640288688a7789b45ea3f458f69c0b83fb7d19c (diff)
downloadports-064028917d02d66074c0c7c6c2d434.tar.gz
ports-064028917d02d66074c0c7c6c2d434.zip
dns/bind918: update to 9.18.20
(cherry picked from commit f0ec7cae3774c244c6836d63d9b2233e8cb15000)
-rw-r--r--dns/bind918/Makefile13
-rw-r--r--dns/bind918/distinfo6
-rw-r--r--dns/bind918/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind918/pkg-plist14
4 files changed, 22 insertions, 25 deletions
diff --git a/dns/bind918/Makefile b/dns/bind918/Makefile
index 2c459d0ecf7c..fb451e1cc4d0 100644
--- a/dns/bind918/Makefile
+++ b/dns/bind918/Makefile
@@ -1,7 +1,7 @@
# pkg-help formatted with fmt 59 63
PORTNAME= bind
-PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
+DISTVERSION= 9.18.20
.if defined(BIND_TOOLS_SLAVE)
# dns/bind-tools here
PORTREVISION= 0
@@ -10,13 +10,12 @@ PORTREVISION= 0
PORTREVISION= 0
.endif
CATEGORIES= dns net
-MASTER_SITES= ISC/bind9/${ISCVERSION}
+MASTER_SITES= ISC/bind9/${DISTVERSION}
.if defined(BIND_TOOLS_SLAVE)
PKGNAMESUFFIX= -tools
.else
PKGNAMESUFFIX= 918
.endif
-DISTNAME= ${PORTNAME}-${ISCVERSION}
MAINTAINER= mat@FreeBSD.org
WWW= https://www.isc.org/bind/
@@ -43,13 +42,11 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
.endif
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:xz
-# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.18.19
CPE_VENDOR= isc
-CPE_VERSION= ${ISCVERSION:C/-.*//}
-.if ${ISCVERSION:M*-*}
-CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
+CPE_VERSION= ${DISTVERSION:C/-.*//}
+.if ${DISTVERSION:M*-*}
+CPE_UPDATE= ${DISTVERSION:C/.*-//:tl}
.endif
GNU_CONFIGURE= yes
diff --git a/dns/bind918/distinfo b/dns/bind918/distinfo
index fe4d19de71fe..d44536bee7b8 100644
--- a/dns/bind918/distinfo
+++ b/dns/bind918/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1695220312
-SHA256 (bind-9.18.19.tar.xz) = 115e09c05439bebade1d272eda08fa88eb3b60129edef690588c87a4d27612cc
-SIZE (bind-9.18.19.tar.xz) = 5508464
+TIMESTAMP = 1700066291
+SHA256 (bind-9.18.20.tar.xz) = 4b891ebf58d3f2a7ac3dd2682990f528a3448eaa1c992ddc5c141b8587a98ec5
+SIZE (bind-9.18.20.tar.xz) = 5506368
diff --git a/dns/bind918/files/extrapatch-bind-min-override-ttl b/dns/bind918/files/extrapatch-bind-min-override-ttl
index a9c1504f7e7a..6bd113a99594 100644
--- a/dns/bind918/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind918/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2023-09-11 08:51:08 UTC
+--- bin/named/config.c.orig 2023-11-09 12:44:11 UTC
+++ bin/named/config.c
@@ -184,6 +184,7 @@ options {\n\
notify-source *;\n\
@@ -10,7 +10,7 @@ Add the override-cache-ttl feature.
parental-source *;\n\
parental-source-v6 *;\n\
provide-ixfr true;\n\
---- bin/named/server.c.orig 2023-09-11 08:51:08 UTC
+--- bin/named/server.c.orig 2023-11-09 12:44:11 UTC
+++ bin/named/server.c
@@ -4571,6 +4571,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- doc/arm/reference.rst.orig 2023-09-11 08:51:09 UTC
+--- doc/arm/reference.rst.orig 2023-11-09 12:44:11 UTC
+++ doc/arm/reference.rst
@@ -4338,6 +4338,10 @@ Tuning
cannot exceed 7 days and is silently truncated to 7 days if set to a
@@ -37,7 +37,7 @@ Add the override-cache-ttl feature.
.. namedconf:statement:: max-cache-ttl
:tags: server
:short: Specifies the maximum time (in seconds) that the server caches ordinary (positive) answers.
---- lib/dns/include/dns/view.h.orig 2023-09-11 08:51:09 UTC
+--- lib/dns/include/dns/view.h.orig 2023-11-09 12:44:12 UTC
+++ lib/dns/include/dns/view.h
@@ -157,6 +157,7 @@ struct dns_view {
bool requestnsid;
@@ -47,9 +47,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2023-09-11 08:51:09 UTC
+--- lib/dns/resolver.c.orig 2023-11-09 12:44:12 UTC
+++ lib/dns/resolver.c
-@@ -6250,6 +6250,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
+@@ -6252,6 +6252,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
/*
@@ -62,7 +62,7 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2023-09-11 08:51:09 UTC
+--- lib/isccfg/namedconf.c.orig 2023-11-09 12:44:12 UTC
+++ lib/isccfg/namedconf.c
@@ -2100,6 +2100,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
diff --git a/dns/bind918/pkg-plist b/dns/bind918/pkg-plist
index 32a8bc1bdfa0..83e48f9a2b45 100644
--- a/dns/bind918/pkg-plist
+++ b/dns/bind918/pkg-plist
@@ -241,19 +241,19 @@ include/ns/xfrout.h
lib/bind/filter-a.so
lib/bind/filter-aaaa.so
lib/libbind9.so
-lib/libbind9-9.18.19.so
+lib/libbind9-9.18.20.so
lib/libdns.so
-lib/libdns-9.18.19.so
+lib/libdns-9.18.20.so
lib/libirs.so
-lib/libirs-9.18.19.so
+lib/libirs-9.18.20.so
lib/libisc.so
-lib/libisc-9.18.19.so
+lib/libisc-9.18.20.so
lib/libisccc.so
-lib/libisccc-9.18.19.so
+lib/libisccc-9.18.20.so
lib/libisccfg.so
-lib/libisccfg-9.18.19.so
+lib/libisccfg-9.18.20.so
lib/libns.so
-lib/libns-9.18.19.so
+lib/libns-9.18.20.so
@comment man/man1/arpaname.1.gz
@comment man/man1/delv.1.gz
@comment man/man1/dig.1.gz