aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-06-02 16:27:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-06-02 16:27:50 +0000
commit0660a669e5125deaf21f939b6d40ce5ce667485e (patch)
tree78d23b5f7ee1570c66c4ac23d9100d3304e9cd3d
parenta14a87bc6fb53ecd35fdd451ceffd61ac3ea8864 (diff)
downloadports-0660a669e5125deaf21f939b6d40ce5ce667485e.tar.gz
ports-0660a669e5125deaf21f939b6d40ce5ce667485e.zip
uWSGI is a fast (pure C), self-healing, developer-friendly WSGI server,
aimed for professional python webapps deployment and development. Over time it has evolved in a complete stack for networked/clustered python applications, implementing message/object passing, RPC and process management. WWW: http://projects.unbit.it/uwsgi/ PR: ports/146865 Submitted by: Daniel Gerzo <danger at FreeBSD.org>
Notes
Notes: svn path=/head/; revision=255555
-rw-r--r--www/Makefile1
-rw-r--r--www/uwsgi/Makefile32
-rw-r--r--www/uwsgi/distinfo3
-rw-r--r--www/uwsgi/pkg-descr7
4 files changed, 43 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bd70ae29e746..9e9e8a88f709 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1743,6 +1743,7 @@
SUBDIR += udmsearch
SUBDIR += ump
SUBDIR += usermanager
+ SUBDIR += uwsgi
SUBDIR += uzbl
SUBDIR += validator
SUBDIR += varnish
diff --git a/www/uwsgi/Makefile b/www/uwsgi/Makefile
new file mode 100644
index 000000000000..59fef9bb4e42
--- /dev/null
+++ b/www/uwsgi/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: uwsgi
+# Date created: 23 May 2010
+# Whom: Daniel Gerzo <danger@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uwsgi
+PORTVERSION= 0.9.5.1
+CATEGORIES= www python
+MASTER_SITES= http://projects.unbit.it/downloads/
+
+MAINTAINER= danger@FreeBSD.org
+COMMENT= Developer-friendly WSGI server which uses uwsgi protocol
+
+MAKE_JOBS_SAFE= yes
+
+USE_GNOME= libxml2
+USE_PYTHON= 2.4+
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/uwsgi/distinfo b/www/uwsgi/distinfo
new file mode 100644
index 000000000000..a9afa1a53ec5
--- /dev/null
+++ b/www/uwsgi/distinfo
@@ -0,0 +1,3 @@
+MD5 (uwsgi-0.9.5.1.tar.gz) = cc032e0f0e987a848606d3bc90241756
+SHA256 (uwsgi-0.9.5.1.tar.gz) = 2efab0f2cea90261c3ee56026618955c15ac7467ba6f0dbfe9e685da28204bc1
+SIZE (uwsgi-0.9.5.1.tar.gz) = 120134
diff --git a/www/uwsgi/pkg-descr b/www/uwsgi/pkg-descr
new file mode 100644
index 000000000000..68c4f95632d6
--- /dev/null
+++ b/www/uwsgi/pkg-descr
@@ -0,0 +1,7 @@
+uWSGI is a fast (pure C), self-healing, developer-friendly WSGI server,
+aimed for professional python webapps deployment and development. Over
+time it has evolved in a complete stack for networked/clustered python
+applications, implementing message/object passing, RPC and process
+management.
+
+WWW: http://projects.unbit.it/uwsgi/