aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-08-21 16:27:51 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-08-21 16:27:51 +0000
commit06834a2d071395861e29b2caaf4a4810faba03cd (patch)
tree8cab704dacd7b7766d1f11aeab53441d71f5cdaa
parent1c4eb6b78e73ed3fc02c45d252bb6b4aceefd187 (diff)
downloadports-06834a2d071395861e29b2caaf4a4810faba03cd.tar.gz
ports-06834a2d071395861e29b2caaf4a4810faba03cd.zip
Pluxml is a tiny tool to generate blog based on php and xml.
Feature: * Rss * categories * can be used as a photoblog WWW: http://pluxml.org/ PR: ports/115382 Submitted by: Philippe Audeoud <jadawin at tuxaco.net>
Notes
Notes: svn path=/head/; revision=198072
-rw-r--r--french/Makefile1
-rw-r--r--french/pluxml-devel/Makefile39
-rw-r--r--french/pluxml-devel/distinfo3
-rw-r--r--french/pluxml-devel/files/pkg-deinstall.in12
-rw-r--r--french/pluxml-devel/files/pkg-message.in16
-rw-r--r--french/pluxml-devel/pkg-descr7
-rw-r--r--french/pluxml-devel/pkg-plist43
-rw-r--r--french/pluxml/Makefile39
-rw-r--r--french/pluxml/distinfo3
-rw-r--r--french/pluxml/files/pkg-deinstall.in12
-rw-r--r--french/pluxml/files/pkg-message.in16
-rw-r--r--french/pluxml/pkg-descr7
-rw-r--r--french/pluxml/pkg-plist43
13 files changed, 241 insertions, 0 deletions
diff --git a/french/Makefile b/french/Makefile
index 04eb09f16c99..10677cf08228 100644
--- a/french/Makefile
+++ b/french/Makefile
@@ -24,6 +24,7 @@
SUBDIR += mozilla-flp
SUBDIR += php_doc
SUBDIR += plgrenouille
+ SUBDIR += pluxml
SUBDIR += staroffice52
SUBDIR += verbiste
SUBDIR += xtel
diff --git a/french/pluxml-devel/Makefile b/french/pluxml-devel/Makefile
new file mode 100644
index 000000000000..9dfecdd01caa
--- /dev/null
+++ b/french/pluxml-devel/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pluxml
+# Date created: 7 August 2007
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+# $FreeBSD$
+
+PORTNAME= pluxml
+PORTVERSION= 0.3.1
+CATEGORIES= french www
+MASTER_SITES= http://pluxml.org/download/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= Small weblog in php and xml
+
+USE_PHP= xml pcre
+WANT_PHP_WEB= yes
+
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+NO_BUILD= yes
+
+SUB_FILES= pkg-message pkg-deinstall
+SUB_LIST= WWWDIR=${WWWDIR} \
+ PORTNAME=${PORTNAME}
+PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+.for data in images pluxml version
+ ${CP} -R ${WRKSRC}/${data} ${WWWDIR}
+.endfor
+ ${CP} ${WRKSRC}/*.php ${WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/french/pluxml-devel/distinfo b/french/pluxml-devel/distinfo
new file mode 100644
index 000000000000..38f00c7eb016
--- /dev/null
+++ b/french/pluxml-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (pluxml0.3.1.tar.gz) = 2c8194441d1de4944c3713daa11e0613
+SHA256 (pluxml0.3.1.tar.gz) = 4eae6ccde259d4df41cb1430ac76e7dcc327bb90a9e20db0a79c368f496dea6d
+SIZE (pluxml0.3.1.tar.gz) = 27903
diff --git a/french/pluxml-devel/files/pkg-deinstall.in b/french/pluxml-devel/files/pkg-deinstall.in
new file mode 100644
index 000000000000..71b2f0262980
--- /dev/null
+++ b/french/pluxml-devel/files/pkg-deinstall.in
@@ -0,0 +1,12 @@
+#! /bin/sh
+# $FreeBSD$
+#
+
+PATH=/bin:/usr/bin:/usr/sbin
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+if [ -d %%WWWDIR%% ]; then
+ echo "===> You may delete '%%WWWDIR%%' if you want to really delete your blog."
+fi
diff --git a/french/pluxml-devel/files/pkg-message.in b/french/pluxml-devel/files/pkg-message.in
new file mode 100644
index 000000000000..3620ae43ea9e
--- /dev/null
+++ b/french/pluxml-devel/files/pkg-message.in
@@ -0,0 +1,16 @@
+---------------------------------------------------------------------------
+
+Browse http://your.host.tld/%%PORTNAME%%/install.php to configure your blog
+
+---------------------------------------------------------------------------
+To make pluxml available through your web site, I suggest
+that you add something like the following to httpd.conf:
+
+ Alias /pluxml/ "%%WWWDIR%%/"
+
+ <Directory "%%WWWDIR%%/">
+ Options none
+ AllowOverride Limit
+ Order Deny,Allow
+ Allow from all
+ </Directory>
diff --git a/french/pluxml-devel/pkg-descr b/french/pluxml-devel/pkg-descr
new file mode 100644
index 000000000000..4cd1874aff29
--- /dev/null
+++ b/french/pluxml-devel/pkg-descr
@@ -0,0 +1,7 @@
+Pluxml is a tiny tool to generate blog based on php and xml.
+Feature:
+* Rss
+* categories
+* can be used as a photoblog
+
+WWW: http://pluxml.org/
diff --git a/french/pluxml-devel/pkg-plist b/french/pluxml-devel/pkg-plist
new file mode 100644
index 000000000000..114b4d993547
--- /dev/null
+++ b/french/pluxml-devel/pkg-plist
@@ -0,0 +1,43 @@
+%%WWWDIR%%/version
+%%WWWDIR%%/index.php
+%%WWWDIR%%/install.php
+%%WWWDIR%%/maj.php
+%%WWWDIR%%/images/index.htm
+%%WWWDIR%%/pluxml/atom.php
+%%WWWDIR%%/pluxml/rss.php
+%%WWWDIR%%/pluxml/admin/admin.css
+%%WWWDIR%%/pluxml/admin/articles.php
+%%WWWDIR%%/pluxml/admin/auth.php
+%%WWWDIR%%/pluxml/admin/categories.php
+%%WWWDIR%%/pluxml/admin/foot.php
+%%WWWDIR%%/pluxml/admin/images.php
+%%WWWDIR%%/pluxml/admin/include.php
+%%WWWDIR%%/pluxml/admin/index.php
+%%WWWDIR%%/pluxml/admin/informations.php
+%%WWWDIR%%/pluxml/admin/parametres.php
+%%WWWDIR%%/pluxml/admin/top.php
+%%WWWDIR%%/pluxml/admin/img/icon.png
+%%WWWDIR%%/pluxml/admin/img/puce.png
+%%WWWDIR%%/pluxml/lib/class.admin.php
+%%WWWDIR%%/pluxml/lib/class.pluxml.php
+%%WWWDIR%%/pluxml/lib/functions.js
+%%WWWDIR%%/pluxml/lib/functions.php
+%%WWWDIR%%/pluxml/lib/lib.util.php
+%%WWWDIR%%/pluxml/templates/default/style.css
+%%WWWDIR%%/pluxml/templates/default/template.php
+%%WWWDIR%%/pluxml/templates/default/img/fond.jpg
+%%WWWDIR%%/pluxml/templates/default/img/header.jpg
+%%WWWDIR%%/pluxml/xml/.htaccess
+%%WWWDIR%%/pluxml/conf/.htaccess
+@dirrm %%WWWDIR%%/pluxml/templates/default/img
+@dirrm %%WWWDIR%%/pluxml/templates/default
+@dirrm %%WWWDIR%%/pluxml/templates
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/pluxml/lib
+@dirrm %%WWWDIR%%/pluxml/admin/img
+@dirrm %%WWWDIR%%/pluxml/admin
+@dirrmtry %%WWWDIR%%/pluxml/xml
+@dirrmtry %%WWWDIR%%/pluxml/conf
+@dirrmtry %%WWWDIR%%/pluxml
+@dirrmtry %%WWWDIR%%
+@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%
diff --git a/french/pluxml/Makefile b/french/pluxml/Makefile
new file mode 100644
index 000000000000..9dfecdd01caa
--- /dev/null
+++ b/french/pluxml/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pluxml
+# Date created: 7 August 2007
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+# $FreeBSD$
+
+PORTNAME= pluxml
+PORTVERSION= 0.3.1
+CATEGORIES= french www
+MASTER_SITES= http://pluxml.org/download/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= Small weblog in php and xml
+
+USE_PHP= xml pcre
+WANT_PHP_WEB= yes
+
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+NO_BUILD= yes
+
+SUB_FILES= pkg-message pkg-deinstall
+SUB_LIST= WWWDIR=${WWWDIR} \
+ PORTNAME=${PORTNAME}
+PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+
+do-install:
+ ${MKDIR} ${WWWDIR}
+.for data in images pluxml version
+ ${CP} -R ${WRKSRC}/${data} ${WWWDIR}
+.endfor
+ ${CP} ${WRKSRC}/*.php ${WWWDIR}
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/french/pluxml/distinfo b/french/pluxml/distinfo
new file mode 100644
index 000000000000..38f00c7eb016
--- /dev/null
+++ b/french/pluxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (pluxml0.3.1.tar.gz) = 2c8194441d1de4944c3713daa11e0613
+SHA256 (pluxml0.3.1.tar.gz) = 4eae6ccde259d4df41cb1430ac76e7dcc327bb90a9e20db0a79c368f496dea6d
+SIZE (pluxml0.3.1.tar.gz) = 27903
diff --git a/french/pluxml/files/pkg-deinstall.in b/french/pluxml/files/pkg-deinstall.in
new file mode 100644
index 000000000000..71b2f0262980
--- /dev/null
+++ b/french/pluxml/files/pkg-deinstall.in
@@ -0,0 +1,12 @@
+#! /bin/sh
+# $FreeBSD$
+#
+
+PATH=/bin:/usr/bin:/usr/sbin
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+if [ -d %%WWWDIR%% ]; then
+ echo "===> You may delete '%%WWWDIR%%' if you want to really delete your blog."
+fi
diff --git a/french/pluxml/files/pkg-message.in b/french/pluxml/files/pkg-message.in
new file mode 100644
index 000000000000..3620ae43ea9e
--- /dev/null
+++ b/french/pluxml/files/pkg-message.in
@@ -0,0 +1,16 @@
+---------------------------------------------------------------------------
+
+Browse http://your.host.tld/%%PORTNAME%%/install.php to configure your blog
+
+---------------------------------------------------------------------------
+To make pluxml available through your web site, I suggest
+that you add something like the following to httpd.conf:
+
+ Alias /pluxml/ "%%WWWDIR%%/"
+
+ <Directory "%%WWWDIR%%/">
+ Options none
+ AllowOverride Limit
+ Order Deny,Allow
+ Allow from all
+ </Directory>
diff --git a/french/pluxml/pkg-descr b/french/pluxml/pkg-descr
new file mode 100644
index 000000000000..4cd1874aff29
--- /dev/null
+++ b/french/pluxml/pkg-descr
@@ -0,0 +1,7 @@
+Pluxml is a tiny tool to generate blog based on php and xml.
+Feature:
+* Rss
+* categories
+* can be used as a photoblog
+
+WWW: http://pluxml.org/
diff --git a/french/pluxml/pkg-plist b/french/pluxml/pkg-plist
new file mode 100644
index 000000000000..114b4d993547
--- /dev/null
+++ b/french/pluxml/pkg-plist
@@ -0,0 +1,43 @@
+%%WWWDIR%%/version
+%%WWWDIR%%/index.php
+%%WWWDIR%%/install.php
+%%WWWDIR%%/maj.php
+%%WWWDIR%%/images/index.htm
+%%WWWDIR%%/pluxml/atom.php
+%%WWWDIR%%/pluxml/rss.php
+%%WWWDIR%%/pluxml/admin/admin.css
+%%WWWDIR%%/pluxml/admin/articles.php
+%%WWWDIR%%/pluxml/admin/auth.php
+%%WWWDIR%%/pluxml/admin/categories.php
+%%WWWDIR%%/pluxml/admin/foot.php
+%%WWWDIR%%/pluxml/admin/images.php
+%%WWWDIR%%/pluxml/admin/include.php
+%%WWWDIR%%/pluxml/admin/index.php
+%%WWWDIR%%/pluxml/admin/informations.php
+%%WWWDIR%%/pluxml/admin/parametres.php
+%%WWWDIR%%/pluxml/admin/top.php
+%%WWWDIR%%/pluxml/admin/img/icon.png
+%%WWWDIR%%/pluxml/admin/img/puce.png
+%%WWWDIR%%/pluxml/lib/class.admin.php
+%%WWWDIR%%/pluxml/lib/class.pluxml.php
+%%WWWDIR%%/pluxml/lib/functions.js
+%%WWWDIR%%/pluxml/lib/functions.php
+%%WWWDIR%%/pluxml/lib/lib.util.php
+%%WWWDIR%%/pluxml/templates/default/style.css
+%%WWWDIR%%/pluxml/templates/default/template.php
+%%WWWDIR%%/pluxml/templates/default/img/fond.jpg
+%%WWWDIR%%/pluxml/templates/default/img/header.jpg
+%%WWWDIR%%/pluxml/xml/.htaccess
+%%WWWDIR%%/pluxml/conf/.htaccess
+@dirrm %%WWWDIR%%/pluxml/templates/default/img
+@dirrm %%WWWDIR%%/pluxml/templates/default
+@dirrm %%WWWDIR%%/pluxml/templates
+@dirrm %%WWWDIR%%/images
+@dirrm %%WWWDIR%%/pluxml/lib
+@dirrm %%WWWDIR%%/pluxml/admin/img
+@dirrm %%WWWDIR%%/pluxml/admin
+@dirrmtry %%WWWDIR%%/pluxml/xml
+@dirrmtry %%WWWDIR%%/pluxml/conf
+@dirrmtry %%WWWDIR%%/pluxml
+@dirrmtry %%WWWDIR%%
+@exec chown -R %%WWWOWN%%:%%WWWGRP%% %D/%%WWWDIR%%