aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-11-23 22:01:00 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-11-23 22:02:58 +0000
commit06be0d5391f475771145a7a9d68d34b0ad5a9b85 (patch)
tree3d3920ca064dcee943db3f90683b057a802390a3
parentcea1194ae5f2bfa34526d25e6908fcd9d1698c0c (diff)
downloadports-06be0d5391f475771145a7a9d68d34b0ad5a9b85.tar.gz
ports-06be0d5391f475771145a7a9d68d34b0ad5a9b85.zip
lang/php81: Update version 8.1.25=>8.1.26
- Switch to system pcre - Switch to libenchant-2 for enchant extension - Remove OPTIONS for using the deprecated cclient library for imap extension - Switch to libedit for readline extension Changelog: https://www.php.net/ChangeLog-8.php#8.1.26
-rw-r--r--lang/php81/Makefile39
-rw-r--r--lang/php81/distinfo6
-rw-r--r--lang/php81/pkg-plist7
3 files changed, 20 insertions, 32 deletions
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 361646278fb6..fa756234327b 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -1,5 +1,5 @@
PORTNAME= php81
-DISTVERSION= 8.1.25
+DISTVERSION= 8.1.26
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${DISTVERSION}
@@ -10,13 +10,14 @@ WWW= https://www.php.net/
LICENSE= PHP301
-USES+= compiler:c11 cpe gnome pkgconfig tar:xz
+USES+= compiler:c11 cpe gnome localbase pkgconfig tar:xz
CPE_PRODUCT= php
PHP_VER= 81
CONFLICTS_INSTALL?= php[0-9][0-9]${PKGNAMESUFFIX}
.if !defined(PKGNAMESUFFIX)
+BUILD_DEPENDS= re2c>0:devel/re2c
LIB_DEPENDS= libargon2.so:security/libargon2 \
libpcre2-8.so:devel/pcre2
@@ -27,19 +28,17 @@ CONFIGURE_ARGS+= --disable-all \
--with-layout=GNU \
--with-libxml \
--with-openssl \
- --with-password-argon2=${LOCALBASE}
-DESTDIRNAME= INSTALL_ROOT
+ --with-password-argon2=${LOCALBASE} \
+ --with-external-pcre=${LOCALBASE}
USES+= autoreconf:build ssl
USE_GNOME= libxml2
-CPPFLAGS= -I${LOCALBASE}/include
-
-LDFLAGS= -L${OPENSSLLIB} -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
# PR230207 Allow relocations against read-only segments (override lld default)
-LDFLAGS_i386= -Wl,-z,notext
+LDFLAGS_i386+= -Wl,-z,notext
-OPTIONS_DEFINE+= CGI CLI DEBUG DTRACE EMBED FPM IPV6 LINKTHR \
+OPTIONS_DEFINE+= CGI CLI DEBUG DTRACE EMBED FPM IPV6 LINKTHR \
MYSQLND PHPDBG ZTS
OPTIONS_DEFAULT= CGI CLI DTRACE EMBED FPM LINKTHR MYSQLND
OPTIONS_EXCLUDE_DragonFly= DTRACE
@@ -88,6 +87,8 @@ PHPDBG_VARS= PHP_SAPI+=phpdbg
ZTS_CONFIGURE_ON= --enable-zts
ZTS_CONFIGURE_ENV= pthreads_working="yes"
+DESTDIRNAME= INSTALL_ROOT
+
.if defined(PKGNAMEPREFIX)
USES+= apache
PLIST= ${PKGDIR}/pkg-plist.mod
@@ -142,7 +143,7 @@ test: build
@(cd ${WRKSRC} && ${MAKE} test)
post-install:
- @${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
+ ${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
post-install-CGI-on:
@@ -228,8 +229,8 @@ DB4_CONFIGURE_ON= --with-db4=${LOCALBASE}
DB4_USES= bdb
DB4_VARS= WITH_BDB_HIGHEST=yes
FLATFILE_CONFIGURE_ON= --disable-flatfile
-GDBM_CONFIGURE_ARGS= --with-gdbm=${LOCALBASE}
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
+GDBM_CONFIGURE_ARGS= --with-gdbm=${LOCALBASE}
INIFILE_CONFIGURE_OFF= --disable-inifile
LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
LMDB_CONFIGURE_ARGS= --with-lmdb=${LOCALBASE}
@@ -249,7 +250,7 @@ USE_GNOME= libxml2
.endif
.if ${PHP_MODNAME} == "enchant"
-LIB_DEPENDS+= libenchant.so:textproc/enchant
+LIB_DEPENDS+= libenchant-2.so:textproc/enchant2
CONFIGURE_ARGS+= --with-enchant=${LOCALBASE}
USES+= pkgconfig
.endif
@@ -329,13 +330,7 @@ USES+= iconv:translit
.if ${PHP_MODNAME} == "imap"
PHP_MOD_PRIO= 30
-OPTIONS_RADIO= CLIENT
-OPTIONS_RADIO_CLIENT= CCLIENT PANDA
-OPTIONS_DEFAULT= PANDA
-CCLIENT_DESC= Uses the original but unmaintained cclient
-PANDA_DESC= Uses the forked panda-cclient instead of the original cclient
-PANDA_LIB_DEPENDS= libc-client.so.2010:mail/panda-cclient
-PANDA_LIB_DEPENDS_OFF= libc-client4.so.9:mail/cclient
+LIB_DEPENDS+= libc-client.so.2010:mail/panda-cclient
CONFIGURE_ARGS+= --with-imap-ssl=${OPENSSLBASE} \
--with-imap=${LOCALBASE}
@@ -442,10 +437,10 @@ OPTIONS_DEFAULT= MYSQLND
MYSQLND_DESC= Use MySQL Native Driver
+MYSQLND_CONFIGURE_ON= --with-pdo-mysql=mysqlnd
MYSQLND_CONFIGURE_OFF= --with-pdo-mysql=${LOCALBASE} \
--with-zlib-dir=/usr
MYSQLND_USES_OFF= mysql
-MYSQLND_CONFIGURE_ON= --with-pdo-mysql=mysqlnd
USE_PHP= pdo:build
.endif
@@ -486,8 +481,8 @@ CONFIGURE_ARGS+= --with-pspell=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "readline"
-CONFIGURE_ARGS+= --with-readline=/usr
-USES+= readline
+CONFIGURE_ARGS+= --with-libedit
+USES+= libedit
.endif
.if ${PHP_MODNAME} == "session"
diff --git a/lang/php81/distinfo b/lang/php81/distinfo
index c59ba91e78d7..950c878c78d3 100644
--- a/lang/php81/distinfo
+++ b/lang/php81/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1698409952
-SHA256 (php-8.1.25.tar.xz) = 66fdba064aa119b1463a7969571d42f4642690275d8605ab5149bcc5107e2484
-SIZE (php-8.1.25.tar.xz) = 11888112
+TIMESTAMP = 1700690550
+SHA256 (php-8.1.26.tar.xz) = 17f87133596449327451ad4b8d9911bfaea59ff5109f3a6f2bb679f967a8ea0f
+SIZE (php-8.1.26.tar.xz) = 11809448
diff --git a/lang/php81/pkg-plist b/lang/php81/pkg-plist
index 84b4ca61ea36..94ef315fa1a8 100644
--- a/lang/php81/pkg-plist
+++ b/lang/php81/pkg-plist
@@ -162,13 +162,6 @@ include/php/ext/libxml/php_libxml.h
%%MYSQLND%%include/php/ext/mysqlnd/mysqlnd_vio.h
%%MYSQLND%%include/php/ext/mysqlnd/mysqlnd_wireprotocol.h
%%MYSQLND%%include/php/ext/mysqlnd/php_mysqlnd.h
-include/php/ext/pcre/pcre2lib/config.h
-include/php/ext/pcre/pcre2lib/pcre2.h
-include/php/ext/pcre/pcre2lib/pcre2_internal.h
-include/php/ext/pcre/pcre2lib/pcre2_intmodedep.h
-include/php/ext/pcre/pcre2lib/pcre2_jit_neon_inc.h
-include/php/ext/pcre/pcre2lib/pcre2_jit_simd_inc.h
-include/php/ext/pcre/pcre2lib/pcre2_ucp.h
include/php/ext/pcre/php_pcre.h
include/php/ext/spl/php_spl.h
include/php/ext/spl/spl_array.h