aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:01:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:11:08 +0000
commit0715e3f21e3792dfdec2336cd8f44280ce3922e0 (patch)
tree1d8cb03f19108ec4346df5b95d725e8a14e6282d
parent8a51e63ac6cf1437d0b6375a1fa8d22f9161da36 (diff)
downloadports-0715e3f21e3792dfdec2336cd8f44280ce3922e0.tar.gz
ports-0715e3f21e3792dfdec2336cd8f44280ce3922e0.zip
devel/nuitka: Update to 2.0
- Convert to USE_PYTHON=pep517 Changes: https://github.com/Nuitka/Nuitka/blob/develop/Changelog.rst
-rw-r--r--devel/nuitka/Makefile6
-rw-r--r--devel/nuitka/distinfo6
-rw-r--r--devel/nuitka/files/patch-setup.py11
3 files changed, 18 insertions, 5 deletions
diff --git a/devel/nuitka/Makefile b/devel/nuitka/Makefile
index da5765e4eb85..2a3cb70b4518 100644
--- a/devel/nuitka/Makefile
+++ b/devel/nuitka/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nuitka
-PORTVERSION= 1.9
+PORTVERSION= 2.0
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
@@ -13,11 +13,13 @@ WWW= https://nuitka.net/ \
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=42:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ordered-set>=4.1.0:devel/py-ordered-set@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zstandard>=0.15:archivers/py-zstandard@${PY_FLAVOR}
USES= cpe python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/devel/nuitka/distinfo b/devel/nuitka/distinfo
index 0129ece1c039..db8bc366867a 100644
--- a/devel/nuitka/distinfo
+++ b/devel/nuitka/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1700760690
-SHA256 (Nuitka-1.9.tar.gz) = 8ef3bac402de4fd48df7c4530f8484d0bf19539cb4a980f36642c7d3c08b3b33
-SIZE (Nuitka-1.9.tar.gz) = 3907890
+TIMESTAMP = 1708450722
+SHA256 (Nuitka-2.0.tar.gz) = 471c61d19d09fec7b652d5603f95f18fc76122156a9ef5c40730ca8f5a80a25d
+SIZE (Nuitka-2.0.tar.gz) = 3964226
diff --git a/devel/nuitka/files/patch-setup.py b/devel/nuitka/files/patch-setup.py
new file mode 100644
index 000000000000..d3e076bc3067
--- /dev/null
+++ b/devel/nuitka/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2023-12-31 10:57:00 UTC
++++ setup.py
+@@ -374,7 +374,7 @@ if sys.platform == "darwin" and sys.version_info < (3,
+ install_requires.append("orderedset >= 2.0.3")
+
+ setup(
+- name="Nuitka",
++ name="nuitka",
+ license="Apache License, Version 2.0",
+ version=version,
+ long_description=long_description,