aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2021-06-04 10:15:57 +0000
committerLewis Cook <lcook@FreeBSD.org>2021-06-04 10:24:14 +0000
commit073656063b7ce50ecfb7851bdc02966eb54d783b (patch)
tree01b3a0c954553f9f6c5ea64e2c0fa79d97d3e045
parent96419941bedafbce043e6a9a834f575812187652 (diff)
downloadports-073656063b7ce50ecfb7851bdc02966eb54d783b.tar.gz
ports-073656063b7ce50ecfb7851bdc02966eb54d783b.zip
sysutils/zrepl: pidfile should be world-readable
PR: 255981 (cherry picked from commit 2a866a1b4fd0e2ce6d07904c920f98e7d994bd59)
-rw-r--r--sysutils/zrepl/Makefile1
-rw-r--r--sysutils/zrepl/files/zrepl.in4
2 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/zrepl/Makefile b/sysutils/zrepl/Makefile
index 38ded8f82ac8..124fc8f2eff4 100644
--- a/sysutils/zrepl/Makefile
+++ b/sysutils/zrepl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= zrepl
DISTVERSIONPREFIX= v
DISTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= sysutils
MAINTAINER= lcook@FreeBSD.org
diff --git a/sysutils/zrepl/files/zrepl.in b/sysutils/zrepl/files/zrepl.in
index 128cd406f652..57a4d48ce0b6 100644
--- a/sysutils/zrepl/files/zrepl.in
+++ b/sysutils/zrepl/files/zrepl.in
@@ -54,8 +54,8 @@ extra_commands="configtest"
zrepl_precmd()
{
if [ ! -d "/var/run/zrepl/stdinserver" ]; then
- install -d -g ${zrepl_group} -o ${zrepl_user} -m 0700 -- "/var/run/zrepl";
- install -d -g ${zrepl_group} -o ${zrepl_user} -m 0700 -- "/var/run/zrepl/stdinserver";
+ install -d -g ${zrepl_group} -o ${zrepl_user} -m 0755 -- "/var/run/zrepl";
+ install -d -g ${zrepl_group} -o ${zrepl_user} -m 0755 -- "/var/run/zrepl/stdinserver";
fi
if [ ! -e "${pidfile}" ]; then