aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2022-01-08 15:20:36 +0000
committerChris Rees <crees@FreeBSD.org>2022-01-13 17:26:37 +0000
commit0741b694b726e50bd2709197b58980b47e4b28e2 (patch)
treed6b11961c96db95d37db31c41ed77ee2014497fe
parentbee5c815503c3ed99c89f2489a61a980b90f2b8e (diff)
downloadports-0741b694b726e50bd2709197b58980b47e4b28e2.tar.gz
ports-0741b694b726e50bd2709197b58980b47e4b28e2.zip
audio/baresip: Fix build (and INDEX) with GSTREAMER option
PR: ports/256971
-rw-r--r--audio/baresip/Makefile6
-rw-r--r--audio/baresip/Makefile.depends2
2 files changed, 4 insertions, 4 deletions
diff --git a/audio/baresip/Makefile b/audio/baresip/Makefile
index 30f8f07fdd83..5b217a00e579 100644
--- a/audio/baresip/Makefile
+++ b/audio/baresip/Makefile
@@ -63,9 +63,9 @@ $o_DESC= ${o:C,^(.).*,\1,}${o:C,^.,,:tl} module
.include "${.CURDIR}/Makefile.depends"
-# Port calls it GST, standard OPTION is GSTREAMER
-.if ${PORT_OPTIONS:MGSTREAMER}
-PORT_OPTIONS+= GST
+# Port used to call it GST, if it's set in make.conf let's not annoy people
+.if ${PORT_OPTIONS:MGST}
+PORT_OPTIONS+= GSTREAMER
.endif
# Port calls it PULSE, standard OPTION is PULSEAUDIO
diff --git a/audio/baresip/Makefile.depends b/audio/baresip/Makefile.depends
index 0ef05c78b25f..55efe72ad5d7 100644
--- a/audio/baresip/Makefile.depends
+++ b/audio/baresip/Makefile.depends
@@ -8,7 +8,7 @@ G711_DEPEND= ${LOCALBASE}/include/spandsp/g711.h:comms/spandsp
G722_DEPEND= ${LOCALBASE}/include/spandsp/g722.h:comms/spandsp
G722_1_DEPEND= # nonexistent
GSM_DEPEND= ${LOCALBASE}/include/gsm.h:audio/gsm
-GST_DEPEND= gst-launch:multimedia/gstreamer
+GSTREAMER_DEPEND= gst-launch-1.0:multimedia/gstreamer1
ILBC_DEPEND= ${LOCALBASE}/include/ilbc/iLBC_define.h:net/ilbc
L16_DEPEND=
OPUS_DEPEND= ${LOCALBASE}/include/opus/opus.h:audio/opus