aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-24 00:54:27 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-24 00:54:27 +0000
commit078a5d741919a7be140ed626640199bd6c7a79da (patch)
tree0d919a1ce11fac7fd748079c13c1a9da60557a06
parentcb1ddcee2a169f766bbbfe1bc405e2467efe2565 (diff)
downloadports-078a5d741919a7be140ed626640199bd6c7a79da.tar.gz
ports-078a5d741919a7be140ed626640199bd6c7a79da.zip
Workaround the following problem on aarch64 by setting LLD_UNSAFE=yes:
cc: error: invalid linker name in argument '-fuse-ld=bfd' Neither emaste nor I can figure out exactly where the offending stanza is coming in. It will take someone with more knowledge of gmake debug flags, and possibly the src build infrastructure, to figure it out. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=473169
-rw-r--r--databases/hashtypes/Makefile1
-rw-r--r--databases/ip4r/Makefile1
-rw-r--r--databases/pg_dirtyread/Makefile1
-rw-r--r--databases/pg_partman/Makefile1
-rw-r--r--databases/pg_qualstats/Makefile1
-rw-r--r--databases/pg_reorg/Makefile1
-rw-r--r--databases/pg_repack/Makefile1
-rw-r--r--databases/pg_stat_kcache/Makefile7
-rw-r--r--databases/pgespresso/Makefile1
-rw-r--r--databases/pglogical/Makefile1
-rw-r--r--databases/pgpool-II-33/Makefile1
-rw-r--r--databases/pgroonga/Makefile1
-rw-r--r--databases/pgsphere/Makefile5
-rw-r--r--databases/pguri/Makefile1
-rw-r--r--databases/pldebugger/Makefile1
-rw-r--r--databases/plpgsql_check/Makefile1
-rw-r--r--databases/postgis20/Makefile1
-rw-r--r--databases/postgis21/Makefile1
-rw-r--r--databases/postgis22/Makefile1
-rw-r--r--databases/postgis23/Makefile1
-rw-r--r--databases/postgis24/Makefile1
-rw-r--r--databases/postgresql-cstore_fdw/Makefile1
-rw-r--r--databases/postgresql-mysql_fdw/Makefile1
-rw-r--r--databases/postgresql-orafce/Makefile1
-rw-r--r--databases/postgresql-plproxy/Makefile1
-rw-r--r--databases/postgresql-repmgr/Makefile1
-rw-r--r--databases/postgresql-tds_fdw/Makefile1
-rw-r--r--databases/postgresql-zhparser/Makefile1
-rw-r--r--databases/skytools/Makefile1
-rw-r--r--databases/tablelog/Makefile1
-rw-r--r--databases/tsearch_extras/Makefile3
31 files changed, 37 insertions, 6 deletions
diff --git a/databases/hashtypes/Makefile b/databases/hashtypes/Makefile
index 5f1112cc8510..dfd2b18b0282 100644
--- a/databases/hashtypes/Makefile
+++ b/databases/hashtypes/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= oss-contrib@dreamindustries.co
COMMENT= Hash data types for PostgreSQL
USES= gmake pgsql zip
+LLD_UNSAFE= yes
MAKE_ARGS= USE_PGXS=1 MODULEDIR=extension
MODULEDIR= ${PREFIX}/share/postgresql/extension
diff --git a/databases/ip4r/Makefile b/databases/ip4r/Makefile
index bcbf5601ba81..b34be60e09ed 100644
--- a/databases/ip4r/Makefile
+++ b/databases/ip4r/Makefile
@@ -15,6 +15,7 @@ OPTIONS_DEFINE= IDXPATCH
IDXPATCH_DESC= Prefer ip4r indexes over seq_scan on large datasets
USES= gmake pgsql
+LLD_UNSAFE= yes
MAKE_ARGS= USE_PGXS=1
diff --git a/databases/pg_dirtyread/Makefile b/databases/pg_dirtyread/Makefile
index 2bc57a48cacc..68cff75c6bc7 100644
--- a/databases/pg_dirtyread/Makefile
+++ b/databases/pg_dirtyread/Makefile
@@ -12,6 +12,7 @@ COMMENT= Read dead but unvacuumed tuples from a PostgreSQL relation
LICENSE= BSD3CLAUSE
USES= gmake pgsql:9.2+
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= ChristophBerg
diff --git a/databases/pg_partman/Makefile b/databases/pg_partman/Makefile
index c6fbdd48faf7..daa1960ebaf6 100644
--- a/databases/pg_partman/Makefile
+++ b/databases/pg_partman/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:databases/py-psycopg2
USES= gmake pgsql:9.4+ python uidfix shebangfix
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= keithf4
diff --git a/databases/pg_qualstats/Makefile b/databases/pg_qualstats/Makefile
index e10cc4bcd760..d06dd8ee2565 100644
--- a/databases/pg_qualstats/Makefile
+++ b/databases/pg_qualstats/Makefile
@@ -14,6 +14,7 @@ USE_GITHUB= yes
GH_ACCOUNT= dalibo
USES= gmake pgsql:9.4+
+LLD_UNSAFE= yes
WANT_PGSQL= server
pre-patch:
diff --git a/databases/pg_reorg/Makefile b/databases/pg_reorg/Makefile
index 97dabff30faf..c068fcf708f7 100644
--- a/databases/pg_reorg/Makefile
+++ b/databases/pg_reorg/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
MAKE_ENV= USE_PGXS=0
USES= gmake pgsql uidfix
+LLD_UNSAFE= yes
WANT_PGSQL_VER= 91+
WANT_PGSQL= server
INSTALL_TARGET= install-strip
diff --git a/databases/pg_repack/Makefile b/databases/pg_repack/Makefile
index 7551a2692300..2358c4c59d0a 100644
--- a/databases/pg_repack/Makefile
+++ b/databases/pg_repack/Makefile
@@ -13,6 +13,7 @@ COMMENT= Reorganize tables in PostgreSQL databases with minimal locks
LICENSE= BSD3CLAUSE
USES= gmake pgsql:9.2+
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= reorg
diff --git a/databases/pg_stat_kcache/Makefile b/databases/pg_stat_kcache/Makefile
index a7d18478f306..b2654dc3b3b8 100644
--- a/databases/pg_stat_kcache/Makefile
+++ b/databases/pg_stat_kcache/Makefile
@@ -11,12 +11,13 @@ COMMENT= Gather statistics about PostgreSQL I/O and CPU usage
LICENSE= PostgreSQL
-USE_GITHUB= yes
-GH_ACCOUNT= dalibo
-
USES= gmake pgsql:9.4+
+LLD_UNSAFE= yes
WANT_PGSQL= server contrib
+USE_GITHUB= yes
+GH_ACCOUNT= dalibo
+
pre-patch:
@${MV} ${BUILD_WRKSRC}/README.rst ${BUILD_WRKSRC}/${PORTNAME}-README.rst
diff --git a/databases/pgespresso/Makefile b/databases/pgespresso/Makefile
index d6186e9ddc34..d12952220435 100644
--- a/databases/pgespresso/Makefile
+++ b/databases/pgespresso/Makefile
@@ -14,6 +14,7 @@ USE_GITHUB= yes
GH_ACCOUNT= 2ndquadrant-it
USES= gmake pgsql:9.2+
+LLD_UNSAFE= yes
WANT_PGSQL= server
PLIST_FILES= lib/postgresql/pgespresso.so \
diff --git a/databases/pglogical/Makefile b/databases/pglogical/Makefile
index a3a8c76cd473..f7fef5b17873 100644
--- a/databases/pglogical/Makefile
+++ b/databases/pglogical/Makefile
@@ -11,6 +11,7 @@ COMMENT= Logical replication system as a PostgreSQL extension
LICENSE= PostgreSQL
USES= gmake pgsql:9.4+
+LLD_UNSAFE= yes
WANT_PGSQL= client server
USE_GITHUB= yes
diff --git a/databases/pgpool-II-33/Makefile b/databases/pgpool-II-33/Makefile
index e3308c341a12..cbc6b030e83a 100644
--- a/databases/pgpool-II-33/Makefile
+++ b/databases/pgpool-II-33/Makefile
@@ -19,6 +19,7 @@ EXPIRATION_DATE= 2018-07-31
RUN_DEPENDS= rsync:net/rsync
USES= gmake libtool perl5 pgsql
+LLD_UNSAFE= yes
WANT_PGSQL= client
USE_PERL5= run
GNU_CONFIGURE= yes
diff --git a/databases/pgroonga/Makefile b/databases/pgroonga/Makefile
index 6464a8cebccb..fd39948ce5c5 100644
--- a/databases/pgroonga/Makefile
+++ b/databases/pgroonga/Makefile
@@ -14,6 +14,7 @@ LICENSE= PostgreSQL
LIB_DEPENDS= libgroonga.so:textproc/groonga
USES= gmake pgsql pkgconfig
+LLD_UNSAFE= yes
SUB_FILES= pkg-message
OPTIONS_DEFINE= MECAB
diff --git a/databases/pgsphere/Makefile b/databases/pgsphere/Makefile
index d33f109c6360..614a7e3813e4 100644
--- a/databases/pgsphere/Makefile
+++ b/databases/pgsphere/Makefile
@@ -13,12 +13,13 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT.pg_sphere
OPTIONS_DEFINE= DOCS
+USES= gmake pgsql
+LLD_UNSAFE= yes
+USE_LDCONFIG= yes
MAKE_ARGS= PG_CONFIG=${LOCALBASE}/bin/pg_config USE_PGXS=1 \
docdir=${DOCSDIR} \
install_bin=/usr/bin/install
TEST_TARGET= installcheck
-USE_LDCONFIG= yes
-USES= gmake pgsql
DATADIR= ${PREFIX}/share/postgresql
DOCSDIR?= ${PREFIX}/share/doc/postgresql
diff --git a/databases/pguri/Makefile b/databases/pguri/Makefile
index 6bc068f98914..8265d3582f81 100644
--- a/databases/pguri/Makefile
+++ b/databases/pguri/Makefile
@@ -12,6 +12,7 @@ BUILD_DEPENDS= uriparser>=0.8.0:net/uriparser
RUN_DEPENDS= uriparser>=0.8.0:net/uriparser
USES= gmake pgsql pkgconfig
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= petere
diff --git a/databases/pldebugger/Makefile b/databases/pldebugger/Makefile
index 0fb27982bf68..674579c06fac 100644
--- a/databases/pldebugger/Makefile
+++ b/databases/pldebugger/Makefile
@@ -13,6 +13,7 @@ COMMENT= PostgreSQL pl/pgsql Debugger API
LICENSE= ART20
USES= gmake pgsql
+LLD_UNSAFE= yes
WANT_PGSQL= server
DOCSDIR= ${PREFIX}/share/doc/postgresql/extension
diff --git a/databases/plpgsql_check/Makefile b/databases/plpgsql_check/Makefile
index 41625e84eb48..0b47a2d1513e 100644
--- a/databases/plpgsql_check/Makefile
+++ b/databases/plpgsql_check/Makefile
@@ -23,6 +23,7 @@ LICENSE_TEXT= If you like it - send a postcard to address: \
LICENSE_PERMS= dist-mirror pkg-mirror dist-sell pkg-sell auto-accept
USES= gmake pgsql:9.2+
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= okbob
diff --git a/databases/postgis20/Makefile b/databases/postgis20/Makefile
index 44bd49cfcf59..8e80a48b2f89 100644
--- a/databases/postgis20/Makefile
+++ b/databases/postgis20/Makefile
@@ -36,6 +36,7 @@ CONFIGURE_ARGS= --with-geosconfig=${LOCALBASE}/bin/geos-config \
${ICONV_CONFIGURE_ARG} ${ICONV_CONFIGURE_BASE}
GNU_CONFIGURE= yes
USES= gmake gnome iconv:wchar_t libtool perl5 pgsql pkgconfig shebangfix
+LLD_UNSAFE= yes
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_PERL5= build
diff --git a/databases/postgis21/Makefile b/databases/postgis21/Makefile
index 1db520b60ca0..366a01221b0f 100644
--- a/databases/postgis21/Makefile
+++ b/databases/postgis21/Makefile
@@ -22,6 +22,7 @@ CONFLICTS_INSTALL= postgis20 postgis22 postgis23 postgis24 postgis
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
USES= gmake iconv:wchar_t libtool:keepla perl5 pgsql pkgconfig shebangfix
+LLD_UNSAFE= yes
SHEBANG_FILES= utils/postgis_restore.pl.in
USE_GNOME= libxml2
USE_LDCONFIG= yes
diff --git a/databases/postgis22/Makefile b/databases/postgis22/Makefile
index 0058843c738a..cfc725218805 100644
--- a/databases/postgis22/Makefile
+++ b/databases/postgis22/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= libproj.so:graphics/proj \
CONFLICTS_INSTALL= postgis20 postgis21 postgis23 postgis24 postgis
USES= gettext gmake iconv:wchar_t libtool:keepla perl5 pgsql pkgconfig shebangfix
+LLD_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
SHEBANG_FILES= extensions/address_standardizer/*.pl raster/test/regress/*.pl \
diff --git a/databases/postgis23/Makefile b/databases/postgis23/Makefile
index 76e4680378a2..14c966751676 100644
--- a/databases/postgis23/Makefile
+++ b/databases/postgis23/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= libproj.so:graphics/proj \
CONFLICTS= postgis20 postgis21 postgis22 postgis24 postgis
USES= gettext gmake iconv:wchar_t libtool:keepla perl5 pgsql pkgconfig shebangfix
+LLD_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
SHEBANG_FILES= extensions/address_standardizer/*.pl raster/test/regress/*.pl \
diff --git a/databases/postgis24/Makefile b/databases/postgis24/Makefile
index 93f507149782..5f25ccb2ca97 100644
--- a/databases/postgis24/Makefile
+++ b/databases/postgis24/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= libproj.so:graphics/proj \
CONFLICTS_INSTALL= postgis20 postgis21 postgis22 postgis23 postgis
USES= gettext gmake iconv:wchar_t libtool:keepla perl5 pgsql pkgconfig shebangfix
+LLD_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ${ICONV_CONFIGURE_BASE}
SHEBANG_FILES= extensions/address_standardizer/*.pl raster/test/regress/*.pl \
diff --git a/databases/postgresql-cstore_fdw/Makefile b/databases/postgresql-cstore_fdw/Makefile
index d62a769be9d4..fd707764207b 100644
--- a/databases/postgresql-cstore_fdw/Makefile
+++ b/databases/postgresql-cstore_fdw/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c
SUB_FILES= pkg-message
USES= gmake pgsql:9.3+
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= citusdata
diff --git a/databases/postgresql-mysql_fdw/Makefile b/databases/postgresql-mysql_fdw/Makefile
index d73fe924bcb3..b4ff0f4edb92 100644
--- a/databases/postgresql-mysql_fdw/Makefile
+++ b/databases/postgresql-mysql_fdw/Makefile
@@ -12,6 +12,7 @@ COMMENT= PostgreSQL foreign data wrapper for MySQL
LICENSE= PostgreSQL
USES= gmake pgsql:9.3+ mysql
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= EnterpriseDB
GH_TAGNAME= c14ee1d
diff --git a/databases/postgresql-orafce/Makefile b/databases/postgresql-orafce/Makefile
index 7a7a6c692a8f..5dbdef412a0c 100644
--- a/databases/postgresql-orafce/Makefile
+++ b/databases/postgresql-orafce/Makefile
@@ -12,6 +12,7 @@ COMMENT= Oracle's compatibility functions and packages for PostgreSQL
LICENSE= PostgreSQL
USES= gmake bison pgsql:9.2+
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_TAGNAME= ffea9cc
diff --git a/databases/postgresql-plproxy/Makefile b/databases/postgresql-plproxy/Makefile
index 15d049ea5dbc..cfd41cc11055 100644
--- a/databases/postgresql-plproxy/Makefile
+++ b/databases/postgresql-plproxy/Makefile
@@ -14,6 +14,7 @@ LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
USES= bison gmake pgsql
+LLD_UNSAFE= yes
USE_GITHUB= yes
post-patch:
diff --git a/databases/postgresql-repmgr/Makefile b/databases/postgresql-repmgr/Makefile
index 714147f14797..49ba57c5d910 100644
--- a/databases/postgresql-repmgr/Makefile
+++ b/databases/postgresql-repmgr/Makefile
@@ -16,6 +16,7 @@ RUN_DEPENDS= rsync:net/rsync
GNU_CONFIGURE= yes
USES+= gettext gmake pgsql:9.3+
+LLD_UNSAFE= yes
USE_RC_SUBR= repmgrd
WANT_PGSQL= server
MAKE_ENV= USE_PGXS=1
diff --git a/databases/postgresql-tds_fdw/Makefile b/databases/postgresql-tds_fdw/Makefile
index 67387738f728..dfd093d51660 100644
--- a/databases/postgresql-tds_fdw/Makefile
+++ b/databases/postgresql-tds_fdw/Makefile
@@ -15,6 +15,7 @@ LICENSE= PostgreSQL
LIB_DEPENDS= libsybdb.so:databases/freetds
USES= gmake pgsql:9.2+
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= tds-fdw
diff --git a/databases/postgresql-zhparser/Makefile b/databases/postgresql-zhparser/Makefile
index 62780e14b325..23202bd00e91 100644
--- a/databases/postgresql-zhparser/Makefile
+++ b/databases/postgresql-zhparser/Makefile
@@ -15,6 +15,7 @@ LICENSE= PostgreSQL
LIB_DEPENDS= libscws.so:textproc/scws
USES= gmake pgsql:9.2+
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= amutu
diff --git a/databases/skytools/Makefile b/databases/skytools/Makefile
index 844b3b9ed7a3..75010f198eba 100644
--- a/databases/skytools/Makefile
+++ b/databases/skytools/Makefile
@@ -12,6 +12,7 @@ COMMENT= PostgreSQL tools from Skype: walshipping, queueing, replication
GNU_CONFIGURE= yes
USES= gmake python:2.7 shebangfix pgsql
+LLD_UNSAFE= yes
SHEBANG_FILES= setup_pkgloader.py setup_skytools.py \
scripts/catsql.py scripts/data_maintainer.py \
diff --git a/databases/tablelog/Makefile b/databases/tablelog/Makefile
index b5d265b289f1..f785072e813e 100644
--- a/databases/tablelog/Makefile
+++ b/databases/tablelog/Makefile
@@ -15,6 +15,7 @@ LICENSE= PostgreSQL
WRKSRC= ${WRKDIR}/table_log-${DISTVERSION}
USES= gmake pgsql
+LLD_UNSAFE= yes
MAKE_ARGS= USE_PGXS=1
OPTIONS_DEFINE= DOCS
diff --git a/databases/tsearch_extras/Makefile b/databases/tsearch_extras/Makefile
index 81e3edb1b119..4a299334e7cf 100644
--- a/databases/tsearch_extras/Makefile
+++ b/databases/tsearch_extras/Makefile
@@ -10,9 +10,10 @@ COMMENT= Functions for getting lower-level data about full text search
LICENSE= PostgreSQL
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+USES= gmake pgsql
+LLD_UNSAFE= yes
USE_GITHUB= yes
GH_ACCOUNT= zulip
-USES= gmake pgsql
PLIST_FILES= lib/postgresql/tsearch_extras.so \
share/postgresql/extension/tsearch_extras--1.0.sql \