aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2024-06-26 15:46:42 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2024-06-26 15:47:51 +0000
commit0792294cb90ce950b6a0d58ddc2f3cd95111b0d6 (patch)
treebea3f2416b62b4e218ba3283a1552223cb8ea029
parent2a69c2b0db5829a96cff21b394e261c49b0372b6 (diff)
downloadports-0792294cb90ce950b6a0d58ddc2f3cd95111b0d6.tar.gz
ports-0792294cb90ce950b6a0d58ddc2f3cd95111b0d6.zip
www/{*chromium,iridium}: fix audio backend selection logic
PR: 279998
-rw-r--r--www/chromium/Makefile1
-rw-r--r--www/chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc9
-rw-r--r--www/iridium/Makefile1
-rw-r--r--www/iridium/files/patch-media_audio_sndio_audio__manager__sndio.cc9
-rw-r--r--www/ungoogled-chromium/Makefile1
-rw-r--r--www/ungoogled-chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc9
6 files changed, 18 insertions, 12 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index ef0fed481be6..72c0c5de909a 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,5 +1,6 @@
PORTNAME= chromium
PORTVERSION= 126.0.6478.126
+PORTREVISION= 1
PULSEMV= 16
PULSEV= ${PULSEMV}.1
CATEGORIES= www wayland
diff --git a/www/chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc b/www/chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc
index 8f42931fbf28..e0c9e4d79afa 100644
--- a/www/chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc
+++ b/www/chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc
@@ -1,6 +1,6 @@
---- media/audio/sndio/audio_manager_sndio.cc.orig 2024-05-21 18:07:39 UTC
+--- media/audio/sndio/audio_manager_sndio.cc.orig 2024-06-26 15:43:18 UTC
+++ media/audio/sndio/audio_manager_sndio.cc
-@@ -0,0 +1,240 @@
+@@ -0,0 +1,241 @@
+// Copyright (c) 2012 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
@@ -207,7 +207,8 @@
+#if defined(USE_PULSEAUDIO)
+ pa_threaded_mainloop* pa_mainloop = nullptr;
+ pa_context* pa_context = nullptr;
-+ if (audio_backend != "sndio" && pulse::InitPulse(&pa_mainloop, &pa_context)) {
++ if ((audio_backend != "sndio" && audio_backend != "alsa") &&
++ pulse::InitPulse(&pa_mainloop, &pa_context)) {
+ return std::make_unique<AudioManagerPulse>(
+ std::move(audio_thread), audio_log_factory, pa_mainloop, pa_context);
+ } else if (audio_backend == "auto") {
@@ -217,7 +218,7 @@
+#endif
+
+#if defined(USE_SNDIO)
-+ if (audio_backend != "pulse") {
++ if (audio_backend != "pulse" && audio_backend != "alsa") {
+ return std::make_unique<AudioManagerSndio>(std::move(audio_thread),
+ audio_log_factory);
+ } else if (audio_backend == "auto") {
diff --git a/www/iridium/Makefile b/www/iridium/Makefile
index 72df93a08cfb..734c72bfcdef 100644
--- a/www/iridium/Makefile
+++ b/www/iridium/Makefile
@@ -1,5 +1,6 @@
PORTNAME= iridium
PORTVERSION= 2024.06.126.2
+PORTREVISION= 1
PULSEMV= 16
PULSEV= ${PULSEMV}.1
CATEGORIES= www wayland
diff --git a/www/iridium/files/patch-media_audio_sndio_audio__manager__sndio.cc b/www/iridium/files/patch-media_audio_sndio_audio__manager__sndio.cc
index e8a0321b47e1..e0c9e4d79afa 100644
--- a/www/iridium/files/patch-media_audio_sndio_audio__manager__sndio.cc
+++ b/www/iridium/files/patch-media_audio_sndio_audio__manager__sndio.cc
@@ -1,6 +1,6 @@
---- media/audio/sndio/audio_manager_sndio.cc.orig 2024-06-25 12:08:48 UTC
+--- media/audio/sndio/audio_manager_sndio.cc.orig 2024-06-26 15:43:18 UTC
+++ media/audio/sndio/audio_manager_sndio.cc
-@@ -0,0 +1,240 @@
+@@ -0,0 +1,241 @@
+// Copyright (c) 2012 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
@@ -207,7 +207,8 @@
+#if defined(USE_PULSEAUDIO)
+ pa_threaded_mainloop* pa_mainloop = nullptr;
+ pa_context* pa_context = nullptr;
-+ if (audio_backend != "sndio" && pulse::InitPulse(&pa_mainloop, &pa_context)) {
++ if ((audio_backend != "sndio" && audio_backend != "alsa") &&
++ pulse::InitPulse(&pa_mainloop, &pa_context)) {
+ return std::make_unique<AudioManagerPulse>(
+ std::move(audio_thread), audio_log_factory, pa_mainloop, pa_context);
+ } else if (audio_backend == "auto") {
@@ -217,7 +218,7 @@
+#endif
+
+#if defined(USE_SNDIO)
-+ if (audio_backend != "pulse") {
++ if (audio_backend != "pulse" && audio_backend != "alsa") {
+ return std::make_unique<AudioManagerSndio>(std::move(audio_thread),
+ audio_log_factory);
+ } else if (audio_backend == "auto") {
diff --git a/www/ungoogled-chromium/Makefile b/www/ungoogled-chromium/Makefile
index 3141f403a14b..caeddd0ee6ec 100644
--- a/www/ungoogled-chromium/Makefile
+++ b/www/ungoogled-chromium/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ungoogled-chromium
PORTVERSION= 126.0.6478.126
+PORTREVISION= 1
UGVERSION= ${DISTVERSION}-1
PULSEMV= 16
PULSEV= ${PULSEMV}.1
diff --git a/www/ungoogled-chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc b/www/ungoogled-chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc
index 35e8ab80fb77..e0c9e4d79afa 100644
--- a/www/ungoogled-chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc
+++ b/www/ungoogled-chromium/files/patch-media_audio_sndio_audio__manager__sndio.cc
@@ -1,6 +1,6 @@
---- media/audio/sndio/audio_manager_sndio.cc.orig 2024-05-23 20:04:36 UTC
+--- media/audio/sndio/audio_manager_sndio.cc.orig 2024-06-26 15:43:18 UTC
+++ media/audio/sndio/audio_manager_sndio.cc
-@@ -0,0 +1,240 @@
+@@ -0,0 +1,241 @@
+// Copyright (c) 2012 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
@@ -207,7 +207,8 @@
+#if defined(USE_PULSEAUDIO)
+ pa_threaded_mainloop* pa_mainloop = nullptr;
+ pa_context* pa_context = nullptr;
-+ if (audio_backend != "sndio" && pulse::InitPulse(&pa_mainloop, &pa_context)) {
++ if ((audio_backend != "sndio" && audio_backend != "alsa") &&
++ pulse::InitPulse(&pa_mainloop, &pa_context)) {
+ return std::make_unique<AudioManagerPulse>(
+ std::move(audio_thread), audio_log_factory, pa_mainloop, pa_context);
+ } else if (audio_backend == "auto") {
@@ -217,7 +218,7 @@
+#endif
+
+#if defined(USE_SNDIO)
-+ if (audio_backend != "pulse") {
++ if (audio_backend != "pulse" && audio_backend != "alsa") {
+ return std::make_unique<AudioManagerSndio>(std::move(audio_thread),
+ audio_log_factory);
+ } else if (audio_backend == "auto") {