aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2016-12-11 15:14:01 +0000
committerThierry Thomas <thierry@FreeBSD.org>2016-12-11 15:14:01 +0000
commit07d6fce4df6945b0a0ea8048499e69018810ba35 (patch)
tree3ef76b77851a4c07e99491a239aaaa1d84ea08ce
parentb43a2972fd410cfd50ad60c7cb37606c43ecf3da (diff)
downloadports-07d6fce4df6945b0a0ea8048499e69018810ba35.tar.gz
ports-07d6fce4df6945b0a0ea8048499e69018810ba35.zip
Fix a transliteration with a patch from Mike Fabian.
It has been approved by upstream, but a chunk is missing. See https://lists.nongnu.org/archive/html/m17n-list/2015-08/msg00001.html and https://bugzilla.redhat.com/show_bug.cgi?id=1256244 PR: 214968 Approved by: maintainer Obtained from: Mike Fabian
Notes
Notes: svn path=/head/; revision=428351
-rw-r--r--devel/m17n-lib/Makefile7
-rw-r--r--devel/m17n-lib/files/patch-src_input.c20
2 files changed, 25 insertions, 2 deletions
diff --git a/devel/m17n-lib/Makefile b/devel/m17n-lib/Makefile
index 065015a6676b..f4e2423db1c8 100644
--- a/devel/m17n-lib/Makefile
+++ b/devel/m17n-lib/Makefile
@@ -3,13 +3,16 @@
PORTNAME= m17n-lib
PORTVERSION= 1.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel textproc
MASTER_SITES= SAVANNAH/m17n
MAINTAINER= nikola.lecic@anthesphoria.net
COMMENT= Library for the multilingual text handling
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= bison:devel/bison \
m17n-db>=1.6.4:devel/m17n-db
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
@@ -22,7 +25,7 @@ RUN_DEPENDS= m17n-db>=1.6.4:devel/m17n-db
MAKE_JOBS_UNSAFE= yes
USES= autoreconf gettext-tools libtool pathfix pkgconfig
-USE_XORG= ice sm x11 xaw xft xt
+USE_XORG= ice sm x11 xaw xft xmu xrender xt
USE_GNOME= libxml2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/devel/m17n-lib/files/patch-src_input.c b/devel/m17n-lib/files/patch-src_input.c
new file mode 100644
index 000000000000..3bfb5c45c94a
--- /dev/null
+++ b/devel/m17n-lib/files/patch-src_input.c
@@ -0,0 +1,20 @@
+--- src/input.c.orig 2014-11-28 22:57:48 UTC
++++ src/input.c
+@@ -4264,7 +4264,7 @@ filter (MInputContext *ic, MSymbol key,
+ if (ic_info->commit_key_head > 0)
+ {
+ memmove (ic_info->keys, ic_info->keys + ic_info->commit_key_head,
+- sizeof (int) * (ic_info->used - ic_info->commit_key_head));
++ sizeof (MSymbol *) * (ic_info->used - ic_info->commit_key_head));
+ ic_info->used -= ic_info->commit_key_head;
+ ic_info->key_head -= ic_info->commit_key_head;
+ ic_info->state_key_head -= ic_info->commit_key_head;
+@@ -4278,7 +4278,7 @@ filter (MInputContext *ic, MSymbol key,
+ if (ic_info->key_head > 0)
+ {
+ memmove (ic_info->keys, ic_info->keys + ic_info->key_head,
+- sizeof (int) * (ic_info->used - ic_info->key_head));
++ sizeof (MSymbol *) * (ic_info->used - ic_info->key_head));
+ ic_info->used -= ic_info->key_head;
+ ic_info->key_head = ic_info->state_key_head
+ = ic_info->commit_key_head = 0;