aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-09-12 15:55:43 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-09-12 18:28:55 +0000
commit07e74c3a4e8e1780a1eecb6ad1d67bfd9ac751f3 (patch)
treea2ec892c170d75967af7d50a98b93b6d2cbbdf40
parent8b75ddb00d40e820387ca079ca6316b323b94706 (diff)
downloadports-07e74c3a4e8e1780a1eecb6ad1d67bfd9ac751f3.tar.gz
ports-07e74c3a4e8e1780a1eecb6ad1d67bfd9ac751f3.zip
x11/kf5-plasma-framework: remove unnecessary dependency on QtScript
-rw-r--r--x11/kf5-plasma-framework/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/x11/kf5-plasma-framework/Makefile b/x11/kf5-plasma-framework/Makefile
index 07ac04a7a909..098903c55d2c 100644
--- a/x11/kf5-plasma-framework/Makefile
+++ b/x11/kf5-plasma-framework/Makefile
@@ -1,20 +1,22 @@
PORTNAME= plasma-framework
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
COMMENT= KF5 plugin based UI runtime used to write user interfaces
-USES= cmake compiler:c++11-lib gettext gl kde:5 pkgconfig qt:5 tar:xz xorg
+USES= cmake compiler:c++11-lib gettext gl kde:5 pkgconfig qt:5 \
+ tar:xz xorg
USE_GL= egl gl
-USE_KDE= activities archive auth codecs completion config \
- configwidgets coreaddons dbusaddons doctools:build globalaccel \
- guiaddons i18n iconthemes jobwidgets kirigami2 kio package \
- notifications service solid wayland windowsystem xmlgui kdeclarative \
- widgetsaddons \
- ecm:build
-USE_QT= buildtools:build concurrent core dbus declarative gui network qmake:build \
- script sql svg widgets x11extras xml
+USE_KDE= activities archive auth codecs completion config configwidgets \
+ coreaddons dbusaddons globalaccel guiaddons i18n iconthemes \
+ jobwidgets kdeclarative kio kirigami2 notifications package \
+ service solid wayland widgetsaddons windowsystem xmlgui \
+ doctools:build ecm:build
+USE_QT= concurrent core dbus declarative gui network sql svg widgets \
+ x11extras xml \
+ buildtools:build qmake:build
USE_XORG= ice sm x11 xcb xext xrandr
.include <bsd.port.mk>