aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2024-04-13 13:43:59 +0000
committerThomas Zander <riggs@FreeBSD.org>2024-04-13 14:33:17 +0000
commit08696f8f5e82b2844e598b6478592a48a25d6458 (patch)
treea0c896aa6a6b445f7616bafbd487e5a0f173ceb3
parent0dc0ed07e249f33a3f0bb63e6d05de0f3e67a368 (diff)
downloadports-08696f8f5e82b2844e598b6478592a48a25d6458.tar.gz
ports-08696f8f5e82b2844e598b6478592a48a25d6458.zip
net/traefik: Update to upstream release 2.11.2
Details: - Bugfix release, see https://github.com/traefik/traefik/releases/tag/v2.11.2 - Defaults around certain timeouts has changed. If those are important for your use case, please review them, see: https://doc.traefik.io/traefik/migration/v2/#v2112 MFH: 2024Q2 (cherry picked from commit d866fc74bce5f709bd9232d6f915072198199e1b)
-rw-r--r--net/traefik/Makefile3
-rw-r--r--net/traefik/distinfo6
-rw-r--r--net/traefik/files/patch-pkg_collector_hydratation_hydration.go11
3 files changed, 4 insertions, 16 deletions
diff --git a/net/traefik/Makefile b/net/traefik/Makefile
index 47147406091c..dfb5d8a685f9 100644
--- a/net/traefik/Makefile
+++ b/net/traefik/Makefile
@@ -1,6 +1,5 @@
PORTNAME= traefik
-PORTVERSION= 2.11.0
-PORTREVISION= 1
+PORTVERSION= 2.11.2
CATEGORIES= net
MASTER_SITES= LOCAL/riggs/${PORTNAME}
diff --git a/net/traefik/distinfo b/net/traefik/distinfo
index 765aff718661..f14b71a70e23 100644
--- a/net/traefik/distinfo
+++ b/net/traefik/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1708775341
-SHA256 (traefik-2.11.0.tar.xz) = 1ee0dbf384cca92fe29b13697bd7d7a4e471c2ec79a8242100d95c7ad524ada4
-SIZE (traefik-2.11.0.tar.xz) = 21482284
+TIMESTAMP = 1712998209
+SHA256 (traefik-2.11.2.tar.xz) = 001d59c2540d22b37b690cadb49ea67bec7980b04e9947413e3133041fd3b7ec
+SIZE (traefik-2.11.2.tar.xz) = 21235432
diff --git a/net/traefik/files/patch-pkg_collector_hydratation_hydration.go b/net/traefik/files/patch-pkg_collector_hydratation_hydration.go
deleted file mode 100644
index 599cf8be55c8..000000000000
--- a/net/traefik/files/patch-pkg_collector_hydratation_hydration.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- pkg/collector/hydratation/hydration.go.orig 2024-02-12 15:25:23 UTC
-+++ pkg/collector/hydratation/hydration.go
-@@ -56,7 +56,7 @@ func fill(field reflect.Value) error {
- case reflect.Int64:
- switch field.Type() {
- case reflect.TypeOf(types.Duration(time.Second)):
-- setTyped(field, int64(defaultNumber*int(time.Second)))
-+ setTyped(field, int64(defaultNumber)*int64(time.Second))
- default:
- setTyped(field, int64(defaultNumber))
- }