aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2024-01-16 13:59:42 +0000
committerRenato Botelho <garga@FreeBSD.org>2024-01-16 14:02:42 +0000
commit08a9c4db98f7c91176d8ccfffc00ff225f6ab3b0 (patch)
treeded4625cdd1ac7f27764d31570d1089a9df6ed8f
parentd1130853502e640a65ba841a7d7ee3bcb4e0c7a4 (diff)
downloadports-08a9c4db98f7c91176d8ccfffc00ff225f6ab3b0.tar.gz
ports-08a9c4db98f7c91176d8ccfffc00ff225f6ab3b0.zip
*/*: Restore GNU_CONFIGURE on my ports
I made a mistake and changed these ports to HAS_CONFIGURE when working on MANPREFIX sanitization. Restore proper macro usage and set GNU_CONFIGURE_MANPREFIX properly to keep manpages installed under ${PREFIX}/share. Reported by: danfe Sponsored by: Rubicon Communications, LLC ("Netgate")
-rw-r--r--archivers/arj/Makefile5
-rw-r--r--archivers/sharutils/Makefile5
-rw-r--r--converters/tnef/Makefile5
-rw-r--r--devel/libslang2/Makefile5
-rw-r--r--editors/jed/Makefile5
-rw-r--r--mail/wmbiff/Makefile5
-rw-r--r--net-mgmt/iprange/Makefile5
-rw-r--r--net/libpcap/Makefile5
-rw-r--r--net/rinetd/Makefile5
-rw-r--r--net/tcpdump/Makefile5
-rw-r--r--security/sudo/Makefile5
-rw-r--r--shells/scponly/Makefile5
-rw-r--r--www/sarg/Makefile5
-rw-r--r--www/squidclamav/Makefile5
14 files changed, 42 insertions, 28 deletions
diff --git a/archivers/arj/Makefile b/archivers/arj/Makefile
index 4cc97a4858e8..b3ac16992d56 100644
--- a/archivers/arj/Makefile
+++ b/archivers/arj/Makefile
@@ -1,6 +1,6 @@
PORTNAME= arj
PORTVERSION= 3.10.22
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= archivers
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/2.78_3.10%20build%2022:source \
DEBIAN_POOL:patch
@@ -30,7 +30,8 @@ PATCH_STRIP= -p1
PORTSCOUT= skipv:3.10g
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
AUTORECONF_WRKSRC= ${WRKSRC}/gnu
CONFIGURE_WRKSRC= ${WRKSRC}/gnu
MAKEFILE= GNUmakefile
diff --git a/archivers/sharutils/Makefile b/archivers/sharutils/Makefile
index eca8d7e1ba9d..7f74cc1d8736 100644
--- a/archivers/sharutils/Makefile
+++ b/archivers/sharutils/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sharutils
PORTVERSION= 4.15.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= archivers
MASTER_SITES= GNU
@@ -14,7 +14,8 @@ USES= charsetfix cpe perl5 tar:xz
OPTIONS_DEFINE= NLS
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --program-prefix=g --disable-uucode
INSTALL_TARGET= install install-man
INFO= sharutils
diff --git a/converters/tnef/Makefile b/converters/tnef/Makefile
index 01746be02957..3d33187873e4 100644
--- a/converters/tnef/Makefile
+++ b/converters/tnef/Makefile
@@ -1,6 +1,6 @@
PORTNAME= tnef
PORTVERSION= 1.4.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/
@@ -16,7 +16,8 @@ CPE_VENDOR= tnef_project
OPTIONS_DEFINE= DOCS
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
PORTDOCS= AUTHORS BUGS NEWS README.md THANKS
PLIST_FILES= bin/tnef \
diff --git a/devel/libslang2/Makefile b/devel/libslang2/Makefile
index 840c02c1749a..e4c6f7cc72da 100644
--- a/devel/libslang2/Makefile
+++ b/devel/libslang2/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libslang2
PORTVERSION= 2.3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.jedsoft.org/releases/slang/
DISTNAME= slang-${PORTVERSION}
@@ -14,7 +14,8 @@ LICENSE= GPLv2
USES= ncurses tar:bzip2
USE_LDCONFIG= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= all static
diff --git a/editors/jed/Makefile b/editors/jed/Makefile
index c1d85a8bc144..561e97c961fd 100644
--- a/editors/jed/Makefile
+++ b/editors/jed/Makefile
@@ -1,6 +1,6 @@
PORTNAME= jed
DISTVERSION= 0.99-19
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= editors
MASTER_SITES= ftp://space.mit.edu/pub/davis/jed/v${PORTVERSION:R}/ \
ftp://ftp.fu-berlin.de/pub/unix/editors/jed/v${PORTVERSION:R}/ \
@@ -25,7 +25,8 @@ HOSTLOOKUP_DESC=Look-up for hostname
OPTIONS_SUB= yes
USES= tar:bzip2
DIST_SUBDIR= jed
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ENV+= JED_ROOT=${PREFIX}/lib/jed
diff --git a/mail/wmbiff/Makefile b/mail/wmbiff/Makefile
index da9c1112ff74..9b34cc2f0918 100644
--- a/mail/wmbiff/Makefile
+++ b/mail/wmbiff/Makefile
@@ -1,6 +1,6 @@
PORTNAME= wmbiff
PORTVERSION= 0.4.36
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail windowmaker afterstep
MASTER_SITES= https://www.dockapps.net/download/
@@ -13,7 +13,8 @@ LICENSE= GPLv2
USES= pkgconfig xorg
USE_XORG= x11 xext xpm
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
SUB_FILES= pkg-message
OPTIONS_DEFINE= GNUTLS
diff --git a/net-mgmt/iprange/Makefile b/net-mgmt/iprange/Makefile
index 08a15c2dc5f4..3ef373a8cc53 100644
--- a/net-mgmt/iprange/Makefile
+++ b/net-mgmt/iprange/Makefile
@@ -1,6 +1,6 @@
PORTNAME= iprange
PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= https://github.com/firehol/iprange/releases/download/v${PORTVERSION}/
@@ -12,7 +12,8 @@ LICENSE= GPLv2+
USES= tar:xz
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
PLIST_FILES= bin/iprange \
share/man/man1/iprange.1.gz
diff --git a/net/libpcap/Makefile b/net/libpcap/Makefile
index 8a92c4301e76..2c3be41ff645 100644
--- a/net/libpcap/Makefile
+++ b/net/libpcap/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libpcap
PORTVERSION= 1.10.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://www.tcpdump.org/release/
@@ -17,7 +17,8 @@ USES= bison cpe gmake ssl
CPE_VENDOR= tcpdump
USE_LDCONFIG= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS+=--enable-dbus=no \
--with-pcap=bpf
CONFIGURE_ENV+= LEX=${LOCALBASE}/bin/flex
diff --git a/net/rinetd/Makefile b/net/rinetd/Makefile
index ca7818c5c765..0151bc1221c9 100644
--- a/net/rinetd/Makefile
+++ b/net/rinetd/Makefile
@@ -1,6 +1,6 @@
PORTNAME= rinetd
PORTVERSION= 0.73
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= v
CATEGORIES= net
@@ -16,7 +16,8 @@ GH_ACCOUNT= samhocevar
GH_TAGNAME= d4e0a60
USE_RC_SUBR= rinetd
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
PORTDOCS= index.html
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index 83a5dfbb9864..24501f521613 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -1,6 +1,6 @@
PORTNAME= tcpdump
PORTVERSION= 4.99.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://www.tcpdump.org/release/
@@ -18,7 +18,8 @@ LIB_DEPENDS= libpcap.so.1:net/libpcap
USES= cpe gmake
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
PLIST_FILES= sbin/tcpdump \
share/man/man1/tcpdump.1.gz
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 332a1b0d7e75..e4bc49005f18 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sudo
PORTVERSION= 1.9.15p5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SUDO
@@ -16,7 +16,8 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= cpe libtool pkgconfig
CPE_VENDOR= todd_miller
USE_LDCONFIG= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --mandir=${PREFIX}/share/man \
--sysconfdir=${PREFIX}/etc \
--with-env-editor \
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index 5ca30dc0937f..5d432fa87e83 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -1,6 +1,6 @@
PORTNAME= scponly
PORTVERSION= 4.8.20110526
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= shells security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-snapshots
DISTNAME= ${PORTNAME}-20110526
@@ -14,7 +14,8 @@ LICENSE= BSD2CLAUSE
USES= cpe tar:tgz
PORTDOCS= BUILDING-JAILS.TXT INSTALL README SECURITY
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
OPTIONS_DEFINE= CHROOT DEFAULT_CHDIR DOCS GFTP RSYNC SCP SUBVERSION SVNSERVE \
UNISON WILDCARDS WINSCP
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index c64e85ddb81e..e171a1562271 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sarg
PORTVERSION= 2.4.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -18,7 +18,8 @@ OPTIONS_SUB= yes
PHP_DESC= Install PHP for reporting generating
USES= autoreconf gmake
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --sysconfdir="${ETCDIR}" \
--enable-fontdir="${ETCDIR}/fonts" \
--enable-imagedir="${ETCDIR}/images"
diff --git a/www/squidclamav/Makefile b/www/squidclamav/Makefile
index 6d42b2c338c9..637122b0f1bf 100644
--- a/www/squidclamav/Makefile
+++ b/www/squidclamav/Makefile
@@ -1,6 +1,6 @@
PORTNAME= squidclamav
PORTVERSION= 7.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www security
MASTER_SITES= SF
@@ -17,7 +17,8 @@ USES= cpe libtool shebangfix
CPE_VENDOR= darold
SHEBANG_FILES= cgi-bin/clwarn.cgi*
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --enable-shared --enable-static \
--sysconfdir="${PREFIX}/etc/c-icap" \
--with-c-icap=${LOCALBASE}