aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2023-04-05 20:04:12 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2023-04-05 20:04:12 +0000
commit08e811b21810363333719a62794f035c0dab73c9 (patch)
tree366dcdd91ef495f681559f69b78ba55b1df10331
parentedc8695588c9b8e1b6a0ca3aa21607653319b343 (diff)
downloadports-08e811b21810363333719a62794f035c0dab73c9.tar.gz
ports-08e811b21810363333719a62794f035c0dab73c9.zip
new port: security/pygost
PyGOST is pure Python 2.7/3.x GOST cryptographic functions library.
-rw-r--r--security/Makefile1
-rw-r--r--security/pygost/Makefile25
-rw-r--r--security/pygost/distinfo3
-rw-r--r--security/pygost/pkg-descr29
4 files changed, 58 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8f8a52918d47..88021d3ad285 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1031,6 +1031,7 @@
SUBDIR += py-zkg
SUBDIR += py-zope.password
SUBDIR += py-zxcvbn
+ SUBDIR += pygost
SUBDIR += qtkeychain
SUBDIR += quantis-kmod
SUBDIR += racoon2
diff --git a/security/pygost/Makefile b/security/pygost/Makefile
new file mode 100644
index 000000000000..34badf62edbc
--- /dev/null
+++ b/security/pygost/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= pygost
+PORTVERSION= 5.11
+CATEGORIES= security python
+MASTER_SITES= http://www.pygost.cypherpunks.ru/ \
+ http://www.grosbein.net/freebsd/distfiles/ \
+ LOCAL/eugen
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tar.zst
+
+MAINTAINER= eugen@FreeBSD.org
+COMMENT= Pure Python 2.7/3.x GOST cryptographic functions library
+WWW= http://www.pygost.cypherpunks.ru/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyderasn>=9.3:devel/py-pyderasn@${PY_FLAVOR}
+
+USES= tar:zst python
+USE_PYTHON= autoplist concurrent distutils optsuffix
+
+NO_ARCH= yes
+PYDISTUTILS_INSTALLARGS+= --install-data ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/pygost/distinfo b/security/pygost/distinfo
new file mode 100644
index 000000000000..cf0ad0a15321
--- /dev/null
+++ b/security/pygost/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680282037
+SHA256 (pygost-5.11.tar.zst) = 2e9900e74d11a59a8441a19a8e789a6b8eae7209ba8b74a4e28910ba90b85c66
+SIZE (pygost-5.11.tar.zst) = 93974
diff --git a/security/pygost/pkg-descr b/security/pygost/pkg-descr
new file mode 100644
index 000000000000..efb7dd2a3669
--- /dev/null
+++ b/security/pygost/pkg-descr
@@ -0,0 +1,29 @@
+PyGOST is pure Python 2.7/3.x GOST cryptographic functions library.
+Currently supported algorithms are:
+
+GOST 28147-89 (RFC 5830) block cipher with ECB, CNT (CTR), CFB, MAC,
+ CBC (RFC 4357) modes of operation
+various 28147-89-related S-boxes included
+GOST R 34.11-94 hash function (RFC 5831)
+GOST R 34.11-94 based PBKDF2 function
+GOST R 34.11-2012 Streebog hash function (RFC 6986)
+GOST R 34.11-2012 based PBKDF2 function (R 50.1.111-2016)
+GOST R 34.10-2001 (RFC 5832) public key signature function
+GOST R 34.10-2012 (RFC 7091) public key signature function
+various 34.10 curve parameters included
+Coordinates conversion from twisted Edwards to Weierstrass form and vice versa
+VKO GOST R 34.10-2001 key agreement function (RFC 4357)
+VKO GOST R 34.10-2012 key agreement function (RFC 7836)
+28147-89 and CryptoPro key wrapping (RFC 4357)
+28147-89 CryptoPro key meshing for CFB and CBC modes (RFC 4357)
+RFC 4491 (using GOST algorithms with X.509) compatibility helpers
+GOST R 34.12-2015 128-bit block cipher Kuznechik (RFC 7801)
+GOST R 34.12-2015 64-bit block cipher Magma
+GOST R 34.13-2015 padding methods and block cipher modes of operation (ECB,
+ CTR, OFB, CBC, CFB, MAC), ISO 10126 padding
+MGM AEAD mode for 64 and 128 bit ciphers (RFC 9058)
+CTR-ACPKM, OMAC-ACPKM-Master modes of operation (R 1323565.1.017-2018)
+KExp15/KImp15 key export/import functions (R 1323565.1.017-2018)
+KDF_GOSTR3411_2012_256, KDF_TREE_GOSTR3411_2012_256 (R 50.1.113-2016)
+KEG export key generation function (R 1323565.1.020-2018)
+PEP247-compatible hash/MAC functions