aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-27 10:10:13 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-27 10:10:13 +0000
commit09731424527119c34b5c74fe49497b9993437c5c (patch)
tree27bbb932675412e132732f161da4753010d0b41a
parentf101560ae9bdc5a32dac66ead540617d30caad5b (diff)
downloadports-09731424527119c34b5c74fe49497b9993437c5c.tar.gz
ports-09731424527119c34b5c74fe49497b9993437c5c.zip
security/p5-Crypt-OpenSSL-Verify: Add p5-Crypt-OpenSSL-Verify 0.35
Given a CA certificate and another untrusted certificate, will show whether the CA signs the certificate. This is a useful thing to have if you're signing with X509 certificates, but outside of SSL. A specific example is where you're working with XML signatures, and need to verify that the signing certificate is valid. WWW: https://metacpan.org/dist/Crypt-OpenSSL-Verify
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-OpenSSL-Verify/Makefile19
-rw-r--r--security/p5-Crypt-OpenSSL-Verify/distinfo3
-rw-r--r--security/p5-Crypt-OpenSSL-Verify/pkg-descr8
-rw-r--r--security/p5-Crypt-OpenSSL-Verify/pkg-plist3
5 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 9189839a3725..fb3be1cc04d2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -526,6 +526,7 @@
SUBDIR += p5-Crypt-OpenSSL-PKCS10
SUBDIR += p5-Crypt-OpenSSL-RSA
SUBDIR += p5-Crypt-OpenSSL-Random
+ SUBDIR += p5-Crypt-OpenSSL-Verify
SUBDIR += p5-Crypt-OpenSSL-X509
SUBDIR += p5-Crypt-PBKDF2
SUBDIR += p5-Crypt-PKCS10
diff --git a/security/p5-Crypt-OpenSSL-Verify/Makefile b/security/p5-Crypt-OpenSSL-Verify/Makefile
new file mode 100644
index 000000000000..7aa57cdccccd
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Verify/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= Crypt-OpenSSL-Verify
+PORTVERSION= 0.35
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OpenSSL Verify certificate verification in XS
+
+LICENSE= OpenSSL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= perl5 ssl
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Crypt/OpenSSL/Verify/Verify.so
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-Verify/distinfo b/security/p5-Crypt-OpenSSL-Verify/distinfo
new file mode 100644
index 000000000000..12bab8bada2d
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Verify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660576670
+SHA256 (Crypt-OpenSSL-Verify-0.35.tar.gz) = 0cfb1d340be7009d404115f733ee00b5bf5e388e6af7bfb7593e7da7d21fdd90
+SIZE (Crypt-OpenSSL-Verify-0.35.tar.gz) = 54845
diff --git a/security/p5-Crypt-OpenSSL-Verify/pkg-descr b/security/p5-Crypt-OpenSSL-Verify/pkg-descr
new file mode 100644
index 000000000000..9d6c6937f0d3
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Verify/pkg-descr
@@ -0,0 +1,8 @@
+Given a CA certificate and another untrusted certificate, will show whether the
+CA signs the certificate. This is a useful thing to have if you're signing with
+X509 certificates, but outside of SSL.
+
+A specific example is where you're working with XML signatures, and need to
+verify that the signing certificate is valid.
+
+WWW: https://metacpan.org/dist/Crypt-OpenSSL-Verify
diff --git a/security/p5-Crypt-OpenSSL-Verify/pkg-plist b/security/p5-Crypt-OpenSSL-Verify/pkg-plist
new file mode 100644
index 000000000000..9590e08727c6
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-Verify/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_ARCH%%/Crypt/OpenSSL/Verify.pm
+%%SITE_ARCH%%/auto/Crypt/OpenSSL/Verify/Verify.so
+%%PERL5_MAN3%%/Crypt::OpenSSL::Verify.3.gz