aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2024-05-09 08:14:05 +0000
committerGleb Popov <arrowd@FreeBSD.org>2024-05-09 11:45:42 +0000
commit0a1b69a66843b4566f3cf1c70937d6650f59c722 (patch)
tree956702c5fe5c77575357ce918f788ea4fba9be73
parent247d5632499f0905ad3d3f6de67dbd83417dee08 (diff)
downloadports-0a1b69a66843b4566f3cf1c70937d6650f59c722.tar.gz
ports-0a1b69a66843b4566f3cf1c70937d6650f59c722.zip
devel/pcsc-lite: Update to 2.2.1
Sponsored by: Serenity Cybersecurity, LLC Reported by: portscout!
-rw-r--r--devel/pcsc-lite/Makefile23
-rw-r--r--devel/pcsc-lite/distinfo6
-rw-r--r--devel/pcsc-lite/files/patch-src_spy_install__spy.sh20
-rw-r--r--devel/pcsc-lite/files/patch-src_spy_setup__spy.sh (renamed from devel/pcsc-lite/files/patch-src_spy_uninstall__spy.sh)8
-rw-r--r--devel/pcsc-lite/pkg-plist10
5 files changed, 21 insertions, 46 deletions
diff --git a/devel/pcsc-lite/Makefile b/devel/pcsc-lite/Makefile
index aaf005eeb887..9f60d7f9e630 100644
--- a/devel/pcsc-lite/Makefile
+++ b/devel/pcsc-lite/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pcsc-lite
-PORTVERSION= 2.0.3
+PORTVERSION= 2.2.1
PORTEPOCH= 2
CATEGORIES= devel security
MASTER_SITES= https://pcsclite.apdu.fr/files/
@@ -12,18 +12,18 @@ LICENSE= BSD3CLAUSE GPLv3+
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= libtool pathfix perl5 pkgconfig python:env shebangfix tar:bzip2
+USES= libtool meson pathfix perl5 pkgconfig python:env shebangfix tar:xz
USE_LDCONFIG= yes
USE_PERL5= build
USE_RC_SUBR= pcscd
-GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-CONFIGURE_ARGS= --disable-libsystemd \
- --enable-usbdropdir=${PREFIX}/lib/pcsc/drivers/ \
- --enable-ipcdir=/var/run
+MESON_ARGS= -Dlibsystemd=false \
+ -Dlibudev=false \
+ -Dlibusb=true \
+ -Dusb=true \
+ -Dusbdropdir=${PREFIX}/lib/pcsc/drivers/ \
+ -Dipcdir=/var/run
-INSTALL_TARGET= install-strip
SHEBANG_FILES= src/spy/pcsc-spy
SUB_FILES= pkg-message
@@ -37,10 +37,10 @@ FEATURES_DESC= Default features knobs
FILTER_DESC= Control (Ignore or Extend) reported reader names
POLKIT_DESC= Polkit authorization support
-FILTER_CONFIGURE_ENABLE= filter
+FILTER_MESON_TRUE= filter_names
-POLKIT_LIB_DEPENDS= libpolkit-gobject-1.so:sysutils/polkit
-POLKIT_CONFIGURE_ENABLE= polkit
+POLKIT_LIB_DEPENDS= libpolkit-gobject-1.so:sysutils/polkit
+POLKIT_MESON_TRUE= polkit
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/pcsc/drivers
@@ -49,7 +49,6 @@ post-install:
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/example/Makefile.am ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/example/Makefile.in ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/example/pcsc_demo.c ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/devel/pcsc-lite/distinfo b/devel/pcsc-lite/distinfo
index c5bf997c8ee2..5047860b99bd 100644
--- a/devel/pcsc-lite/distinfo
+++ b/devel/pcsc-lite/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1709531598
-SHA256 (pcsc-lite-2.0.3.tar.bz2) = f42ee9efa489e9ff5d328baefa26f9c515be65021856e78d99ad1f0ead9ec85d
-SIZE (pcsc-lite-2.0.3.tar.bz2) = 818562
+TIMESTAMP = 1715200330
+SHA256 (pcsc-lite-2.2.1.tar.xz) = 625edcd6cf4b45af015eb5b6b75ea47f8914e892774c67e1079c9553c8665a57
+SIZE (pcsc-lite-2.2.1.tar.xz) = 207664
diff --git a/devel/pcsc-lite/files/patch-src_spy_install__spy.sh b/devel/pcsc-lite/files/patch-src_spy_install__spy.sh
deleted file mode 100644
index acfc10ad71a0..000000000000
--- a/devel/pcsc-lite/files/patch-src_spy_install__spy.sh
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/spy/install_spy.sh.orig 2020-08-05 11:01:32 UTC
-+++ src/spy/install_spy.sh
-@@ -5,7 +5,7 @@ set -e
-
- # ldconfig --print-cache will return something like
- # libpcsclite.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libpcsclite.so.1
--DIR=$(ldconfig --print-cache | grep libpcsclite.so.1)
-+DIR=$(ldconfig -r | grep libpcsclite.so.1)
-
- # get the right part only: /usr/lib/x86_64-linux-gnu/libpcsclite.so.1
- DIR=$(echo $DIR | cut -d'=' -f2 | cut -d' ' -f2)
-@@ -14,7 +14,7 @@ DIR=$(dirname $DIR)
- DIR=$(dirname $DIR)
-
- # find the spying library
--SPY=$(ldconfig --print-cache | grep libpcscspy.so)
-+SPY=$(ldconfig -r | grep libpcscspy.so)
- SPY=$(echo $SPY | cut -d'=' -f2 | cut -d' ' -f2)
-
- echo "Using directory:" $DIR
diff --git a/devel/pcsc-lite/files/patch-src_spy_uninstall__spy.sh b/devel/pcsc-lite/files/patch-src_spy_setup__spy.sh
index bfdb94466e46..e28bfae05f30 100644
--- a/devel/pcsc-lite/files/patch-src_spy_uninstall__spy.sh
+++ b/devel/pcsc-lite/files/patch-src_spy_setup__spy.sh
@@ -1,6 +1,6 @@
---- src/spy/uninstall_spy.sh.orig 2020-08-05 11:01:32 UTC
-+++ src/spy/uninstall_spy.sh
-@@ -5,7 +5,7 @@ set -e
+--- src/spy/setup_spy.sh.orig 2024-05-08 09:57:49 UTC
++++ src/spy/setup_spy.sh
+@@ -5,7 +5,7 @@ PATH="$PATH:/usr/sbin"
# ldconfig --print-cache will return something like
# libpcsclite.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libpcsclite.so.1
@@ -8,4 +8,4 @@
+DIR=$(ldconfig -r | grep libpcsclite.so.1)
# get the right part only: /usr/lib/x86_64-linux-gnu/libpcsclite.so.1
- DIR=$(echo $DIR | cut -d'=' -f2 | cut -d' ' -f2)
+ DIR=$(echo "$DIR" | cut -d'=' -f2 | cut -d' ' -f2)
diff --git a/devel/pcsc-lite/pkg-plist b/devel/pcsc-lite/pkg-plist
index 2fb3b5e51c24..9f1ed8666eb4 100644
--- a/devel/pcsc-lite/pkg-plist
+++ b/devel/pcsc-lite/pkg-plist
@@ -7,20 +7,16 @@ include/PCSC/winscard.h
include/PCSC/wintypes.h
lib/libpcsclite.so
lib/libpcsclite.so.1
-lib/libpcsclite.so.1.0.0
+lib/libpcsclite_real.so
+lib/libpcsclite_real.so.1
lib/libpcscspy.so
lib/libpcscspy.so.0
-lib/libpcscspy.so.0.0.0
libdata/pkgconfig/libpcsclite.pc
sbin/pcscd
-%%PORTDOCS%%%%DOCSDIR%%/README.polkit
-%%PORTDOCS%%%%DOCSDIR%%/install_spy.sh
-%%PORTDOCS%%%%DOCSDIR%%/uninstall_spy.sh
+%%PORTDOCS%%%%DOCSDIR%%/setup_spy.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.am
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.in
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pcsc_demo.c
share/man/man1/pcsc-spy.1.gz
-share/man/man5/reader.conf.5.gz
share/man/man8/pcscd.8.gz
%%POLKIT%%share/polkit-1/actions/org.debian.pcsc-lite.policy
@dir lib/pcsc/services