aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-29 16:54:10 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-29 17:32:35 +0000
commit0a28a51398d1be4dd07249535c030cc0a60ab719 (patch)
treea4e314b5f9a1535fc8996b0cd420422d6e6a0860
parentbe22e4e5f1fb06d357fcb7f6e78501d78ccf26dc (diff)
downloadports-0a28a51398d1be4dd07249535c030cc0a60ab719.tar.gz
ports-0a28a51398d1be4dd07249535c030cc0a60ab719.zip
devel/leatherman: Unbreak on HEAD
- Pet portclippy while I am here Approved by: portmgr (blanket)
-rw-r--r--devel/leatherman/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/devel/leatherman/Makefile b/devel/leatherman/Makefile
index 9a7b70559f38..ff5b8d2222e4 100644
--- a/devel/leatherman/Makefile
+++ b/devel/leatherman/Makefile
@@ -15,16 +15,22 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
USES= compiler:c++11-lang cmake gettext ruby
USE_GITHUB= yes
GH_ACCOUNT= puppetlabs
+USE_LDCONFIG= yes
CMAKE_ON= LEATHERMAN_SHARED
CMAKE_OFF= ENABLE_CXX_WERROR
-USE_LDCONFIG= yes
+
TEST_TARGET= test
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
post-configure:
# This file is vendored in vendor/Catch-1.10.0.zip and extracted at configure step
${SED} -i '' -e '1s|\(.*\)|#include <sys/signal.h>\n\1|' ${CONFIGURE_WRKSRC}/src/Catch-1.10.0/single_include/catch.hpp
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+ ${REINPLACE_CMD} -e 's|ptrdiff_t|size_t|' ${CONFIGURE_WRKSRC}/src/Catch-1.10.0/single_include/catch.hpp
+.endif
-PLIST_SUB= PORTVERSION=${PORTVERSION}
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>