aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 12:25:31 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 12:25:31 +0000
commit0a618235c76d379d40ae3087e19a8de0068c2221 (patch)
tree41cf041a87bd7a1565726cc8c45116a9b3796ca6
parent7c3711d9a332b74fec45705f6ba8e8282c85bde2 (diff)
downloadports-0a618235c76d379d40ae3087e19a8de0068c2221.tar.gz
ports-0a618235c76d379d40ae3087e19a8de0068c2221.zip
biology/fasttree: fix build on powerpc
LLVM on powerpc doesn't have libomp. Same issue happens on armv6 and armv7 but someone has to test whether doing the same for those architectures is enough.
-rw-r--r--biology/fasttree/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/biology/fasttree/Makefile b/biology/fasttree/Makefile
index 30dd2cd31972..304ee4959939 100644
--- a/biology/fasttree/Makefile
+++ b/biology/fasttree/Makefile
@@ -16,6 +16,12 @@ BROKEN_armv7= fails to compile: FastTree-2.1.10.c:305:10: 'omp.h' file not foun
NO_WRKSUBDIR= yes
PLIST_FILES= bin/FastTree
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES= compiler:gcc-c++11-lib
+.endif
+
do-extract:
@${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
@${CP} ${FILESDIR}/Makefile ${WRKSRC}