aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:42:36 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-04-17 23:58:03 +0000
commit0a6959119fa7970dd81d7f339850ea8bbb5e3c81 (patch)
tree800057ae43de74503c81657454a4676fb5903037
parent2aef9cbc31d730ba2d778cd906c1613f8c24d531 (diff)
downloadports-0a6959119fa7970dd81d7f339850ea8bbb5e3c81.tar.gz
ports-0a6959119fa7970dd81d7f339850ea8bbb5e3c81.zip
math/fxt: Update to 2022.04.13
- Update MASTER_SITES - Convert REINPLACE_CMD to patch file - Update WWW - Take maintainership
-rw-r--r--math/fxt/Makefile21
-rw-r--r--math/fxt/distinfo6
-rw-r--r--math/fxt/files/patch-makefile79
-rw-r--r--math/fxt/files/patch-src-fxtalloca.h13
-rw-r--r--math/fxt/files/patch-src_fxtalloca.h18
-rw-r--r--math/fxt/pkg-descr20
-rw-r--r--math/fxt/pkg-plist4
7 files changed, 114 insertions, 47 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index 2ed96583f4da..e225fd269cf2 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -1,33 +1,26 @@
# Created by: ijliao
PORTNAME= fxt
-DISTVERSION= 2021.04.06
+DISTVERSION= 2022.04.13
CATEGORIES= math
-MASTER_SITES= http://www.jjj.de/fxt/
+MASTER_SITES= https://www.jjj.de/fxt/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= FFT code and related stuff
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Llibrary of low-level algorithms
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
USES= compiler:c++11-lang gmake
+
MAKE_ENV= FXT_INSTALL="${INSTALL_DATA}"
MAKEFILE= makefile
+WRKSRC= ${WRKDIR}/fxt
OPTIONS_DEFINE= EXAMPLES
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|^\(FXT_CXXFLAGS\)|#\1| ; \
- s|\([[:space:]]\)\($$(INCDIR)\)|\1$$(DESTDIR)\2|g ; \
- s|\([[:space:]]\)\($$(LIBDIR)\)|\1$$(DESTDIR)\2|g' \
- ${WRKSRC}/makefile
-
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- (cd ${WRKSRC}/demo && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+ cd ${WRKSRC}/demo && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
index 4b2bdffb47f8..20f3d3e62659 100644
--- a/math/fxt/distinfo
+++ b/math/fxt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1619719598
-SHA256 (fxt-2021.04.06.tar.gz) = 119c5347bb6d8a61b4a478a029cfc500205a18e2b82d7df41c0532e4d839db0f
-SIZE (fxt-2021.04.06.tar.gz) = 1856376
+TIMESTAMP = 1650228686
+SHA256 (fxt-2022.04.13.tar.gz) = c1a5f2a0a24d9794088b21dc85cc475905659844d5367e8a31dbc6402d27272a
+SIZE (fxt-2022.04.13.tar.gz) = 1856776
diff --git a/math/fxt/files/patch-makefile b/math/fxt/files/patch-makefile
new file mode 100644
index 000000000000..ed412ac3f861
--- /dev/null
+++ b/math/fxt/files/patch-makefile
@@ -0,0 +1,79 @@
+--- makefile.orig 2021-04-06 13:42:27 UTC
++++ makefile
+@@ -8,22 +8,22 @@ PROJ=fxt
+ include flags.mk
+
+ #### choose the FLAG combo here:
+-FXT_CXXFLAGS=
++#FXT_CXXFLAGS=
+ #FXT_CXXFLAGS += -std=c++11
+-FXT_CXXFLAGS += -std=c++17
+-FXT_CXXFLAGS += -pipe
++#FXT_CXXFLAGS += -std=c++17
++#FXT_CXXFLAGS += -pipe
+ #FXT_CXXFLAGS += -fno-exceptions
+-FXT_CXXFLAGS += $(OFLAGS) # uncomment for OPTIMIZATION
++#FXT_CXXFLAGS += $(OFLAGS) # uncomment for OPTIMIZATION
+ #FXT_CXXFLAGS += -O3 # test -O3
+ #FXT_CXXFLAGS += $(GFLAGS) # uncomment for DEBUGGING
+ #FXT_CXXFLAGS += $(PFLAGS) # uncomment for PROFILING
+ #
+-FXT_CXXFLAGS += $(WFLAGS) # uncomment for WARNINGS
++#FXT_CXXFLAGS += $(WFLAGS) # uncomment for WARNINGS
+ #FXT_CXXFLAGS += -Werror # make all warnings ERRORS
+ #FXT_CXXFLAGS += -fmax-errors=1 # clang chokes on this one
+
+ #FXT_CXXFLAGS += -D__NO_MATH_INLINES
+-FXT_CXXFLAGS += $(FXT_EXTRA_FLAGS)
++#FXT_CXXFLAGS += $(FXT_EXTRA_FLAGS)
+
+ #FXT_CXXFLAGS += $(CLANG_FLAGS) ## for clang++
+
+@@ -200,27 +200,27 @@ install: lib
+ : '[$@]'
+ @echo 'PREFIX=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(INCDIR)'
+ @:
+- @test -d $(INCDIR) || mkdir $(INCDIR)
+- @$(FXT_INSTALL) $(FXTIDIR)/*.h $(INCDIR)/
+- @cd src && for f in $(SHFXTSRCDIRS); do mkdir -p $(INCDIR)/$$f; done
+- @cd src && for f in $(SHFXTSRCDIRS); do $(FXT_INSTALL) $$f/*.h $(INCDIR)/$$f; done
++ @test -d $(DESTDIR)$(INCDIR) || mkdir $(DESTDIR)$(INCDIR)
++ @$(FXT_INSTALL) $(FXTIDIR)/*.h $(DESTDIR)$(INCDIR)/
++ @cd src && for f in $(SHFXTSRCDIRS); do mkdir -p $(DESTDIR)$(INCDIR)/$$f; done
++ @cd src && for f in $(SHFXTSRCDIRS); do $(FXT_INSTALL) $$f/*.h $(DESTDIR)$(INCDIR)/$$f; done
+ @:
+- @test -d $(LIBDIR) || mkdir $(LIBDIR)
+- @$(FXT_INSTALL) $(FXTLIB) $(LIBDIR)/
++ @test -d $(DESTDIR)$(LIBDIR) || mkdir $(DESTDIR)$(LIBDIR)
++ @$(FXT_INSTALL) $(FXTLIB) $(DESTDIR)$(LIBDIR)/
+ : '[$@ OK]'
+
+ .PHONY: chk-install ##x print whether installed header files are up to date
+ chk-install:
+ @(cd src && find . -maxdepth 2 -name \*.h | sort) > tmp-hdr1
+- @(cd $(INCDIR)/ && find . -name \*.h | sort) > tmp-hdr2
++ @(cd $(DESTDIR)$(INCDIR)/ && find . -name \*.h | sort) > tmp-hdr2
+ @-diff tmp-hdr1 tmp-hdr2
+ @rm tmp-hdr1 tmp-hdr2
+
+-.PHONY: uninstall ## uninstall headers and lib, but leave directory $(INCDIR)
++.PHONY: uninstall ## uninstall headers and lib, but leave directory $(DESTDIR)$(INCDIR)
+ uninstall:
+- : '[$@]' ## note: we do not remove $(INCDIR)
+- rm -rf $(INCDIR)/*
+- rm -f $(LIBDIR)/$(FXTLIB)
++ : '[$@]' ## note: we do not remove $(DESTDIR)$(INCDIR)
++ rm -rf $(DESTDIR)$(INCDIR)/*
++ rm -f $(DESTDIR)$(LIBDIR)/$(FXTLIB)
+
+ .PHONY: reinstall ## uninstall and install
+ reinstall: # uninstall install
+@@ -785,7 +785,7 @@ showsrc:
+ # @for h in */*.h; do \
+ # grep -L $$h depend.mk &>/dev/null || echo $$h ; done
+ #
+-## @for h in $$(ls -1 $(INCDIR) ); do \
++## @for h in $$(ls -1 $(DESTDIR)$(INCDIR) ); do \
+
+ #.PHONY: shownotes ##x show comments that contain the string "note"
+ #shownotes:
diff --git a/math/fxt/files/patch-src-fxtalloca.h b/math/fxt/files/patch-src-fxtalloca.h
new file mode 100644
index 000000000000..1d6235758c41
--- /dev/null
+++ b/math/fxt/files/patch-src-fxtalloca.h
@@ -0,0 +1,13 @@
+--- src/fxtalloca.h.orig 2021-10-28 13:13:12 UTC
++++ src/fxtalloca.h
+@@ -16,8 +16,8 @@
+ #undef ALLOCA
+
+ #ifdef FORCE_ALLOCA_H
+-#include <alloca.h>
+-//#include <stdlib.h> // for BSD
++//#include <alloca.h>
++#include <stdlib.h> // for BSD
+ #define ALLOCA(Type, v, n) Type *v = (Type *)alloca((n)*sizeof(Type))
+ #else
+ #define ALLOCA(Type, v, n) Type v[n]
diff --git a/math/fxt/files/patch-src_fxtalloca.h b/math/fxt/files/patch-src_fxtalloca.h
deleted file mode 100644
index 7b7ec5f31996..000000000000
--- a/math/fxt/files/patch-src_fxtalloca.h
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/fxtalloca.h.orig 2012-11-21 18:05:08 UTC
-+++ src/fxtalloca.h
-@@ -16,13 +16,13 @@
- #if defined __GNUC__ // GNU compiler
- #define ALLOCA(Type, v, n) Type v[n]
- #else // __GNUC__
--#include <alloca.h>
-+#include <stdlib.h>
- #define ALLOCA(Type, v, n) Type *v = (Type *)alloca((n)*sizeof(Type))
- #endif // __GNUC__
-
- #ifdef FORCE_ALLOCA_H
- #undef ALLOCA
--#include <alloca.h>
-+#include <stdlib.h>
- //#include <stdlib.h> // for BSD
- #define ALLOCA(Type, v, n) Type *v = (Type *)alloca((n)*sizeof(Type))
- #endif
diff --git a/math/fxt/pkg-descr b/math/fxt/pkg-descr
index f4c06e284255..d7b1bab1b032 100644
--- a/math/fxt/pkg-descr
+++ b/math/fxt/pkg-descr
@@ -1,13 +1,13 @@
fxt is a library package (coming as C++ source code) containing various
algorithms for:
- - Fast Fourier Transform (FFT) incl. real-valued,
- - multidimensional and weighted variants.
- - Fast Hartley Transform (FHT)
- - Number Theoretic Transform (NTT), Fast Walsh Transform.
- - Convolution (cyclic, linear and weighted),
- - correlation and power spectrum.
- - Fast Haar Transform, Fast Wavelet Transform
- - Mass storage convolution and fast multiplication routines.
- - Sine- and cosine transform (DCT, DST), Fast Z-Transform (FZT)
+- Fast Fourier Transform (FFT) incl. real-valued,
+- multidimensional and weighted variants.
+- Fast Hartley Transform (FHT)
+- Number Theoretic Transform (NTT), Fast Walsh Transform.
+- Convolution (cyclic, linear and weighted),
+- correlation and power spectrum.
+- Fast Haar Transform, Fast Wavelet Transform
+- Mass storage convolution and fast multiplication routines.
+- Sine- and cosine transform (DCT, DST), Fast Z-Transform (FZT)
-WWW: http://www.jjj.de/fxt/
+WWW: https://www.jjj.de/fxt/
diff --git a/math/fxt/pkg-plist b/math/fxt/pkg-plist
index 3a2448684f05..1ae6965b2607 100644
--- a/math/fxt/pkg-plist
+++ b/math/fxt/pkg-plist
@@ -779,10 +779,10 @@ lib/libfxt.a
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/debruijn-lookup-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/dragon-curve-moves-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/dragon-curve-moves-out.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/fibrep-demo.cc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/fibrep-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/fibrep-subset-lexrev-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/fibrep-subset-lexrev-out.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/fibrep2-demo.cc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/fibrep2-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/gotcha-demo.cc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/gotcha-out.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bits/gray-demo.cc