aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-25 23:28:49 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-10-25 23:28:49 +0000
commit0aa4d822f251e8508993a60f669f1b8fc86b64c9 (patch)
tree952d0b0dd95f2e149a67088a516f2911c5d228dc
parentddfba5bcd6143862fa7fe3ae7873ca03a4817b8b (diff)
downloadports-0aa4d822f251e8508993a60f669f1b8fc86b64c9.tar.gz
ports-0aa4d822f251e8508993a60f669f1b8fc86b64c9.zip
devel/kyra: fix build on non-x86
Fun fact: for some reason base GCC on 12.2-RELEASE on powerpc64 can build this port without this patch even though __GNUC__ is defined.
-rw-r--r--devel/kyra/Makefile4
-rw-r--r--devel/kyra/files/patch-encoder__MakefileKyra4
-rw-r--r--devel/kyra/files/patch-engine__MakefileKyra4
-rw-r--r--devel/kyra/files/patch-engine_encoder.h6
-rw-r--r--devel/kyra/files/patch-engine_imagetree.h6
-rw-r--r--devel/kyra/files/patch-engine_namefield.h8
-rw-r--r--devel/kyra/files/patch-grinliz_glperformance.h20
-rw-r--r--devel/kyra/files/patch-guiExtended_progress.h8
-rw-r--r--devel/kyra/files/patch-guitest__guitest.cpp4
9 files changed, 40 insertions, 24 deletions
diff --git a/devel/kyra/Makefile b/devel/kyra/Makefile
index 60eaa482c84c..3239df9e3e86 100644
--- a/devel/kyra/Makefile
+++ b/devel/kyra/Makefile
@@ -15,10 +15,6 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
-BROKEN_aarch64= invalid output constraint =A in assembler
-BROKEN_armv6= invalid output constraint =A in assembler
-BROKEN_armv7= invalid output constraint =A in assembler
-
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= compiler gl gmake jpeg sdl zip
diff --git a/devel/kyra/files/patch-encoder__MakefileKyra b/devel/kyra/files/patch-encoder__MakefileKyra
index 7dccfc1b79dd..d33e4ec639a0 100644
--- a/devel/kyra/files/patch-encoder__MakefileKyra
+++ b/devel/kyra/files/patch-encoder__MakefileKyra
@@ -1,6 +1,6 @@
---- encoder/MakefileKyra.orig
+--- encoder/MakefileKyra.orig 2005-09-21 18:12:50 UTC
+++ encoder/MakefileKyra
-@@ -110,7 +110,7 @@
+@@ -110,7 +110,7 @@ OBJS := $(addsuffix .o,$(basename ${SRCS}))
# Output
#****************************************************************************
diff --git a/devel/kyra/files/patch-engine__MakefileKyra b/devel/kyra/files/patch-engine__MakefileKyra
index c0ee8d2ed656..886a268edf05 100644
--- a/devel/kyra/files/patch-engine__MakefileKyra
+++ b/devel/kyra/files/patch-engine__MakefileKyra
@@ -1,6 +1,6 @@
---- engine/MakefileKyra.orig
+--- engine/MakefileKyra.orig 2006-07-21 01:54:05 UTC
+++ engine/MakefileKyra
-@@ -130,6 +130,7 @@
+@@ -130,6 +130,7 @@ SRCS := action.cpp \
../util/glstring.cpp \
../util/glisomath.cpp \
../../grinliz/gldebug.cpp \
diff --git a/devel/kyra/files/patch-engine_encoder.h b/devel/kyra/files/patch-engine_encoder.h
index d36b98a248de..f9fe5d6fad80 100644
--- a/devel/kyra/files/patch-engine_encoder.h
+++ b/devel/kyra/files/patch-engine_encoder.h
@@ -1,6 +1,6 @@
---- engine/encoder.h.orig 2007-11-12 17:25:45.000000000 +0100
-+++ engine/encoder.h 2007-11-12 17:25:59.000000000 +0100
-@@ -185,7 +185,7 @@
+--- engine/encoder.h.orig 2005-03-31 01:02:36 UTC
++++ engine/encoder.h
+@@ -148,7 +148,7 @@ class KrEncoder
GLASSERT( numRGBA >= numSegment );
// GLASSERT( numSegment >= numLine );
}
diff --git a/devel/kyra/files/patch-engine_imagetree.h b/devel/kyra/files/patch-engine_imagetree.h
index 3a80086453cb..494f878687f3 100644
--- a/devel/kyra/files/patch-engine_imagetree.h
+++ b/devel/kyra/files/patch-engine_imagetree.h
@@ -1,6 +1,6 @@
---- engine/imagetree.h.orig 2007-11-12 17:22:54.000000000 +0100
-+++ engine/imagetree.h 2007-11-12 17:23:06.000000000 +0100
-@@ -190,7 +190,7 @@
+--- engine/imagetree.h.orig 2005-03-31 01:02:38 UTC
++++ engine/imagetree.h
+@@ -190,7 +190,7 @@ class KrImageTree
void Clear( KrImNode* root ); // delete the entire tree
// Recursive hit test walk.
diff --git a/devel/kyra/files/patch-engine_namefield.h b/devel/kyra/files/patch-engine_namefield.h
index 03ab36ad2ba8..9f27cecc6ce3 100644
--- a/devel/kyra/files/patch-engine_namefield.h
+++ b/devel/kyra/files/patch-engine_namefield.h
@@ -1,7 +1,7 @@
---- engine/namefield.h.orig Tue Sep 12 19:06:04 2006
-+++ engine/namefield.h Tue Sep 12 19:07:20 2006
-@@ -31,6 +31,7 @@
- #include "../util/gltypes.h"
+--- engine/namefield.h.orig 2005-02-14 08:03:33 UTC
++++ engine/namefield.h
+@@ -34,6 +34,7 @@
+ #include "../../grinliz/gltypes.h"
#include "../util/gllist.h"
#include "SDL_endian.h"
+#include "SDL_rwops.h"
diff --git a/devel/kyra/files/patch-grinliz_glperformance.h b/devel/kyra/files/patch-grinliz_glperformance.h
new file mode 100644
index 000000000000..7089639e9723
--- /dev/null
+++ b/devel/kyra/files/patch-grinliz_glperformance.h
@@ -0,0 +1,20 @@
+--- ../grinliz/glperformance.h.orig 2021-10-26 01:06:25.780070000 +0200
++++ ../grinliz/glperformance.h 2021-10-26 01:16:02.969577000 +0200
+@@ -34,6 +34,8 @@
+ #include "gltypes.h"
+ #include "gldebug.h"
+
++#include <SDL/SDL_timer.h>
++
+ namespace grinliz {
+
+ const int GL_MAX_PROFILE_DATAITEM = 64;
+@@ -91,7 +93,7 @@
+ #else
+ inline U64 FastTime()
+ {
+- #ifdef __GNUC__
++ #if defined(__GNUC__) && (defined(__amd64__) || defined(__i386__))
+ U64 val;
+ __asm__ __volatile__ ("rdtsc" : "=A" (val));
+ return val;
diff --git a/devel/kyra/files/patch-guiExtended_progress.h b/devel/kyra/files/patch-guiExtended_progress.h
index b5c98606925d..e4c6ca345f13 100644
--- a/devel/kyra/files/patch-guiExtended_progress.h
+++ b/devel/kyra/files/patch-guiExtended_progress.h
@@ -1,6 +1,6 @@
---- guiExtended/progress.h.orig 2007-11-12 17:24:08.000000000 +0100
-+++ guiExtended/progress.h 2007-11-12 17:24:34.000000000 +0100
-@@ -43,7 +43,7 @@
+--- guiExtended/progress.h.orig 2004-11-21 19:28:32 UTC
++++ guiExtended/progress.h
+@@ -43,7 +43,7 @@ class KrProgress : public KrWidget (public)
/** if width of the resource is greater then its height then makes
a horizontal, else makes a vertical progress bar
*/
@@ -9,7 +9,7 @@
int height,
KrRGBA FillColor,
KrRGBA ChangeColor,
-@@ -53,7 +53,7 @@
+@@ -53,7 +53,7 @@ class KrProgress : public KrWidget (public)
/** if width of the resource is greater then its height then makes
a horizontal, else makes a vertical progress bar
*/
diff --git a/devel/kyra/files/patch-guitest__guitest.cpp b/devel/kyra/files/patch-guitest__guitest.cpp
index d70993b5656c..de9b79c958b2 100644
--- a/devel/kyra/files/patch-guitest__guitest.cpp
+++ b/devel/kyra/files/patch-guitest__guitest.cpp
@@ -1,6 +1,6 @@
---- guitest/guitest.cpp.orig
+--- guitest/guitest.cpp.orig 2005-04-07 05:53:51 UTC
+++ guitest/guitest.cpp
-@@ -96,19 +96,19 @@
+@@ -96,19 +96,19 @@ class MyConsole : public KrConsole
switch ( event.type )
{
case KrWidgetEvent::ACTIVATED: