aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-02 16:28:19 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-02 16:28:19 +0000
commit0acc0ba51101895c8e83c6eaf482bfe02746e614 (patch)
tree782bc61e817e6dbc4db3e0a339e5c01587fd39ed
parent25e9cfb388e3396e5f13cb9636cc5b3ff82d6660 (diff)
downloadports-0acc0ba51101895c8e83c6eaf482bfe02746e614.tar.gz
ports-0acc0ba51101895c8e83c6eaf482bfe02746e614.zip
Primate Plunge is an arcade game, you have help poor Monkey navigate his way
down through trecherous jungles, canyons, towering waterfalls, into the heart of a volcano and through the driving rain of a cold industrial city. Monkey will find help along the way in the form of exciting powerups, including parachutes and jetpacks. WWW: http://www.aelius.com/primateplunge/ PR: ports/92686 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Notes
Notes: svn path=/head/; revision=155089
-rw-r--r--games/Makefile1
-rw-r--r--games/primateplunge/Makefile36
-rw-r--r--games/primateplunge/distinfo3
-rw-r--r--games/primateplunge/pkg-descr8
-rw-r--r--games/primateplunge/pkg-plist165
5 files changed, 213 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 936486e5e641..4f1d13d306a4 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -466,6 +466,7 @@
SUBDIR += powwow
SUBDIR += ppracer
SUBDIR += prboom
+ SUBDIR += primateplunge
SUBDIR += ptkei
SUBDIR += pvpgn
SUBDIR += py-sgflib
diff --git a/games/primateplunge/Makefile b/games/primateplunge/Makefile
new file mode 100644
index 000000000000..956df3a4da26
--- /dev/null
+++ b/games/primateplunge/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: primateplunge
+# Date created: 2006-02-01
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= primateplunge
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= http://www.ecs.soton.ac.uk/~njh/primateplunge/
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Primate Plunge is an arcade game
+
+RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_SDL= sdl mixer
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+PRIMATEDIR= sounds graphics
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/src/primateplunge ${PREFIX}/bin/primateplunge
+ @cd ${WRKSRC} && \
+ ${FIND} ${PRIMATEDIR} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} -E ${PRIMATEDIR} -type f -iregex ".*\.(bmp|wav|mid)" -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/AUTHORS ${WRKSRC}/TIPS ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/primateplunge/distinfo b/games/primateplunge/distinfo
new file mode 100644
index 000000000000..aa1aeea86ca4
--- /dev/null
+++ b/games/primateplunge/distinfo
@@ -0,0 +1,3 @@
+MD5 (primateplunge-1.1.tar.gz) = dd89b75d3af7dbbc3af3e9b2d8909c50
+SHA256 (primateplunge-1.1.tar.gz) = 4df43ace79ff8aa41547e65c26120ed941528da8b82e16563bf285324831bc0c
+SIZE (primateplunge-1.1.tar.gz) = 5245884
diff --git a/games/primateplunge/pkg-descr b/games/primateplunge/pkg-descr
new file mode 100644
index 000000000000..ff109329a459
--- /dev/null
+++ b/games/primateplunge/pkg-descr
@@ -0,0 +1,8 @@
+Primate Plunge is an arcade game, you have help poor Monkey navigate his way
+down through trecherous jungles, canyons, towering waterfalls, into the heart
+of a volcano and through the driving rain of a cold industrial city.
+
+Monkey will find help along the way in the form of exciting powerups, including
+parachutes and jetpacks.
+
+WWW: http://www.aelius.com/primateplunge/
diff --git a/games/primateplunge/pkg-plist b/games/primateplunge/pkg-plist
new file mode 100644
index 000000000000..e553f171278f
--- /dev/null
+++ b/games/primateplunge/pkg-plist
@@ -0,0 +1,165 @@
+bin/primateplunge
+%%DATADIR%%/graphics/crumble/frame.bmp
+%%DATADIR%%/graphics/crumble/largeBackground.bmp
+%%DATADIR%%/graphics/crumble/medRocks.bmp
+%%DATADIR%%/graphics/crumble/nearRocks.bmp
+%%DATADIR%%/graphics/frenzie/background.bmp
+%%DATADIR%%/graphics/frenzie/cliff.bmp
+%%DATADIR%%/graphics/frenzie/frame.bmp
+%%DATADIR%%/graphics/frenzie/waterBack.bmp
+%%DATADIR%%/graphics/frenzie/waterFront.bmp
+%%DATADIR%%/graphics/antiGrav.bmp
+%%DATADIR%%/graphics/backtomain.bmp
+%%DATADIR%%/graphics/branch.bmp
+%%DATADIR%%/graphics/bubbles.bmp
+%%DATADIR%%/graphics/ceilingSpikes.bmp
+%%DATADIR%%/graphics/clock.bmp
+%%DATADIR%%/graphics/conveyorleft.bmp
+%%DATADIR%%/graphics/conveyorright.bmp
+%%DATADIR%%/graphics/evilBranch.bmp
+%%DATADIR%%/graphics/fall.bmp
+%%DATADIR%%/graphics/fallLeft.bmp
+%%DATADIR%%/graphics/fallRight.bmp
+%%DATADIR%%/graphics/flipper.bmp
+%%DATADIR%%/graphics/gameCompleteScreen.bmp
+%%DATADIR%%/graphics/heal.bmp
+%%DATADIR%%/graphics/healthEmpty.bmp
+%%DATADIR%%/graphics/healthFull.bmp
+%%DATADIR%%/graphics/idle.bmp
+%%DATADIR%%/graphics/instructions.bmp
+%%DATADIR%%/graphics/instructions2.bmp
+%%DATADIR%%/graphics/jetpackMonkey.bmp
+%%DATADIR%%/graphics/jetpackPickup.bmp
+%%DATADIR%%/graphics/jumpPickup.bmp
+%%DATADIR%%/graphics/laser.bmp
+%%DATADIR%%/graphics/linuxThankYou.bmp
+%%DATADIR%%/graphics/loading.bmp
+%%DATADIR%%/graphics/locked.bmp
+%%DATADIR%%/graphics/log.bmp
+%%DATADIR%%/graphics/logo.bmp
+%%DATADIR%%/graphics/medal.bmp
+%%DATADIR%%/graphics/monkeyIdle.bmp
+%%DATADIR%%/graphics/need.bmp
+%%DATADIR%%/graphics/needComplete.bmp
+%%DATADIR%%/graphics/next.bmp
+%%DATADIR%%/graphics/numbers.bmp
+%%DATADIR%%/graphics/off.bmp
+%%DATADIR%%/graphics/on.bmp
+%%DATADIR%%/graphics/paraBag.bmp
+%%DATADIR%%/graphics/parachute.bmp
+%%DATADIR%%/graphics/paused.bmp
+%%DATADIR%%/graphics/pipe.bmp
+%%DATADIR%%/graphics/piranha.bmp
+%%DATADIR%%/graphics/prev.bmp
+%%DATADIR%%/graphics/primateplunged.bmp
+%%DATADIR%%/graphics/record.bmp
+%%DATADIR%%/graphics/rustSpikes.bmp
+%%DATADIR%%/graphics/shield.bmp
+%%DATADIR%%/graphics/silver.bmp
+%%DATADIR%%/graphics/spikeRock.bmp
+%%DATADIR%%/graphics/springRope.bmp
+%%DATADIR%%/graphics/star.bmp
+%%DATADIR%%/graphics/starRating1Screen.bmp
+%%DATADIR%%/graphics/starRating2Screen.bmp
+%%DATADIR%%/graphics/starRating3Screen.bmp
+%%DATADIR%%/graphics/starRating4Screen.bmp
+%%DATADIR%%/graphics/starRating5Screen.bmp
+%%DATADIR%%/graphics/swingLeft.bmp
+%%DATADIR%%/graphics/swingRight.bmp
+%%DATADIR%%/graphics/taskBarIcon.bmp
+%%DATADIR%%/graphics/whale.bmp
+%%DATADIR%%/graphics/worldunlocked.bmp
+%%DATADIR%%/graphics/junglej/backTrees.bmp
+%%DATADIR%%/graphics/junglej/background.bmp
+%%DATADIR%%/graphics/junglej/frame.bmp
+%%DATADIR%%/graphics/junglej/sideTrunks.bmp
+%%DATADIR%%/graphics/junglej/vines.bmp
+%%DATADIR%%/graphics/moltenm/background.bmp
+%%DATADIR%%/graphics/moltenm/distant.bmp
+%%DATADIR%%/graphics/moltenm/frame.bmp
+%%DATADIR%%/graphics/moltenm/hotRocks.bmp
+%%DATADIR%%/graphics/moltenm/middleRocks.bmp
+%%DATADIR%%/graphics/moltenm/normal.bmp
+%%DATADIR%%/graphics/moltenm/rockFallApart.bmp
+%%DATADIR%%/graphics/moltenm/sides.bmp
+%%DATADIR%%/graphics/moltenm/veryHotPlatform.bmp
+%%DATADIR%%/graphics/menuitems/back-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/back-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/cancel-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/cancel-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/instructions-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/instructions-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/music-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/music-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/newgame-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/newgame-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/options-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/options-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/quit-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/quit-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/reset-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/reset-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/sound-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/sound-over-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/sure-reset.bmp
+%%DATADIR%%/graphics/menuitems/yes-menuitem.bmp
+%%DATADIR%%/graphics/menuitems/yes-over-menuitem.bmp
+%%DATADIR%%/graphics/skyscra/background.bmp
+%%DATADIR%%/graphics/skyscra/frame.bmp
+%%DATADIR%%/graphics/skyscra/pipesBack.bmp
+%%DATADIR%%/graphics/skyscra/pipesFore.bmp
+%%DATADIR%%/graphics/skyscra/pipesMid.bmp
+%%DATADIR%%/graphics/skyscra/rain.bmp
+%%DATADIR%%/sounds/AmbienceJungle.wav
+%%DATADIR%%/sounds/AmbienceRain.wav
+%%DATADIR%%/sounds/AmbienceUnderwater.wav
+%%DATADIR%%/sounds/AmbienceVolcano.wav
+%%DATADIR%%/sounds/AmbienceWaterFall.wav
+%%DATADIR%%/sounds/AmbienceWind.wav
+%%DATADIR%%/sounds/Boing1.wav
+%%DATADIR%%/sounds/Boing2.wav
+%%DATADIR%%/sounds/Boing3.wav
+%%DATADIR%%/sounds/BreakingRock.wav
+%%DATADIR%%/sounds/BreakingTree.wav
+%%DATADIR%%/sounds/BurningMonkeyHands.wav
+%%DATADIR%%/sounds/BurningMonkeyHandsEvenMore.wav
+%%DATADIR%%/sounds/CongratsEnding.wav
+%%DATADIR%%/sounds/Congratulations.wav
+%%DATADIR%%/sounds/gameMusic.wav
+%%DATADIR%%/sounds/GetJewel.wav
+%%DATADIR%%/sounds/JetPack.wav
+%%DATADIR%%/sounds/InterfaceSelect.wav
+%%DATADIR%%/sounds/land1.wav
+%%DATADIR%%/sounds/land2.wav
+%%DATADIR%%/sounds/LandingOnSpikes.wav
+%%DATADIR%%/sounds/LandMetal.wav
+%%DATADIR%%/sounds/MonkeyAh4.wav
+%%DATADIR%%/sounds/MonkeyBigHit1.wav
+%%DATADIR%%/sounds/MonkeyBigHit2.wav
+%%DATADIR%%/sounds/MonkeyBigHit3.wav
+%%DATADIR%%/sounds/MonkeyDeath2.wav
+%%DATADIR%%/sounds/MonkeySmallHit1.wav
+%%DATADIR%%/sounds/MonkeySmallHit2.wav
+%%DATADIR%%/sounds/MonkeySmallHit3.wav
+%%DATADIR%%/sounds/Parachute.wav
+%%DATADIR%%/sounds/Piranha.wav
+%%DATADIR%%/sounds/PowerUpBean.wav
+%%DATADIR%%/sounds/PowerUpHealth.wav
+%%DATADIR%%/sounds/PowerUpJet.wav
+%%DATADIR%%/sounds/PowerUpParachute.wav
+%%DATADIR%%/sounds/timeUp.wav
+%%DATADIR%%/sounds/StarRating.wav
+%%DATADIR%%/sounds/titleMusic.mid
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/TIPS
+@dirrm %%DATADIR%%/graphics/crumble
+@dirrm %%DATADIR%%/graphics/frenzie
+@dirrm %%DATADIR%%/graphics/junglej
+@dirrm %%DATADIR%%/graphics/moltenm
+@dirrm %%DATADIR%%/graphics/menuitems
+@dirrm %%DATADIR%%/graphics/skyscra
+@dirrm %%DATADIR%%/graphics
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%