aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2014-12-25 13:49:11 +0000
committerWen Heping <wen@FreeBSD.org>2014-12-25 13:49:11 +0000
commit0ad531667a063e5852b2b7a6bde897d072ab068b (patch)
treede4c25a10dfcf70cd101bf1eb13b8c33b96dff84
parent3275123a1bb3b82707c6a0b3dad822fcd09a43fe (diff)
downloadports-0ad531667a063e5852b2b7a6bde897d072ab068b.tar.gz
ports-0ad531667a063e5852b2b7a6bde897d072ab068b.zip
Define that a user must be logged in and have the proper permissions to
access a route WWW: https://metacpan.org/pod/Dancer2::Plugin::Auth::Extensible::Provider::Usergroup PR: 196191 Submitted by: hvo.pm@xs4all.nl
Notes
Notes: svn path=/head/; revision=375555
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/Makefile24
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/distinfo2
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/pkg-descr4
-rw-r--r--security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/pkg-plist2
5 files changed, 33 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 9c74e8b8704b..b11341a899e1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -536,6 +536,7 @@
SUBDIR += p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup
SUBDIR += p5-Dancer-Plugin-Passphrase
SUBDIR += p5-Dancer2-Plugin-Auth-Extensible
+ SUBDIR += p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup
SUBDIR += p5-Dancer2-Plugin-Passphrase
SUBDIR += p5-Data-Entropy
SUBDIR += p5-Data-Password
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/Makefile b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/Makefile
new file mode 100644
index 000000000000..e8ee7d5cb8de
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/Makefile
@@ -0,0 +1,24 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer2-Plugin-Auth-Extensible-Provider-Usergroup
+PORTVERSION= 0.22
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Extensible authentication framework for Dancer2 apps
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Dancer2>=0.156001:${PORTSDIR}/www/p5-Dancer2 \
+ p5-Dancer2-Plugin-Auth-Extensible>=0:${PORTSDIR}/security/p5-Dancer2-Plugin-Auth-Extensible \
+ p5-Dancer2-Plugin-Passphrase>=0:${PORTSDIR}/security/p5-Dancer2-Plugin-Passphrase
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/distinfo b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/distinfo
new file mode 100644
index 000000000000..18d0abb04f8f
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer2-Plugin-Auth-Extensible-Provider-Usergroup-0.22.tar.gz) = c24087542deabac7a78e3bb58c934d45efd8bb66867400820a5234029e0d3d69
+SIZE (Dancer2-Plugin-Auth-Extensible-Provider-Usergroup-0.22.tar.gz) = 8661
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/pkg-descr b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/pkg-descr
new file mode 100644
index 000000000000..5e3bc21fc472
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/pkg-descr
@@ -0,0 +1,4 @@
+Define that a user must be logged in and have the proper permissions to
+access a route
+
+WWW: https://metacpan.org/pod/Dancer2::Plugin::Auth::Extensible::Provider::Usergroup
diff --git a/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/pkg-plist b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/pkg-plist
new file mode 100644
index 000000000000..54b8ddace0b2
--- /dev/null
+++ b/security/p5-Dancer2-Plugin-Auth-Extensible-Provider-Usergroup/pkg-plist
@@ -0,0 +1,2 @@
+%%PERL5_MAN3%%/Dancer2::Plugin::Auth::Extensible::Provider::Usergroup.3.gz
+%%SITE_PERL%%/Dancer2/Plugin/Auth/Extensible/Provider/Usergroup.pm