aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2019-01-16 01:19:21 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2019-01-16 01:19:21 +0000
commit0b04ed8c7b100d2fd841a1b627b71ac1b846fdba (patch)
tree0f529ba4af046bfe4b06c9fc6824205059f4cd9f
parent20a78f41da98dafb5face7c959a089ab006c9856 (diff)
downloadports-0b04ed8c7b100d2fd841a1b627b71ac1b846fdba.tar.gz
ports-0b04ed8c7b100d2fd841a1b627b71ac1b846fdba.zip
* Updated to 1.0.0
* Added upgrade reminder in pkg-message Changes: https://guacamole.apache.org/releases/1.0.0/
Notes
Notes: svn path=/head/; revision=490440
-rw-r--r--net/guacamole-server/Makefile9
-rw-r--r--net/guacamole-server/distinfo6
-rw-r--r--net/guacamole-server/pkg-plist16
-rw-r--r--www/guacamole-client/Makefile5
-rw-r--r--www/guacamole-client/distinfo10
-rw-r--r--www/guacamole-client/files/pkg-message.in5
-rw-r--r--www/guacamole-client/pkg-plist3
7 files changed, 31 insertions, 23 deletions
diff --git a/net/guacamole-server/Makefile b/net/guacamole-server/Makefile
index 839c4b5e0c65..0c51c2e05ad5 100644
--- a/net/guacamole-server/Makefile
+++ b/net/guacamole-server/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= guacamole-server
-DISTVERSION= 0.9.14
-PORTREVISION= 4
+DISTVERSION= 1.0.0
CATEGORIES= net
MAINTAINER= ultima@FreeBSD.org
@@ -38,8 +37,8 @@ GROUPS= guacamole
SUB_LIST= GUACD_USER=${USERS} \
GUACD_GROUP=${GROUPS}
-OPTIONS_DEFINE= GUACENC NLS SSL WEBP
-OPTIONS_DEFAULT= GUACENC PULSEAUDIO RDP SSH SSL VNC VORBIS WEBP
+OPTIONS_DEFINE= GUACENC GUACLOG NLS SSL WEBP
+OPTIONS_DEFAULT= GUACENC GUACLOG PULSEAUDIO RDP SSH SSL VNC VORBIS WEBP
OPTIONS_GROUP= SP AUDIO
OPTIONS_GROUP_SP= RDP SSH VNC
OPTIONS_GROUP_AUDIO= VORBIS PULSEAUDIO
@@ -47,6 +46,7 @@ OPTIONS_SUB= yes
AUDIO_DESC= Audio Support
GUACENC_DESC= Video Encoding Utility
+GUACLOG_DESC= Input log interpreter
RDP_DESC= RDP protocol support
SP_DESC= Supported Protocols
VNC_DESC= VNC protocol support
@@ -55,6 +55,7 @@ GUACENC_CONFIGURE_ENABLE= guacenc
GUACENC_CONFIGURE_WITH= libavcodec libavutil libswscale
GUACENC_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
GUACENC_CFLAGS= -Wno-error=deprecated
+GUACLOG_CONFIGURE_ENABLE= guaclog
NLS_USES= gettext-runtime
PULSEAUDIO_CONFIGURE_WITH= pulse
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
diff --git a/net/guacamole-server/distinfo b/net/guacamole-server/distinfo
index b0b05aa6359b..eb3ec8915932 100644
--- a/net/guacamole-server/distinfo
+++ b/net/guacamole-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516318156
-SHA256 (apache-guacamole-server-0.9.14_GH0.tar.gz) = 3a4e3f856ebf3daacaf08b93b45a013f919530a11d86cc5c41f858b3bc2984b6
-SIZE (apache-guacamole-server-0.9.14_GH0.tar.gz) = 412667
+TIMESTAMP = 1547246983
+SHA256 (apache-guacamole-server-1.0.0_GH0.tar.gz) = d93d7014a9f2a8f689a790b041cef37326d14982d0ff0c0517f92c84f0bf3ef8
+SIZE (apache-guacamole-server-1.0.0_GH0.tar.gz) = 441591
diff --git a/net/guacamole-server/pkg-plist b/net/guacamole-server/pkg-plist
index 79a7f5dd5259..b378082c1f7b 100644
--- a/net/guacamole-server/pkg-plist
+++ b/net/guacamole-server/pkg-plist
@@ -1,3 +1,5 @@
+%%GUACENC%%bin/guacenc
+%%GUACLOG%%bin/guaclog
%%ETCDIR%%/guacd.conf.sample
include/guacamole/audio-fntypes.h
include/guacamole/audio-types.h
@@ -9,13 +11,13 @@ include/guacamole/client.h
include/guacamole/error-types.h
include/guacamole/error.h
include/guacamole/hash.h
-include/guacamole/parser-constants.h
-include/guacamole/parser-types.h
-include/guacamole/parser.h
include/guacamole/layer-types.h
include/guacamole/layer.h
include/guacamole/object-types.h
include/guacamole/object.h
+include/guacamole/parser-constants.h
+include/guacamole/parser-types.h
+include/guacamole/parser.h
include/guacamole/plugin-constants.h
include/guacamole/plugin.h
include/guacamole/pool-types.h
@@ -54,10 +56,10 @@ include/guacamole/user.h
%%VNC%%lib/libguac-client-vnc.so.0.0.0
lib/libguac.a
lib/libguac.so
-lib/libguac.so.12
-lib/libguac.so.12.3.0
+lib/libguac.so.16
+lib/libguac.so.16.0.0
+%%GUACENC%%man/man1/guacenc.1.gz
+%%GUACLOG%%man/man1/guaclog.1.gz
man/man5/guacd.conf.5.gz
man/man8/guacd.8.gz
-%%GUACENC%%man/man1/guacenc.1.gz
sbin/guacd
-%%GUACENC%%bin/guacenc
diff --git a/www/guacamole-client/Makefile b/www/guacamole-client/Makefile
index cfbe09f7f936..866066bf0844 100644
--- a/www/guacamole-client/Makefile
+++ b/www/guacamole-client/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= guacamole-client
-DISTVERSION= 0.9.14
-PORTREVISION= 1
+DISTVERSION= 1.0.0
CATEGORIES= www java
MASTER_SITES+= https://sourceforge.net/projects/distfiles/files/${PORTNAME}/:repo \
http://sourceforge.net/projects/distfiles/files/${PORTNAME}/:repo
@@ -41,7 +40,7 @@ TOMCAT_DESC= Use Tomcat as your servlet
TOMCAT_RUN_DEPENDS= ${LOCALBASE}/apache-tomcat-8.0/bin/bootstrap.jar:www/tomcat8
SERVER_RUN_DEPENDS= guacd:net/guacamole-server
-AUTH_EXTENSION= cas duo header ldap noauth openid
+AUTH_EXTENSION= cas duo header ldap openid quickconnect totp
post-patch:
@${REINPLACE_CMD} 's|/etc/guacamole|${ETCDIR}| ; \
diff --git a/www/guacamole-client/distinfo b/www/guacamole-client/distinfo
index b5db388296b2..da17e7795014 100644
--- a/www/guacamole-client/distinfo
+++ b/www/guacamole-client/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1516328642
-SHA256 (guacamole-client/repository-0.9.14.tar.xz) = e43889aec0a36c799283d935f4dc3889a62862c9cd68ef25f9ca930c0a113d5d
-SIZE (guacamole-client/repository-0.9.14.tar.xz) = 48252548
-SHA256 (guacamole-client/apache-guacamole-client-0.9.14_GH0.tar.gz) = 2b2df9ee951696c29a2c1d9b0415c7d5742f3dee33da6dea4b52082bd8e04db0
-SIZE (guacamole-client/apache-guacamole-client-0.9.14_GH0.tar.gz) = 5821042
+TIMESTAMP = 1547351778
+SHA256 (guacamole-client/repository-1.0.0.tar.xz) = b2a6d480ddbe40dec2c9af67730574c957dee7c037f21e82538174528b344daa
+SIZE (guacamole-client/repository-1.0.0.tar.xz) = 56084152
+SHA256 (guacamole-client/apache-guacamole-client-1.0.0_GH0.tar.gz) = 6c44a41bbeec50301462f3bef23a479d207e754b604f61044400402f6b2b85ca
+SIZE (guacamole-client/apache-guacamole-client-1.0.0_GH0.tar.gz) = 5978548
diff --git a/www/guacamole-client/files/pkg-message.in b/www/guacamole-client/files/pkg-message.in
index bcf8f3fd06fc..20df17fc94c8 100644
--- a/www/guacamole-client/files/pkg-message.in
+++ b/www/guacamole-client/files/pkg-message.in
@@ -1,6 +1,11 @@
+For a quick Guacamole setup and test:
Guacamole-client requires authentication to start.
cp %%ETCDIR%%/user-mapping.xml.sample \
%%ETCDIR%%/user-mapping.xml
Once tomcat8 and guacd are running
http://localhost:8080/guacamole
+
+For upgrading guacamole, this is a reminder to upgrade
+the auth-extensions. (and database if jdbc is used)
+https://guacamole.apache.org/doc/gug/jdbc-auth.html
diff --git a/www/guacamole-client/pkg-plist b/www/guacamole-client/pkg-plist
index 27da2e6165d3..9e0b3a1a7c6b 100644
--- a/www/guacamole-client/pkg-plist
+++ b/www/guacamole-client/pkg-plist
@@ -7,6 +7,7 @@
%%DATADIR%%/guacamole-auth-header.tar.gz
%%DATADIR%%/guacamole-auth-jdbc.tar.gz
%%DATADIR%%/guacamole-auth-ldap.tar.gz
-%%DATADIR%%/guacamole-auth-noauth.tar.gz
%%DATADIR%%/guacamole-auth-openid.tar.gz
+%%DATADIR%%/guacamole-auth-quickconnect.tar.gz
+%%DATADIR%%/guacamole-auth-totp.tar.gz
%%DATADIR%%/guacamole.war