aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2023-10-09 09:02:14 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2023-10-09 09:02:14 +0000
commit0b4ed72cbba69b466a1356ace2c4302de5b57bc6 (patch)
treefcc9fde19be679680bfe819f1317641b2cf7aff6
parentf22649e35840ddc7d3a19b8e9dd643b3f7885e0f (diff)
downloadports-0b4ed72cbba69b466a1356ace2c4302de5b57bc6.tar.gz
ports-0b4ed72cbba69b466a1356ace2c4302de5b57bc6.zip
emulators/vice: fix build on arm64
PR: 273785
-rw-r--r--emulators/vice/Makefile2
-rw-r--r--emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c14
2 files changed, 14 insertions, 2 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 0af755eaf558..13f589cfa7b0 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vice
PORTVERSION= 3.7.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= SF/vice-emu/releases
diff --git a/emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c b/emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c
index c360674300c3..1fad3f0bf319 100644
--- a/emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c
+++ b/emulators/vice/files/patch-src_arch_shared_iodrv_io-unix-access.c
@@ -1,4 +1,4 @@
---- src/arch/shared/iodrv/io-unix-access.c.orig 2022-12-24 19:44:57 UTC
+--- src/arch/shared/iodrv/io-unix-access.c.orig 2022-12-27 23:56:56 UTC
+++ src/arch/shared/iodrv/io-unix-access.c
@@ -26,6 +26,15 @@
@@ -16,3 +16,15 @@
#ifdef UNIX_COMPILE
#include <fcntl.h>
+@@ -121,7 +130,11 @@ static uint8_t device_io_inb(uint16_t addr)
+ #ifdef HAVE_INBV
+ return inbv(addr);
+ #else
++#ifdef HAVE_INB
+ return inb(addr);
++#else
++ return 0;
++#endif
+ #endif
+ }
+