aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 11:53:34 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 12:52:37 +0000
commit0b6102ed18e864ce2a58f332dca096db34f82dce (patch)
treec41e97e0368691179ed4df6b61b8b845aa718ad9
parent7b5a22aab9be731ac84e6ced719c2fd26b7ca52a (diff)
downloadports-0b6102ed18e864ce2a58f332dca096db34f82dce.tar.gz
ports-0b6102ed18e864ce2a58f332dca096db34f82dce.zip
lang/elk: Fix build with llvm16
- Utilize USES=localbase - Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--lang/elk/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/lang/elk/Makefile b/lang/elk/Makefile
index eb721da18839..4b71aa5cc48e 100644
--- a/lang/elk/Makefile
+++ b/lang/elk/Makefile
@@ -8,17 +8,22 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Embeddable Scheme interpreter
WWW= http://sam.zoy.org/projects/elk/
+ #libelf.so:devel/libelf
LIB_DEPENDS= libgdbm.so:databases/gdbm \
- libelf.so:devel/libelf
+ libXaw.so:x11-toolkits/libXaw
-USES= libtool motif tar:bzip2
-GNU_CONFIGURE= yes
+USES= libtool localbase:ldflags motif tar:bzip2 xorg
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
+USE_XORG= ice sm x11 xext xmu xt
+
+GNU_CONFIGURE= yes
+
INSTALL_TARGET= install-strip
+
MAKE_JOBS_UNSAFE= yes
-CPPFLAGS+= -I${LOCALBASE}/include/libelf -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include/libelf
OPTIONS_DEFINE= EXAMPLES
@@ -28,6 +33,10 @@ OPTIONS_DEFINE= EXAMPLES
CFLAGS= -O0
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s|doc examples||g' ${WRKSRC}/Makefile.in