aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-25 19:45:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-25 19:45:09 +0000
commit0b811a20f7cd4cce60386ef8676593f9133f3a11 (patch)
treee295c61665f1b36379f0a2459cc5e2f984828d47
parent0d310d700aa060b02feec9c7487893a983bf7098 (diff)
downloadports-0b811a20f7cd4cce60386ef8676593f9133f3a11.tar.gz
ports-0b811a20f7cd4cce60386ef8676593f9133f3a11.zip
*/*php*: Final cleanup for php74
Approved by: portmgr (blanket infrastructure) Sponsored by: Bounce Experts
-rw-r--r--lang/php80-extensions/Makefile2
-rw-r--r--lang/php81-extensions/Makefile2
-rw-r--r--lang/php81/Makefile2
-rw-r--r--lang/php82-extensions/Makefile2
-rw-r--r--lang/php82/Makefile2
-rw-r--r--net/pecl-xmlrpc/Makefile1
-rw-r--r--www/osticket/Makefile2
-rw-r--r--www/pecl-http/Makefile1
-rw-r--r--www/typo3-12/Makefile2
9 files changed, 7 insertions, 9 deletions
diff --git a/lang/php80-extensions/Makefile b/lang/php80-extensions/Makefile
index d1239621bae7..eb1e9e6185a8 100644
--- a/lang/php80-extensions/Makefile
+++ b/lang/php80-extensions/Makefile
@@ -9,7 +9,7 @@ WWW= https://www.php.net/
USES= metaport php
PHP_VER= 80
-IGNORE_WITH_PHP= 74 81 82
+IGNORE_WITH_PHP= 81 82
OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
DOM ENCHANT EXIF FILEINFO FILTER FTP GD GETTEXT \
diff --git a/lang/php81-extensions/Makefile b/lang/php81-extensions/Makefile
index c29290d9c37c..4180f6c906b9 100644
--- a/lang/php81-extensions/Makefile
+++ b/lang/php81-extensions/Makefile
@@ -10,7 +10,7 @@ WWW= https://www.php.net/
USES= metaport php
PHP_VER= 81
-IGNORE_WITH_PHP= 74 80 82
+IGNORE_WITH_PHP= 80 82
OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA DOM ENCHANT EXIF FFI \
FILEINFO FILTER FTP GD GETTEXT GMP ICONV IMAP INTL LDAP \
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 7a790edf6c22..a03589d7055a 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -179,7 +179,7 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 81
-IGNORE_WITH_PHP= 74 80
+IGNORE_WITH_PHP= 80 82
EXTSUBDIR= ${DISTNAME}/ext/${PHP_MODNAME}
WRKSRC= ${WRKDIR}/${EXTSUBDIR}
diff --git a/lang/php82-extensions/Makefile b/lang/php82-extensions/Makefile
index 2e4b8d4ec789..5c735ca56e3c 100644
--- a/lang/php82-extensions/Makefile
+++ b/lang/php82-extensions/Makefile
@@ -10,7 +10,7 @@ WWW= https://www.php.net/
USES= metaport php
PHP_VER= 82
-IGNORE_WITH_PHP= 74 80 81
+IGNORE_WITH_PHP= 80 81
OPTIONS_DEFINE= BCMATH BZ2 CALENDAR CTYPE CURL DBA DOM ENCHANT EXIF FFI \
FILEINFO FILTER FTP GD GETTEXT GMP ICONV IMAP INTL LDAP \
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index a95a8fad88bd..899f48f4ac99 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -180,7 +180,7 @@ COMMENT= The ${PHP_MODNAME} shared extension for php
USES+= php:ext,noflavors
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_VER= 82
-IGNORE_WITH_PHP= 74 80 81
+IGNORE_WITH_PHP= 80 81
EXTSUBDIR= ${DISTNAME}/ext/${PHP_MODNAME}
WRKSRC= ${WRKDIR}/${EXTSUBDIR}
diff --git a/net/pecl-xmlrpc/Makefile b/net/pecl-xmlrpc/Makefile
index d1a6008207fd..3bd7e4040496 100644
--- a/net/pecl-xmlrpc/Makefile
+++ b/net/pecl-xmlrpc/Makefile
@@ -11,7 +11,6 @@ WWW= https://pecl.php.net/package/xmlrpc
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 74
USES= iconv:translit gnome php:pecl pkgconfig
USE_PHP= xml:build
USE_GNOME= libxml2
diff --git a/www/osticket/Makefile b/www/osticket/Makefile
index 586f3a2f5c56..95189698fcb6 100644
--- a/www/osticket/Makefile
+++ b/www/osticket/Makefile
@@ -18,7 +18,7 @@ USES= cpe php:web zip
CPE_VENDOR= enhancesoft
USE_PHP= ctype curl dom fileinfo filter gd gettext iconv imap intl json \
mbstring mysqli opcache phar session xml zip
-IGNORE_WITH_PHP= 74 82
+IGNORE_WITH_PHP= 82
NO_ARCH= yes
NO_BUILD= yes
SUB_FILES= pkg-message
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index 5a48c2e18f89..a18124ef1f45 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -24,6 +24,5 @@ RUN_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf2@${PH
USES= php:pecl
USE_PHP= hash:build iconv:build zlib:build
-IGNORE_WITH_PHP= 74
.include <bsd.port.mk>
diff --git a/www/typo3-12/Makefile b/www/typo3-12/Makefile
index b7e714b58310..96bef4b2cf72 100644
--- a/www/typo3-12/Makefile
+++ b/www/typo3-12/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
IGNORE_WITH_MYSQL= 55 56 57 101m 102m
-IGNORE_WITH_PHP= 74 80 82
+IGNORE_WITH_PHP= 80 82
USES= cpe php:web,flavors shebangfix
USE_PHP= ctype dom fileinfo filter gd hash intl json \