aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-29 23:30:46 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-29 23:32:33 +0000
commit0b98cb4e41c9560063cba4da0efd30b391d6275b (patch)
tree3c123cc6f2477e316e547a788c9432c7ed508ce5
parent3fe6962ac26c20788eab32fb3abf146ae9d1ae8e (diff)
downloadports-0b98cb4e41c9560063cba4da0efd30b391d6275b.tar.gz
ports-0b98cb4e41c9560063cba4da0efd30b391d6275b.zip
security/py-flask-bcrypt: New port: Flask extension that provides bcrypt hashing utilities for your application
Flask-Bcrypt is a Flask extension that provides bcrypt hashing utilities for your application. Due to the recent increased prevalence of powerful hardware, such as modern GPUs, hashes have become increasingly easy to crack. A proactive solution to this is to use a hash that was designed to be "de-optimized". Bcrypt is such a hashing facility; unlike hashing algorithms such as MD5 and SHA1, which are optimized for speed, bcrypt is intentionally structured to be slow. For sensitive data that must be protected, such as passwords, bcrypt is an advisable choice.
-rw-r--r--security/Makefile1
-rw-r--r--security/py-flask-bcrypt/Makefile21
-rw-r--r--security/py-flask-bcrypt/distinfo3
-rw-r--r--security/py-flask-bcrypt/pkg-descr11
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 448996693d2a..8b7c7d709195 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -899,6 +899,7 @@
SUBDIR += py-fail2ban
SUBDIR += py-fido2
SUBDIR += py-first-server
+ SUBDIR += py-flask-bcrypt
SUBDIR += py-flask-httpauth
SUBDIR += py-flask-kerberos
SUBDIR += py-flask-saml
diff --git a/security/py-flask-bcrypt/Makefile b/security/py-flask-bcrypt/Makefile
new file mode 100644
index 000000000000..7e9f36525545
--- /dev/null
+++ b/security/py-flask-bcrypt/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= Flask-Bcrypt
+PORTVERSION= 1.0.1
+CATEGORIES= security www python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Flask extension that provides bcrypt hashing utilities for your application
+WWW= https://github.com/maxcountryman/flask-bcrypt
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>0:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}bcrypt>0:security/py-bcrypt@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-flask-bcrypt/distinfo b/security/py-flask-bcrypt/distinfo
new file mode 100644
index 000000000000..5ee43c55a203
--- /dev/null
+++ b/security/py-flask-bcrypt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680277022
+SHA256 (Flask-Bcrypt-1.0.1.tar.gz) = f07b66b811417ea64eb188ae6455b0b708a793d966e1a80ceec4a23bc42a4369
+SIZE (Flask-Bcrypt-1.0.1.tar.gz) = 5996
diff --git a/security/py-flask-bcrypt/pkg-descr b/security/py-flask-bcrypt/pkg-descr
new file mode 100644
index 000000000000..ae8d5a4a5a88
--- /dev/null
+++ b/security/py-flask-bcrypt/pkg-descr
@@ -0,0 +1,11 @@
+Flask-Bcrypt is a Flask extension that provides bcrypt hashing utilities for
+your application.
+
+Due to the recent increased prevalence of powerful hardware, such as modern
+GPUs, hashes have become increasingly easy to crack. A proactive solution to
+this is to use a hash that was designed to be "de-optimized". Bcrypt is such a
+hashing facility; unlike hashing algorithms such as MD5 and SHA1, which are
+optimized for speed, bcrypt is intentionally structured to be slow.
+
+For sensitive data that must be protected, such as passwords, bcrypt is an
+advisable choice.