aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 12:28:43 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 12:52:38 +0000
commit0c1b85fc1dac1c83d4e168ef17319e321c1b6c65 (patch)
tree913e6b9f8c5407db15d5022408267e7003716dcb
parentc09ca3eae83a370c4890921b25ad57e94a729635 (diff)
downloadports-0c1b85fc1dac1c83d4e168ef17319e321c1b6c65.tar.gz
ports-0c1b85fc1dac1c83d4e168ef17319e321c1b6c65.zip
science/libint2: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--science/libint2/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/science/libint2/Makefile b/science/libint2/Makefile
index 732244bfb784..dc248431c546 100644
--- a/science/libint2/Makefile
+++ b/science/libint2/Makefile
@@ -16,21 +16,24 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libgmpxx.so:math/gmp
USES= autoreconf:build compiler:c++11-lang gmake libtool localbase:ldflags
+USE_CXXSTD= c++14
USE_GITHUB= yes
GH_ACCOUNT= evaleev
USE_LDCONFIG= yes
-ALL_TARGET= default
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared \
--enable-1body=1 --enable-eri=1 --enable-eri3=1 --enable-eri2=1 --enable-contracted-ints \
--with-cc-optflags="${CFLAGS}" --with-cxx-optflags="${CXXFLAGS}"
+ALL_TARGET= default
+
+PLIST_SUB= VER=${DISTVERSION}
+
OPTIONS_DEFINE= STATIC # osa@ requested to keep static libs on 2018/08/28
OPTIONS_SUB= yes
-STATIC_CONFIGURE_ENABLE= static
-PLIST_SUB= VER=${DISTVERSION}
+STATIC_CONFIGURE_ENABLE= static
post-patch:
@${REINPLACE_CMD} -e 's| -rpath|${LDFLAGS} -rpath|g' \