aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-02 15:44:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-02 16:32:25 +0000
commit0c1e7c9c383bb22ffda9809a5f66af0155ac9c61 (patch)
treec98b1ea872523c54ca214a5ac9723be8ac53b2b5
parent408b2a2d6052242991f217c1622264eb7aada7a6 (diff)
downloadports-0c1e7c9c383bb22ffda9809a5f66af0155ac9c61.tar.gz
ports-0c1e7c9c383bb22ffda9809a5f66af0155ac9c61.zip
mail/deforaos-mailer: Unbreak on HEAD
- Add missing dependencies reported by poudriere - Pet portclippy Approved by: portmgr (blanket)
-rw-r--r--mail/deforaos-mailer/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/mail/deforaos-mailer/Makefile b/mail/deforaos-mailer/Makefile
index b83a30eae5c3..1cb2f8e28475 100644
--- a/mail/deforaos-mailer/Makefile
+++ b/mail/deforaos-mailer/Makefile
@@ -14,10 +14,13 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libSystem.so:devel/deforaos-libsystem \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz \
+ libfontconfig.so:x11-fonts/fontconfig \
libDesktop.so:x11/deforaos-libdesktop
-USES= desktop-file-utils gnome pkgconfig ssl
-USE_GNOME= gtk20
+USES= gnome pkgconfig ssl
+USE_GNOME= cairo gdkpixbuf2 gtk20
USE_LDCONFIG= yes
MAKE_ARGS+= PREFIX=${PREFIX}
@@ -27,9 +30,10 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-NLS_USES= gettext
+
DOCS_BUILD_DEPENDS= xsltproc:textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl
+NLS_USES= gettext
.include <bsd.port.pre.mk>
@@ -55,6 +59,13 @@ post-patch:
${REINPLACE_CMD} 's|-Wl,-pie||g' \
${WRKSRC}/src/Makefile \
${WRKSRC}/tests/Makefile
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+ ${REINPLACE_CMD} 's/stack-protector-all/stack-protector-all -Wno-error=int-conversion/g' \
+ ${WRKSRC}/src/Makefile \
+ ${WRKSRC}/src/account/Makefile \
+ ${WRKSRC}/src/plugins/Makefile \
+ ${WRKSRC}/tests/Makefile
+.endif
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* \