aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 18:11:32 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-08-16 18:25:19 +0000
commit0c51acb74b16116794d0ff218d43ff3e59d33fa4 (patch)
tree466eae3dd64538b9f78b2faec84d46e659faeebb
parenta29f5f238e14c1c39b9d995e867e1ad131542960 (diff)
downloadports-0c51acb74b16116794d0ff218d43ff3e59d33fa4.tar.gz
ports-0c51acb74b16116794d0ff218d43ff3e59d33fa4.zip
www/p5-AnyEvent-WebSocket-Client: Add missing *_DEPENDS
- Update version requirement of *_DEPENDS - Sort *_DEPENDS - Remove MASTER_SITE_SUBDIR - Fix TEST_DEPENDS - Update pkg-descr - Bump PORTREVISION for dependency change - Take maintainership
-rw-r--r--www/p5-AnyEvent-WebSocket-Client/Makefile22
-rw-r--r--www/p5-AnyEvent-WebSocket-Client/distinfo2
-rw-r--r--www/p5-AnyEvent-WebSocket-Client/pkg-descr11
3 files changed, 18 insertions, 17 deletions
diff --git a/www/p5-AnyEvent-WebSocket-Client/Makefile b/www/p5-AnyEvent-WebSocket-Client/Makefile
index 63d28640e6bf..8ed4a0b7d7f8 100644
--- a/www/p5-AnyEvent-WebSocket-Client/Makefile
+++ b/www/p5-AnyEvent-WebSocket-Client/Makefile
@@ -1,24 +1,26 @@
PORTNAME= AnyEvent-WebSocket-Client
PORTVERSION= 0.55
+PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:PLICEASE
+#MASTER_SITE_SUBDIR= CPAN:PLICEASE
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= WebSocket client for AnyEvent
WWW= https://github.com/plicease/AnyEvent-WebSocket-Client
LICENSE= ART10
-BUILD_DEPENDS= p5-AnyEvent>0:devel/p5-AnyEvent \
- p5-Test2-Suite>0:devel/p5-Test2-Suite
-RUN_DEPENDS:= p5-AnyEvent>0:devel/p5-AnyEvent \
- p5-Moo>0:devel/p5-Moo \
- p5-PerlX-Maybe>0:devel/p5-PerlX-Maybe \
- p5-Protocol-WebSocket>0:www/p5-Protocol-WebSocket \
- p5-URI-ws>0:net/p5-URI-ws \
- p5-URI>0:net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-AnyEvent>=7.13:devel/p5-AnyEvent \
+ p5-AnyEvent-Connector>=0.03:devel/p5-AnyEvent-Connector \
+ p5-Moo>=2.0:devel/p5-Moo \
+ p5-PerlX-Maybe>=0.003:devel/p5-PerlX-Maybe \
+ p5-Protocol-WebSocket>=0.20:www/p5-Protocol-WebSocket \
+ p5-URI>=1.53:net/p5-URI \
+ p5-URI-ws>=0:net/p5-URI-ws
+TEST_DEPENDS= p5-Test2-Suite>=0.000121:devel/p5-Test2-Suite
USES= perl5
USE_PERL5= configure
diff --git a/www/p5-AnyEvent-WebSocket-Client/distinfo b/www/p5-AnyEvent-WebSocket-Client/distinfo
index 4ad888efb4d9..fced63b2ca6e 100644
--- a/www/p5-AnyEvent-WebSocket-Client/distinfo
+++ b/www/p5-AnyEvent-WebSocket-Client/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1691764940
+TIMESTAMP = 1691070002
SHA256 (AnyEvent-WebSocket-Client-0.55.tar.gz) = 55cf0ea6f93f8f4932ead5f9a89b027642ed60381a93528411c7e9331dd4c025
SIZE (AnyEvent-WebSocket-Client-0.55.tar.gz) = 48268
diff --git a/www/p5-AnyEvent-WebSocket-Client/pkg-descr b/www/p5-AnyEvent-WebSocket-Client/pkg-descr
index f69342798747..f893f504a2b4 100644
--- a/www/p5-AnyEvent-WebSocket-Client/pkg-descr
+++ b/www/p5-AnyEvent-WebSocket-Client/pkg-descr
@@ -1,6 +1,5 @@
-This class provides an interface to interact with a web server that
-provides services via the WebSocket protocol in an AnyEvent context.
-It uses Protocol::WebSocket rather than reinventing the wheel. You could
-use AnyEvent and Protocol::WebSocket directly if you wanted finer grain
-control, but if that is not necessary then this class may save you some
-time.
+AnyEvent::WebSocket::Client provides an interface to interact with a web server
+that provides services via the WebSocket protocol in an AnyEvent context. It
+uses Protocol::WebSocket rather than reinventing the wheel. You could use
+AnyEvent and Protocol::WebSocket directly if you wanted finer grain control, but
+if that is not necessary then this class may save you some time.