aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 23:22:34 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-27 23:43:45 +0000
commit0c5c50aacfb407a93575f2f104523055f4c839fa (patch)
tree4e7e81bfe3a1ab74e694c6de4b00a86eef11ec72
parent19497bfc4c10a4b7124fe94a82ee8348b2d3bf1a (diff)
downloadports-0c5c50aacfb407a93575f2f104523055f4c839fa.tar.gz
ports-0c5c50aacfb407a93575f2f104523055f4c839fa.zip
www/libnghttp2: Update to 1.53.0
-rw-r--r--www/libnghttp2/Makefile16
-rw-r--r--www/libnghttp2/distinfo6
-rw-r--r--www/libnghttp2/files/patch-CMakeLists.txt20
-rw-r--r--www/libnghttp2/files/patch-Makefile.in16
-rw-r--r--www/libnghttp2/pkg-plist2
5 files changed, 28 insertions, 32 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index e9e7c1cbaef6..4f4f4911e5d8 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nghttp2
-DISTVERSION= 1.52.0
+PORTVERSION= 1.53.0
CATEGORIES= www net
-MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
+MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -11,12 +11,12 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-USE_LDCONFIG= yes
+USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-CMAKE_OFF= ENABLE_DOC \
- ENABLE_HTTP3
-CMAKE_ON= ENABLE_LIB_ONLY \
- ENABLE_STATIC_LIB
+CONFIGURE_ARGS= --enable-lib-only
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USE_CXXSTD= c++14
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/www/libnghttp2/distinfo b/www/libnghttp2/distinfo
index 367c9878258b..5a1f6869b338 100644
--- a/www/libnghttp2/distinfo
+++ b/www/libnghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1676359019
-SHA256 (nghttp2-1.52.0.tar.xz) = 3ea9f0439e60469ad4d39cb349938684ffb929dd7e8e06a7bffe9f9d21f8ba7d
-SIZE (nghttp2-1.52.0.tar.xz) = 1491732
+TIMESTAMP = 1685162050
+SHA256 (nghttp2-1.53.0.tar.xz) = b867184254e5a29b0ba68413aa14f8b0ce1142a371761374598dec092dabb809
+SIZE (nghttp2-1.53.0.tar.xz) = 1543180
diff --git a/www/libnghttp2/files/patch-CMakeLists.txt b/www/libnghttp2/files/patch-CMakeLists.txt
deleted file mode 100644
index 9eb3864499c1..000000000000
--- a/www/libnghttp2/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
---- CMakeLists.txt.orig 2022-12-24 08:18:29 UTC
-+++ CMakeLists.txt
-@@ -503,7 +503,7 @@ include_directories(
- set(PKGDATADIR "${CMAKE_INSTALL_FULL_DATADIR}/${CMAKE_PROJECT_NAME}")
- set(PKGLIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}/${CMAKE_PROJECT_NAME}")
-
--install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
-+#install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
-
- add_subdirectory(lib)
- #add_subdirectory(lib/includes)
-@@ -519,7 +519,7 @@ if(ENABLE_DOC)
- add_subdirectory(doc)
- endif()
- add_subdirectory(contrib)
--add_subdirectory(script)
-+#add_subdirectory(script)
- add_subdirectory(bpf)
-
-
diff --git a/www/libnghttp2/files/patch-Makefile.in b/www/libnghttp2/files/patch-Makefile.in
new file mode 100644
index 000000000000..d4174dca7bda
--- /dev/null
+++ b/www/libnghttp2/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig 2023-02-13 12:02:52 UTC
++++ Makefile.in
+@@ -448,11 +448,10 @@ top_srcdir = @top_srcdir@
+ # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+ # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+ # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+-SUBDIRS = lib third-party src bpf examples tests integration-tests \
+- doc contrib script
++SUBDIRS = lib
+
+ ACLOCAL_AMFLAGS = -I m4
+-dist_doc_DATA = README.rst
++dist_doc_DATA =
+ EXTRA_DIST = nghttpx.conf.sample proxy.pac.sample android-config android-env \
+ Dockerfile.android \
+ cmakeconfig.h.in \
diff --git a/www/libnghttp2/pkg-plist b/www/libnghttp2/pkg-plist
index fc71897d44a1..ed807891ee4c 100644
--- a/www/libnghttp2/pkg-plist
+++ b/www/libnghttp2/pkg-plist
@@ -3,5 +3,5 @@ include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
lib/libnghttp2.so
lib/libnghttp2.so.14
-lib/libnghttp2.so.14.24.1
+lib/libnghttp2.so.14.24.2
libdata/pkgconfig/libnghttp2.pc