aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 13:29:22 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 17:42:34 +0000
commit0c6028e22f9e0629c01205dd56d5baedfe251bfc (patch)
tree0e136ab80bbcfe1934d3245d121238a4a7eba5e6
parentb997f300ebba0c6ffd467394efe8afa0fa8bb02a (diff)
downloadports-0c6028e22f9e0629c01205dd56d5baedfe251bfc.tar.gz
ports-0c6028e22f9e0629c01205dd56d5baedfe251bfc.zip
games/aquaria: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--games/aquaria/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/games/aquaria/Makefile b/games/aquaria/Makefile
index aca4d2d93fc8..0190b93653c5 100644
--- a/games/aquaria/Makefile
+++ b/games/aquaria/Makefile
@@ -20,14 +20,12 @@ LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libpng.so:graphics/png \
libtinyxml2.so:textproc/tinyxml2
+USES= cmake:insource compiler:c++11-lang lua:51 openal pkgconfig sdl
+USE_CXXSTD= c++11
USE_GITHUB= yes
GH_ACCOUNT= AquariaOSE
GH_PROJECT= Aquaria
-USES= cmake:insource compiler:c++11-lang lua:51 openal pkgconfig sdl
-EXCLUDE= AL FTGL GL SDL* freetype2 glm glpng/png glpng/zlib \
- libogg-* libvorbis-* lua-* tinyxml2*
-EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ExternalLibs/,}
CMAKE_ARGS= -DAQUARIA_DEFAULT_DATA_DIR:PATH="${DATADIR}"
CMAKE_OFF= AQUARIA_INTERNAL_FREETYPE \
AQUARIA_INTERNAL_FTGL \
@@ -38,11 +36,9 @@ CMAKE_OFF= AQUARIA_INTERNAL_FREETYPE \
AQUARIA_INTERNAL_SDL \
AQUARIA_INTERNAL_TINYXML2 \
AQUARIA_INTERNAL_ZLIB
+
LDFLAGS+= -Wl,--as-needed # avoid overlinking (vorbis deps)
LDFLAGS_i386= -Wl,-z,notext -Wl,--no-check-dynamic-relocations
-SUB_FILES= pkg-message
-PLIST_FILES= bin/aquaria
-PORTDATA= *
DESKTOP_ENTRIES="${GH_PROJECT}" \
"" \
@@ -50,14 +46,23 @@ DESKTOP_ENTRIES="${GH_PROJECT}" \
"${PORTNAME}" \
"Game;ArcadeGame;" \
""
+EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ExternalLibs/,}
+SUB_FILES= pkg-message
+
+PLIST_FILES= bin/aquaria
+PORTDATA= *
OPTIONS_DEFINE= SDL2
OPTIONS_DEFAULT=SDL2
SDL2_DESC= Use SDL 2.x instead of SDL 1.2.x
-SDL2_CMAKE_BOOL=AQUARIA_USE_SDL2
+
SDL2_USE= SDL=sdl2
SDL2_USE_OFF= SDL=sdl
+SDL2_CMAKE_BOOL=AQUARIA_USE_SDL2
+
+EXCLUDE= AL FTGL GL SDL* freetype2 glm glpng/png glpng/zlib \
+ libogg-* libvorbis-* lua-* tinyxml2*
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin