aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-05-06 21:43:21 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-05-06 23:06:49 +0000
commit0ca297ebde9208e840817e54bdaac21bab4bdbc2 (patch)
tree96a1738cad3709d5c55eb79d2cc75178355884f6
parent27e4f43fc62071c02469eb90b9aba13aa6b372c7 (diff)
downloadports-0ca297ebde9208e840817e54bdaac21bab4bdbc2.tar.gz
ports-0ca297ebde9208e840817e54bdaac21bab4bdbc2.zip
databases/arrow: unbreak build after 4aec6e124381
In file included from cpp/src/arrow/ipc/test_common.cc:36: In file included from cpp/src/arrow/testing/builder.h:29: In file included from cpp/src/arrow/testing/gtest_util.h:31: In file included from /usr/local/include/gtest/gtest.h:64: In file included from /usr/local/include/gtest/gtest-assertion-result.h:46: In file included from /usr/local/include/gtest/gtest-message.h:57: /usr/local/include/gtest/internal/gtest-port.h:270:2: error: C++ versions less than C++14 are not supported. #error C++ versions less than C++14 are not supported. ^ Reported by: pkg-fallout
-rw-r--r--databases/arrow/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/arrow/Makefile b/databases/arrow/Makefile
index 4c1cf85ebcd1..1202eee45594 100644
--- a/databases/arrow/Makefile
+++ b/databases/arrow/Makefile
@@ -17,12 +17,13 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE.txt
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-USES= cmake compiler:c++11-lang localbase pkgconfig python:build
+USES= cmake compiler:c++14-lang localbase pkgconfig python:build
+USE_CXXSTD= c++14 # googletest 1.13
USE_LDCONFIG= yes
WRKSRC_SUBDIR= cpp
-CMAKE_ARGS= -DARROW_SIMD_LEVEL=NONE -DARROW_RUNTIME_SIMD_LEVEL=NONE
+CMAKE_ARGS= -DCMAKE_CXX_STANDARD=14 -DARROW_SIMD_LEVEL=NONE -DARROW_RUNTIME_SIMD_LEVEL=NONE
CMAKE_OFF= ARROW_BUILD_STATIC ARROW_WITH_BACKTRACE ARROW_BUILD_TESTS ARROW_BUILD_BENCHMARKS
OPTIONS_GROUP= COMPRESSION COMPONENTS # components are listed in cpp/cmake_modules/DefineOptions.cmake