aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2013-05-18 11:57:57 +0000
committerMax Khon <fjoe@FreeBSD.org>2013-05-18 11:57:57 +0000
commit0ca6e0b9525ee6e939ae244754fe2f333961bc78 (patch)
tree11ee4adcb9dbe8b88ae1e0086636002f60524d68
parent4442797212b4a54f726533e058f2a40b9a9f6f22 (diff)
downloadports-0ca6e0b9525ee6e939ae244754fe2f333961bc78.tar.gz
ports-0ca6e0b9525ee6e939ae244754fe2f333961bc78.zip
- Update to last released 4.8.8.
- Switch to the official master site now that http://midnight-commander.org/ is back.
Notes
Notes: svn path=/head/; revision=318426
-rw-r--r--misc/mc/Makefile12
-rw-r--r--misc/mc/distinfo4
-rw-r--r--misc/mc/files/patch-mc-editor46
-rw-r--r--misc/mc/pkg-plist134
4 files changed, 19 insertions, 177 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index a9e3d186f3ad..989c9a187f77 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -2,14 +2,10 @@
# $FreeBSD$
PORTNAME= mc
-PORTVERSION= 4.8.1.7
+PORTVERSION= 4.8.8
PORTREVISION= 0
CATEGORIES= misc shells
-#MASTER_SITES= http://www.midnight-commander.org/downloads/
-#MASTER_SITE_SUBDIR= utils/file/managers/mc
-MASTER_SITES= ${MASTER_SITE_LOCAL}\
- http://people.freebsd.org/~fjoe/
-MASTER_SITE_SUBDIR= fjoe
+MASTER_SITES= http://ftp.osuosl.org/pub/midnightcommander/
MAINTAINER= fjoe@FreeBSD.org
COMMENT= Midnight Commander, a free Norton Commander Clone
@@ -27,6 +23,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= ZIP=${UNZIP_CMD} UNZIP=${UNZIP_CMD}
USE_AUTOTOOLS= libtool
+PORTDATA= *
+
OPTIONS= SLANG "Build with SLang library" on \
ICONV "Build with iconv recoding" on \
NLS "Build with NLS support" on \
@@ -48,10 +46,8 @@ CONFIGURE_ARGS+=--enable-vfs-smb --with-configdir=${LOCALBASE}/etc\
.if defined(WITH_ICONV) || !(defined(WITHOUT_ICONV) || defined(MINIMAL))
USES+= iconv
-PLIST_SUB= CHARSETS=""
.else
CONFIGURE_ARGS+=--disable-charset
-PLIST_SUB= CHARSETS="@comment "
.endif
.if !defined(WITH_NLS) && (defined(WITHOUT_NLS) || defined(MINIMAL))
diff --git a/misc/mc/distinfo b/misc/mc/distinfo
index e0a82728b6ba..23eff1371598 100644
--- a/misc/mc/distinfo
+++ b/misc/mc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mc-4.8.1.7.tar.xz) = ea5340c35735e374eed9b92268e80a12121a8fdf21ec249fef095fe2522faf9c
-SIZE (mc-4.8.1.7.tar.xz) = 2049316
+SHA256 (mc-4.8.8.tar.xz) = b898a343b2b11274a20b2a491f9f5422b6d041e65e152c56d7255084fd04b78b
+SIZE (mc-4.8.8.tar.xz) = 2150988
diff --git a/misc/mc/files/patch-mc-editor b/misc/mc/files/patch-mc-editor
deleted file mode 100644
index 1129f4781783..000000000000
--- a/misc/mc/files/patch-mc-editor
+++ /dev/null
@@ -1,46 +0,0 @@
-Index: src/filemanager/ext.c
-===================================================================
---- src/filemanager/ext.c (revision 05d220a9c6f31134373e4326608a6d7e9cbb20f1)
-+++ src/filemanager/ext.c (revision 529a7ba24c9da9fdb1df939ff0fe35c6d27e65df)
-@@ -637,4 +637,7 @@
- int have_type = 0; /* Flag used by regex_check_type() */
-
-+ if (filename_vpath == NULL)
-+ return 0;
-+
- /* Check for the special View:%d parameter */
- if (strncmp (action, "View:", 5) == 0)
-Index: src/filemanager/midnight.c
-===================================================================
---- src/filemanager/midnight.c (revision 308237aa11bf34450340574131a9894a1892e997)
-+++ src/filemanager/midnight.c (revision 529a7ba24c9da9fdb1df939ff0fe35c6d27e65df)
-@@ -952,9 +952,11 @@
- case MC_RUN_EDITOR:
- {
-- vfs_path_t *param_vpath;
--
-- param_vpath = vfs_path_from_str (mc_run_param0);
-- ret = edit_file (param_vpath, mc_args__edit_start_line);
-- vfs_path_free (param_vpath);
-+ vfs_path_t *vpath = NULL;
-+
-+ if (mc_run_param0 != NULL && *mc_run_param0 != '\0')
-+ vpath = vfs_path_from_str (mc_run_param0);
-+
-+ ret = edit_file (vpath, mc_args__edit_start_line);
-+ vfs_path_free (vpath);
- }
- break;
-@@ -962,7 +964,9 @@
- case MC_RUN_VIEWER:
- {
-- vfs_path_t *vpath;
--
-- vpath = prepend_cwd_on_local (mc_run_param0);
-+ vfs_path_t *vpath = NULL;
-+
-+ if (mc_run_param0 != NULL && *mc_run_param0 != '\0')
-+ vpath = prepend_cwd_on_local (mc_run_param0);
-+
- view_file (vpath, 0, 1);
- vfs_path_free (vpath);
diff --git a/misc/mc/pkg-plist b/misc/mc/pkg-plist
index cc26788b8fb2..bd41e2c892db 100644
--- a/misc/mc/pkg-plist
+++ b/misc/mc/pkg-plist
@@ -3,16 +3,24 @@ bin/mcdiff
%%EDITOR%%bin/mcedit
bin/mcview
%%EDITOR%%etc/mc/edit.indent.rc
-%%EDITOR%%etc/mc/edit.spell.rc
etc/mc/filehighlight.ini
+etc/mc/mc.default.keymap
+etc/mc/mc.emacs.keymap
etc/mc/mc.ext
etc/mc/mc.keymap
-etc/mc/mc.keymap.default
-etc/mc/mc.keymap.emacs
etc/mc/mc.menu
etc/mc/mc.menu.sr
etc/mc/mcedit.menu
etc/mc/sfs.ini
+libexec/mc/ext.d/archive.sh
+libexec/mc/ext.d/doc.sh
+libexec/mc/ext.d/image.sh
+libexec/mc/ext.d/misc.sh
+libexec/mc/ext.d/package.sh
+libexec/mc/ext.d/sound.sh
+libexec/mc/ext.d/text.sh
+libexec/mc/ext.d/video.sh
+libexec/mc/ext.d/web.sh
libexec/mc/extfs.d/README
libexec/mc/extfs.d/README.extfs
libexec/mc/extfs.d/a+
@@ -45,6 +53,7 @@ libexec/mc/extfs.d/uc1541
libexec/mc/extfs.d/ucab
libexec/mc/extfs.d/uha
libexec/mc/extfs.d/ulha
+libexec/mc/extfs.d/ulib
libexec/mc/extfs.d/urar
libexec/mc/extfs.d/uzip
libexec/mc/extfs.d/uzoo
@@ -117,124 +126,6 @@ libexec/mc/mc.sh
%%NLS%%share/locale/wa/LC_MESSAGES/mc.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/mc.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/mc.mo
-%%DATADIR%%/examples/macros.d/macro.0.sh
-%%DATADIR%%/examples/macros.d/macro.1.sh
-%%DATADIR%%/examples/macros.d/macro.3.sh
-%%DATADIR%%/examples/macros.d/macro.4.sh
-%%DATADIR%%/examples/macros.d/macro.5.sh
-%%DATADIR%%/examples/macros.d/macro.6.sh
-%%DATADIR%%/examples/macros.d/macro.7.sh
-%%DATADIR%%/help/mc.hlp
-%%NLS%%%%DATADIR%%/help/mc.hlp.es
-%%NLS%%%%DATADIR%%/help/mc.hlp.hu
-%%NLS%%%%DATADIR%%/help/mc.hlp.it
-%%NLS%%%%DATADIR%%/help/mc.hlp.pl
-%%NLS%%%%DATADIR%%/help/mc.hlp.ru
-%%NLS%%%%DATADIR%%/help/mc.hlp.sr
-%%DATADIR%%/hints/mc.hint
-%%NLS%%%%DATADIR%%/hints/mc.hint.cs
-%%NLS%%%%DATADIR%%/hints/mc.hint.es
-%%NLS%%%%DATADIR%%/hints/mc.hint.hu
-%%NLS%%%%DATADIR%%/hints/mc.hint.it
-%%NLS%%%%DATADIR%%/hints/mc.hint.nl
-%%NLS%%%%DATADIR%%/hints/mc.hint.pl
-%%NLS%%%%DATADIR%%/hints/mc.hint.ru
-%%NLS%%%%DATADIR%%/hints/mc.hint.sr
-%%NLS%%%%DATADIR%%/hints/mc.hint.uk
-%%NLS%%%%DATADIR%%/hints/mc.hint.zh
-%%CHARSETS%%%%DATADIR%%/mc.charsets
-%%DATADIR%%/mc.lib
-%%DATADIR%%/skins/dark.ini
-%%DATADIR%%/skins/darkfar.ini
-%%DATADIR%%/skins/default.ini
-%%DATADIR%%/skins/double-lines.ini
-%%DATADIR%%/skins/featured.ini
-%%DATADIR%%/skins/gotar.ini
-%%DATADIR%%/skins/mc46.ini
-%%DATADIR%%/skins/nicedark.ini
-%%DATADIR%%/skins/sand256.ini
-%%DATADIR%%/skins/xoria256.ini
-%%EDITOR%%%%DATADIR%%/syntax/PKGBUILD.syntax
-%%EDITOR%%%%DATADIR%%/syntax/Syntax
-%%EDITOR%%%%DATADIR%%/syntax/ada95.syntax
-%%EDITOR%%%%DATADIR%%/syntax/as.syntax
-%%EDITOR%%%%DATADIR%%/syntax/aspx.syntax
-%%EDITOR%%%%DATADIR%%/syntax/assembler.syntax
-%%EDITOR%%%%DATADIR%%/syntax/awk.syntax
-%%EDITOR%%%%DATADIR%%/syntax/c.syntax
-%%EDITOR%%%%DATADIR%%/syntax/cabal.syntax
-%%EDITOR%%%%DATADIR%%/syntax/changelog.syntax
-%%EDITOR%%%%DATADIR%%/syntax/cmake.syntax
-%%EDITOR%%%%DATADIR%%/syntax/cs.syntax
-%%EDITOR%%%%DATADIR%%/syntax/css.syntax
-%%EDITOR%%%%DATADIR%%/syntax/cxx.syntax
-%%EDITOR%%%%DATADIR%%/syntax/cython.syntax
-%%EDITOR%%%%DATADIR%%/syntax/d.syntax
-%%EDITOR%%%%DATADIR%%/syntax/debian-changelog.syntax
-%%EDITOR%%%%DATADIR%%/syntax/debian-control.syntax
-%%EDITOR%%%%DATADIR%%/syntax/debian-description.syntax
-%%EDITOR%%%%DATADIR%%/syntax/debian-sources-list.syntax
-%%EDITOR%%%%DATADIR%%/syntax/diff.syntax
-%%EDITOR%%%%DATADIR%%/syntax/dlink.syntax
-%%EDITOR%%%%DATADIR%%/syntax/dos.syntax
-%%EDITOR%%%%DATADIR%%/syntax/ebuild.syntax
-%%EDITOR%%%%DATADIR%%/syntax/eiffel.syntax
-%%EDITOR%%%%DATADIR%%/syntax/erlang.syntax
-%%EDITOR%%%%DATADIR%%/syntax/f90.syntax
-%%EDITOR%%%%DATADIR%%/syntax/filehighlight.syntax
-%%EDITOR%%%%DATADIR%%/syntax/fortran.syntax
-%%EDITOR%%%%DATADIR%%/syntax/haskell.syntax
-%%EDITOR%%%%DATADIR%%/syntax/html.syntax
-%%EDITOR%%%%DATADIR%%/syntax/idl.syntax
-%%EDITOR%%%%DATADIR%%/syntax/ini.syntax
-%%EDITOR%%%%DATADIR%%/syntax/j.syntax
-%%EDITOR%%%%DATADIR%%/syntax/java.syntax
-%%EDITOR%%%%DATADIR%%/syntax/js.syntax
-%%EDITOR%%%%DATADIR%%/syntax/latex.syntax
-%%EDITOR%%%%DATADIR%%/syntax/lisp.syntax
-%%EDITOR%%%%DATADIR%%/syntax/lsm.syntax
-%%EDITOR%%%%DATADIR%%/syntax/lua.syntax
-%%EDITOR%%%%DATADIR%%/syntax/m4.syntax
-%%EDITOR%%%%DATADIR%%/syntax/mail.syntax
-%%EDITOR%%%%DATADIR%%/syntax/makefile.syntax
-%%EDITOR%%%%DATADIR%%/syntax/ml.syntax
-%%EDITOR%%%%DATADIR%%/syntax/named.syntax
-%%EDITOR%%%%DATADIR%%/syntax/nemerle.syntax
-%%EDITOR%%%%DATADIR%%/syntax/nroff.syntax
-%%EDITOR%%%%DATADIR%%/syntax/octave.syntax
-%%EDITOR%%%%DATADIR%%/syntax/pascal.syntax
-%%EDITOR%%%%DATADIR%%/syntax/perl.syntax
-%%EDITOR%%%%DATADIR%%/syntax/php.syntax
-%%EDITOR%%%%DATADIR%%/syntax/po.syntax
-%%EDITOR%%%%DATADIR%%/syntax/povray.syntax
-%%EDITOR%%%%DATADIR%%/syntax/procmail.syntax
-%%EDITOR%%%%DATADIR%%/syntax/properties.syntax
-%%EDITOR%%%%DATADIR%%/syntax/python.syntax
-%%EDITOR%%%%DATADIR%%/syntax/ruby.syntax
-%%EDITOR%%%%DATADIR%%/syntax/sh.syntax
-%%EDITOR%%%%DATADIR%%/syntax/slang.syntax
-%%EDITOR%%%%DATADIR%%/syntax/smalltalk.syntax
-%%EDITOR%%%%DATADIR%%/syntax/spec.syntax
-%%EDITOR%%%%DATADIR%%/syntax/sql.syntax
-%%EDITOR%%%%DATADIR%%/syntax/strace.syntax
-%%EDITOR%%%%DATADIR%%/syntax/swig.syntax
-%%EDITOR%%%%DATADIR%%/syntax/syntax.syntax
-%%EDITOR%%%%DATADIR%%/syntax/tcl.syntax
-%%EDITOR%%%%DATADIR%%/syntax/texinfo.syntax
-%%EDITOR%%%%DATADIR%%/syntax/tt.syntax
-%%EDITOR%%%%DATADIR%%/syntax/unknown.syntax
-%%EDITOR%%%%DATADIR%%/syntax/verilog.syntax
-%%EDITOR%%%%DATADIR%%/syntax/vhdl.syntax
-%%EDITOR%%%%DATADIR%%/syntax/xml.syntax
-%%EDITOR%%%%DATADIR%%/syntax/yum-repo.syntax
-%%EDITOR%%%%DATADIR%%/syntax/yxx.syntax
-%%EDITOR%%@dirrm %%DATADIR%%/syntax
-@dirrm %%DATADIR%%/skins
-@dirrm %%DATADIR%%/hints
-@dirrm %%DATADIR%%/help
-@dirrm %%DATADIR%%/examples/macros.d
-@dirrm %%DATADIR%%/examples
-@dirrm %%DATADIR%%
%%NLS%%@dirrmtry share/locale/sv_SE/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/sv_SE
%%NLS%%@dirrmtry share/locale/it_IT/LC_MESSAGES
@@ -247,5 +138,6 @@ libexec/mc/mc.sh
%%NLS%%@dirrmtry share/locale/de_CH
@dirrm libexec/mc/fish
@dirrm libexec/mc/extfs.d
+@dirrm libexec/mc/ext.d
@dirrm libexec/mc
@dirrm etc/mc