aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-06-05 15:19:51 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-06-05 15:19:51 +0000
commit0ce9a5d60b55b765ca3099b48871beccf2080dd6 (patch)
treeaf4102e0d0d925791b4bc2ab360be927de853f7f
parent5b1f2cff0ed195b4a215b78c2f58b6ff21c5f4ac (diff)
downloadports-0ce9a5d60b55b765ca3099b48871beccf2080dd6.tar.gz
ports-0ce9a5d60b55b765ca3099b48871beccf2080dd6.zip
Add cad/pcb-rnd: Flexible, modular Printed Circuit Board editor
PR: 264289
-rw-r--r--cad/Makefile1
-rw-r--r--cad/librnd/Makefile81
-rw-r--r--cad/librnd/distinfo3
-rw-r--r--cad/librnd/files/patch-scconfig_src_gui_find__lesstif2.c13
-rw-r--r--cad/librnd/files/patch-scconfig_src_gui_find__misc.c13
-rw-r--r--cad/librnd/files/patch-scconfig_src_gui_find__x.c15
-rw-r--r--cad/librnd/pkg-descr8
-rw-r--r--cad/librnd/pkg-plist254
8 files changed, 388 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 3229fe0b7c5f..d1ae58b9eb62 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -75,6 +75,7 @@
SUBDIR += librecad
SUBDIR += libredwg
SUBDIR += librepcb
+ SUBDIR += librnd
SUBDIR += linux-eagle5
SUBDIR += logisim
SUBDIR += magic
diff --git a/cad/librnd/Makefile b/cad/librnd/Makefile
new file mode 100644
index 000000000000..9988eafb1178
--- /dev/null
+++ b/cad/librnd/Makefile
@@ -0,0 +1,81 @@
+PORTNAME= librnd
+DISTVERSION= 3.1.2
+CATEGORIES= cad
+MASTER_SITES= http://repo.hu/projects/${PORTNAME}/releases/
+
+MAINTAINER= fuz@fuz.su
+COMMENT= Flexible, modular two-dimensional CAD engine
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfungw.so:devel/fungw
+
+USES= gmake pkgconfig tar:bz2
+USE_LDCONFIG= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --all=plugin --plugin-hid_remote
+TEST_TARGET= test
+BINARY_ALIAS= make=${MAKE_CMD}
+
+OPTIONS_DEFINE= DOCS GD MOTIF GTK2 GTK2GL GTK4 STROKE WGET
+OPTIONS_DEFAULT= GD GTK2 GTK2GL STROKE WGET
+OPTIONS_SUB= yes
+GTK2GL_DESC= GTK+ 2 GUI with OpenGL support
+GTK4_DESC= GTK+ 4 GUI toolkit support
+WGET_DESC= Wget support
+
+GD_LIB_DEPENDS= libgd.so:graphics/gd
+GD_CONFIGURE_OFF= --disable-gd
+
+GTK2GL_IMPLIES= GTK2
+GTK2GL_LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
+GTK2GL_USES= gl
+GTK2GL_USE= gl=gl,glu gnome=pangox-compat xorg=x11
+GTK2GL_CONFIGURE_OFF= --disable-hid_gtk2_gl
+
+GTK2_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
+GTK2_USES= gnome
+GTK2_USE= gnome=cairo,gdkpixbuf2,gtk20
+GTK2_CONFIGURE_OFF= --disable-hid_gtk2_gdk
+
+GTK4_IMPLIES= GTK2
+GTK4_LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
+ libgraphene-1.0.so:graphics/graphene \
+ libharfbuzz.so:print/harfbuzz \
+ libvulkan.so:graphics/vulkan-loader
+GTK4_USES= gl gnome
+GTK4_USE= gl=gl,glu gnome=cairo,gdkpixbuf2,gtk40
+GTK4_CONFIGURE_OFF= --disable-hid_gtk4_gl
+
+MOTIF_USES= motif
+MOTIF_USE= xorg=xt,x11,xinerama,xrender
+MOTIF_CONFIGURE_OFF= --disable-hid_lesstif
+
+STROKE_LIB_DEPENDS= libstroke.so:devel/libstroke
+STROKE_CONFIGURE_OFF= --disable-stroke
+
+WGET_RUN_DEPENDS= wget:ftp/wget
+WGET_CONFIGURE_OFF= --disable-lib_wget
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK4} || ${PORT_OPTIONS:MMOTIF}
+PLIST_SUB+= GUI=""
+.else
+PLIST_SUB+= GUI="@comment "
+.endif
+
+pre-configure:
+ ${REINPLACE_CMD} \
+ -e 's,%%LOCALBASE%%,${LOCALBASE},' \
+ -e 's,%%MOTIFLIB%%,${MOTIFLIB},' \
+ ${WRKSRC}/scconfig/src/gui/find_gl.c \
+ ${WRKSRC}/scconfig/src/gui/find_lesstif2.c \
+ ${WRKSRC}/scconfig/src/gui/find_misc.c \
+ ${WRKSRC}/scconfig/src/gui/find_x.c
+
+.include <bsd.port.post.mk>
diff --git a/cad/librnd/distinfo b/cad/librnd/distinfo
new file mode 100644
index 000000000000..04e9345c89e2
--- /dev/null
+++ b/cad/librnd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1653657927
+SHA256 (librnd-3.1.2.tar.bz2) = 8510d434e63fad66c599cae40a01c291a8b94e2473fa9472d76c8de8a31c4e1b
+SIZE (librnd-3.1.2.tar.bz2) = 1238925
diff --git a/cad/librnd/files/patch-scconfig_src_gui_find__lesstif2.c b/cad/librnd/files/patch-scconfig_src_gui_find__lesstif2.c
new file mode 100644
index 000000000000..ba82cfabd1e2
--- /dev/null
+++ b/cad/librnd/files/patch-scconfig_src_gui_find__lesstif2.c
@@ -0,0 +1,13 @@
+--- scconfig/src/gui/find_lesstif2.c.orig 2022-05-06 17:10:54 UTC
++++ scconfig/src/gui/find_lesstif2.c
+@@ -45,8 +45,8 @@ int find_lesstif2(const char *name, int logdepth, int
+ NL;
+
+ const char *node = "libs/gui/lesstif2";
+- char **cflags, *cflags_arr[] = {"", "-I/opt/X11/include", NULL};
+- char **ldflags, *ldflags_arr[] = {"-lXm -lX11", "-lXm -lXt", "-L/opt/X11/lib -lXm -lXt -lX11", NULL}; /* note: -lXt must be after -lXm else lesstif fails to init with runtime error */
++ char **cflags, *cflags_arr[] = {"-I%%LOCALBASE%%/include", "", "-I/opt/X11/include", NULL};
++ char **ldflags, *ldflags_arr[] = {"%%MOTIFLIB%% -lXt -lX11", "-lXm -lX11", "-lXm -lXt", "-L/opt/X11/lib -lXm -lXt -lX11", NULL}; /* note: -lXt must be after -lXm else lesstif fails to init with runtime error */
+
+ if (require("cc/cc", logdepth, fatal))
+ return 1;
diff --git a/cad/librnd/files/patch-scconfig_src_gui_find__misc.c b/cad/librnd/files/patch-scconfig_src_gui_find__misc.c
new file mode 100644
index 000000000000..a5292eb22b63
--- /dev/null
+++ b/cad/librnd/files/patch-scconfig_src_gui_find__misc.c
@@ -0,0 +1,13 @@
+--- scconfig/src/gui/find_misc.c.orig 2022-05-06 18:29:16 UTC
++++ scconfig/src/gui/find_misc.c
+@@ -45,8 +45,8 @@ int find_libstroke(const char *name, int logdepth, int
+ NL;
+
+ const char *node = "libs/gui/libstroke";
+- char **cflags, *cflags_arr[] = {"", NULL};
+- char **ldflags, *ldflags_arr[] = {"-lstroke", NULL};
++ char **cflags, *cflags_arr[] = {"-I%%LOCALBASE%%/include", NULL};
++ char **ldflags, *ldflags_arr[] = {"-L%%LOCALBASE%%/lib -lstroke", NULL};
+
+ if (require("cc/cc", logdepth, fatal))
+ return 1;
diff --git a/cad/librnd/files/patch-scconfig_src_gui_find__x.c b/cad/librnd/files/patch-scconfig_src_gui_find__x.c
new file mode 100644
index 000000000000..faffd25a346d
--- /dev/null
+++ b/cad/librnd/files/patch-scconfig_src_gui_find__x.c
@@ -0,0 +1,15 @@
+--- scconfig/src/gui/find_x.c.orig 2018-12-09 09:02:02 UTC
++++ scconfig/src/gui/find_x.c
+@@ -41,9 +41,9 @@ int find_xopendisplay(const char *name, int logdepth,
+ NL;
+
+ const char *node = "libs/gui/xopendisplay";
+- char **cflags, *cflags_arr[] = {"", "-I/opt/X11/include", "-I/usr/X11R6/include", NULL};
+- char **ldflags, *ldflags_arr[] = {"-lX11", "-L/opt/X11/lib -lX11", "-L/usr/X11R6/lib -lX11", NULL};
+- char **Lflags, *Lflags_arr[] = {"", "-L/opt/X11/lib", "-L/usr/X11R6/lib", NULL};
++ char **cflags, *cflags_arr[] = {"-I%%LOCALBASE%%/include", "-I/opt/X11/include", "-I/usr/X11R6/include", NULL};
++ char **ldflags, *ldflags_arr[] = {"-L%%LOCALBASE%%/lib -lX11", "-L/opt/X11/lib -lX11", "-L/usr/X11R6/lib -lX11", NULL};
++ char **Lflags, *Lflags_arr[] = {"-L%%LOCALBASE%%/lib", "-L/opt/X11/lib", "-L/usr/X11R6/lib", NULL};
+
+ if (require("cc/cc", logdepth, fatal))
+ return 1;
diff --git a/cad/librnd/pkg-descr b/cad/librnd/pkg-descr
new file mode 100644
index 000000000000..bdb14e78400e
--- /dev/null
+++ b/cad/librnd/pkg-descr
@@ -0,0 +1,8 @@
+librnd is a free/open source, flexible, modular two-dimensional CAD engine
+
+ - with transparent multiple GUI toolkit support,
+ - flexible, dynamic menu system
+ - flexible, dynamic configuration system
+ - support for user scripting in a dozen languages
+
+WWW: http://www.repo.hu/projects/librnd/
diff --git a/cad/librnd/pkg-plist b/cad/librnd/pkg-plist
new file mode 100644
index 000000000000..e2913de4764b
--- /dev/null
+++ b/cad/librnd/pkg-plist
@@ -0,0 +1,254 @@
+include/librnd/config.h
+include/librnd/core/actions.h
+include/librnd/core/anyload.h
+include/librnd/core/base64.h
+include/librnd/core/box.h
+include/librnd/core/box_isc.h
+include/librnd/core/buildin.hidlib.h
+include/librnd/core/color.h
+include/librnd/core/color_cache.h
+include/librnd/core/compat_fs.h
+include/librnd/core/compat_inc.h
+include/librnd/core/compat_lrealpath.h
+include/librnd/core/compat_misc.h
+include/librnd/core/conf.h
+include/librnd/core/conf_hid.h
+include/librnd/core/config.h
+include/librnd/core/error.h
+include/librnd/core/event.h
+include/librnd/core/file_loaded.h
+include/librnd/core/fptr_cast.h
+include/librnd/core/funchash.h
+include/librnd/core/funchash_core.h
+include/librnd/core/funchash_core_list.h
+include/librnd/core/global_typedefs.h
+include/librnd/core/globalconst.h
+include/librnd/core/grid.h
+include/librnd/core/heap.h
+include/librnd/core/hid.h
+include/librnd/core/hid_attrib.h
+include/librnd/core/hid_cfg.h
+include/librnd/core/hid_cfg_action.h
+include/librnd/core/hid_cfg_input.h
+include/librnd/core/hid_dad.h
+include/librnd/core/hid_dad_spin.h
+include/librnd/core/hid_dad_tree.h
+include/librnd/core/hid_dad_unit.h
+include/librnd/core/hid_init.h
+include/librnd/core/hid_inlines.h
+include/librnd/core/hid_menu.h
+include/librnd/core/hid_nogui.h
+include/librnd/core/hidlib.h
+include/librnd/core/hidlib_conf.h
+include/librnd/core/list_conf.h
+include/librnd/core/math_helper.h
+include/librnd/core/misc_util.h
+include/librnd/core/paths.h
+include/librnd/core/pixmap.h
+include/librnd/core/plugins.h
+include/librnd/core/rnd_bool.h
+include/librnd/core/rnd_printf.h
+include/librnd/core/rotate.h
+include/librnd/core/safe_fs.h
+include/librnd/core/safe_fs_dir.h
+include/librnd/core/tool.h
+include/librnd/core/unit.h
+include/librnd/core/vtc0.h
+include/librnd/plugins/lib_hid_common/dialogs_conf.h
+include/librnd/plugins/lib_hid_common/dlg_comm_m.h
+include/librnd/plugins/lib_hid_common/dlg_pref.h
+include/librnd/plugins/lib_hid_common/place.h
+include/librnd/plugins/lib_hid_common/toolbar.h
+include/librnd/plugins/lib_hid_common/xpm.h
+include/librnd/plugins/lib_hid_common/zoompan.h
+include/librnd/plugins/lib_wget/lib_wget.h
+include/librnd/poly/offset.h
+include/librnd/poly/polyarea.h
+include/librnd/poly/polygon1_gen.h
+include/librnd/poly/rtree.h
+include/librnd/poly/rtree2_compat.h
+include/librnd/poly/self_isc.h
+include/librnd/scconfig/hooks_common.h
+include/librnd/scconfig/plugin_3state.h
+include/librnd/scconfig/rnd_hook_detect.h
+include/librnd/src_3rd/genht/hash.h
+include/librnd/src_3rd/genht/ht.c
+include/librnd/src_3rd/genht/ht.h
+include/librnd/src_3rd/genht/ht_inlines.h
+include/librnd/src_3rd/genht/ht_utils.h
+include/librnd/src_3rd/genht/htip.h
+include/librnd/src_3rd/genht/htpi.h
+include/librnd/src_3rd/genht/htpp.h
+include/librnd/src_3rd/genht/htsi.h
+include/librnd/src_3rd/genht/htsp.h
+include/librnd/src_3rd/genht/htss.h
+include/librnd/src_3rd/genht/siphash24.h
+include/librnd/src_3rd/genht/version.h
+include/librnd/src_3rd/genlist/genadlist.h
+include/librnd/src_3rd/genlist/gendlist.h
+include/librnd/src_3rd/genlist/genlistalloc.h
+include/librnd/src_3rd/genlist/gentdlist_impl.c
+include/librnd/src_3rd/genlist/gentdlist_impl.h
+include/librnd/src_3rd/genlist/gentdlist_undef.h
+include/librnd/src_3rd/genregex/regex.h
+include/librnd/src_3rd/genregex/regex_se.h
+include/librnd/src_3rd/genregex/regex_sei.h
+include/librnd/src_3rd/genregex/regex_templ.h
+include/librnd/src_3rd/genrtree/genrtree_api.h
+include/librnd/src_3rd/genrtree/genrtree_debug.h
+include/librnd/src_3rd/genrtree/genrtree_delete.h
+include/librnd/src_3rd/genrtree/genrtree_impl.h
+include/librnd/src_3rd/genrtree/genrtree_search.h
+include/librnd/src_3rd/gensexpr/gensexpr_impl.h
+include/librnd/src_3rd/gensexpr/gsx_parse.h
+include/librnd/src_3rd/gensexpr/gsxl.h
+include/librnd/src_3rd/gensexpr/gsxnl.h
+include/librnd/src_3rd/genvector/gds_char.h
+include/librnd/src_3rd/genvector/genvector_impl.c
+include/librnd/src_3rd/genvector/genvector_impl.h
+include/librnd/src_3rd/genvector/genvector_undef.h
+include/librnd/src_3rd/genvector/vtd0.h
+include/librnd/src_3rd/genvector/vti0.h
+include/librnd/src_3rd/genvector/vtl0.h
+include/librnd/src_3rd/genvector/vtp0.h
+include/librnd/src_3rd/genvector/vts0.h
+include/librnd/src_3rd/libfungw/scconfig_hooks.h
+include/librnd/src_3rd/liblhtpers/lhtpers.h
+include/librnd/src_3rd/liblihata/dom.h
+include/librnd/src_3rd/liblihata/hash_str.h
+include/librnd/src_3rd/liblihata/lihata.h
+include/librnd/src_3rd/liblihata/parser.h
+include/librnd/src_3rd/liblihata/tree.h
+include/librnd/src_3rd/libulzw/libulzw.h
+include/librnd/src_3rd/puplug/config.h
+include/librnd/src_3rd/puplug/error.h
+include/librnd/src_3rd/puplug/libs.h
+include/librnd/src_3rd/puplug/libs_dep_parse.h
+include/librnd/src_3rd/puplug/os_dep.h
+include/librnd/src_3rd/puplug/os_dep_fs.h
+include/librnd/src_3rd/puplug/puplug.h
+include/librnd/src_3rd/puplug/scconfig_hooks.h
+include/librnd/src_3rd/puplug/util.h
+include/librnd/src_3rd/ureglex/exec.h
+lib/librnd-3rd.a
+lib/librnd-3rd.so
+lib/librnd-3rd.so.3
+lib/librnd-3rd.so.3.1.2
+lib/librnd-hid.a
+lib/librnd-hid.so
+lib/librnd-hid.so.3
+lib/librnd-hid.so.3.1.2
+lib/librnd-poly.a
+lib/librnd-poly.so
+lib/librnd-poly.so.3
+lib/librnd-poly.so.3.1.2
+lib/librnd3/plugins/diag_rnd.pup
+lib/librnd3/plugins/diag_rnd.so
+lib/librnd3/plugins/hid_batch.pup
+lib/librnd3/plugins/hid_batch.so
+%%GTK2%%lib/librnd3/plugins/hid_gtk2_gdk.pup
+%%GTK2%%lib/librnd3/plugins/hid_gtk2_gdk.so
+%%GTK2GL%%lib/librnd3/plugins/hid_gtk2_gl.pup
+%%GTK2GL%%lib/librnd3/plugins/hid_gtk2_gl.so
+%%GTK4%%lib/librnd3/plugins/hid_gtk4_gl.pup
+%%GTK4%%lib/librnd3/plugins/hid_gtk4_gl.so
+%%MOTIF%%lib/librnd3/plugins/hid_lesstif.pup
+%%MOTIF%%lib/librnd3/plugins/hid_lesstif.so
+lib/librnd3/plugins/hid_remote.pup
+lib/librnd3/plugins/hid_remote.so
+lib/librnd3/plugins/irc.pup
+lib/librnd3/plugins/irc.so
+lib/librnd3/plugins/lib_gensexpr.pup
+lib/librnd3/plugins/lib_gensexpr.so
+%%GTK2%%lib/librnd3/plugins/lib_gtk2_common.pup
+%%GTK2%%lib/librnd3/plugins/lib_gtk2_common.so
+%%GTK4%%lib/librnd3/plugins/lib_gtk4_common.pup
+%%GTK4%%lib/librnd3/plugins/lib_gtk4_common.so
+%%GUI%%lib/librnd3/plugins/lib_hid_common.pup
+%%GUI%%lib/librnd3/plugins/lib_hid_common.so
+%%GTK2GL%%lib/librnd3/plugins/lib_hid_gl.pup
+%%GTK2GL%%lib/librnd3/plugins/lib_hid_gl.so
+lib/librnd3/plugins/lib_portynet.pup
+lib/librnd3/plugins/lib_portynet.so
+%%WGET%%lib/librnd3/plugins/lib_wget.pup
+%%WGET%%lib/librnd3/plugins/lib_wget.so
+lib/librnd3/plugins/loghid.pup
+lib/librnd3/plugins/loghid.so
+lib/librnd3/plugins/map_plugins.sh
+lib/librnd3/plugins/script.pup
+lib/librnd3/plugins/script.so
+%%STROKE%%lib/librnd3/plugins/stroke.pup
+%%STROKE%%lib/librnd3/plugins/stroke.so
+lib/librnd3/puplug
+lib/librnd3/scconfig/cquote
+lib/librnd3/scconfig/gen_conf.sh
+lib/librnd3/scconfig/sccbox
+lib/librnd3/scconfig/template/cdep.tmpasm
+lib/librnd3/scconfig/template/comp_var.tmpasm
+lib/librnd3/scconfig/template/compile.tmpasm
+lib/librnd3/scconfig/template/debug.tmpasm
+lib/librnd3/scconfig/template/plugin_conf.tmpasm
+lib/librnd3/scconfig/template/plugin_intconf.tmpasm
+lib/librnd3/scconfig/template/plugin_intmenu.tmpasm
+lib/librnd3/scconfig/template/plugin_sphash.tmpasm
+lib/librnd3/sphash
+%%PORTDOCS%%%%DOCSDIR%%3/Autostyle.html
+%%PORTDOCS%%%%DOCSDIR%%3/TODO
+%%PORTDOCS%%%%DOCSDIR%%3/UNIX.txt
+%%PORTDOCS%%%%DOCSDIR%%3/conf/groups.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/history.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/index.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/index_prog.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/index_user.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/lists.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/merging.png
+%%PORTDOCS%%%%DOCSDIR%%3/conf/noextend.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/plugin_chk.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/prio.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/scalars.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/sources.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/syntax.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_BOOLEAN.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_COLOR.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_COORD.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_INCREMENTS.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_INTEGER.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_LIST.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_REAL.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_STRING.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/CFN_UNIT.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/appearance.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/appearance_color.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/appearance_loglevels.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/appearance_messages.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/appearance_misc.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/appearance_padstack.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/appearance_subc.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/design.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/design_drc.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/design_drc_disable.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/design_thermal.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/editor.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/editor_selection.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/editor_view.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/import_footprint_placement.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/import_footprint_removal.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/rc.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/rc_path.html
+%%PORTDOCS%%%%DOCSDIR%%3/conf/tree/temp.html
+%%PORTDOCS%%%%DOCSDIR%%3/contact.html
+%%PORTDOCS%%%%DOCSDIR%%3/contrib.html
+%%PORTDOCS%%%%DOCSDIR%%3/developer/hid_remote/proto_high.html
+%%PORTDOCS%%%%DOCSDIR%%3/developer/hid_remote/proto_low.html
+%%PORTDOCS%%%%DOCSDIR%%3/developer/hid_remote/proto_parse.html
+%%PORTDOCS%%%%DOCSDIR%%3/developer/hid_remote/proto_parse.svg
+%%PORTDOCS%%%%DOCSDIR%%3/index.html
+%%PORTDOCS%%%%DOCSDIR%%3/irc.html
+%%PORTDOCS%%%%DOCSDIR%%3/license.html
+%%PORTDOCS%%%%DOCSDIR%%3/mac.txt
+%%PORTDOCS%%%%DOCSDIR%%3/news.html
+%%PORTDOCS%%%%DOCSDIR%%3/windows.html
+%%DATADIR%%3/librnd.mak
+%%DATADIR%%3/librnd_packages.sh
+%%DATADIR%%3/plugin.state
+@dir include/librnd/src_3rd/libfungwbind/c