aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-05-20 16:30:48 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-05-20 17:13:59 +0000
commit0ceb67a27a99cc776fb10cb4f03763a592c56a45 (patch)
treeb690240a6a8531bd5ce144e5a056c0f7911d9ad2
parentcd194f5dd282d7904c258264f875e85bfbf5fe07 (diff)
downloadports-0ceb67a27a99cc776fb10cb4f03763a592c56a45.tar.gz
ports-0ceb67a27a99cc776fb10cb4f03763a592c56a45.zip
comms/chirp: welcome back
Project now in Python 3 and uses wxPython for GUI. Event: BSDCan 2023
-rw-r--r--MOVED1
-rw-r--r--comms/Makefile1
-rw-r--r--comms/chirp/Makefile57
-rw-r--r--comms/chirp/distinfo3
-rw-r--r--comms/chirp/pkg-descr3
5 files changed, 64 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 60f209ee3b07..7ada28335b3b 100644
--- a/MOVED
+++ b/MOVED
@@ -5120,7 +5120,6 @@ sysutils/syslog-ng323|sysutils/syslog-ng|2020-10-12|Has expired: Agreed upon ups
devel/libsoup-gnome|devel/libsoup|2020-10-12|Reunited into on package they have the same dependencies
sysutils/plasma5-user-manager|x11/plasma5-plasma-desktop|2020-10-13|Reintegrated into other plasma5 components
devel/geany-plugin-geanypy||2020-10-15|Has expired: Uses deprecated version of python
-comms/chirp||2020-10-16|Use deprecated version of python
x11-toolkits/py-gtk2||2020-10-16|Remove deprecated binding replace by py-gobject
www/py-unit|www/unit-python|2020-10-21|Rename to be more consistent with the naming convention
sysutils/phpfpm_exporter|net-mgmt/phpfpm_exporter|2020-10-24|Move to net-mgmt category
diff --git a/comms/Makefile b/comms/Makefile
index 6b62709c275e..7f9af8d05b1c 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -16,6 +16,7 @@
SUBDIR += bluegps
SUBDIR += bluez-firmware
SUBDIR += bpl+
+ SUBDIR += chirp
SUBDIR += chu
SUBDIR += comserv
SUBDIR += concordance
diff --git a/comms/chirp/Makefile b/comms/chirp/Makefile
new file mode 100644
index 000000000000..924b4f10d6e0
--- /dev/null
+++ b/comms/chirp/Makefile
@@ -0,0 +1,57 @@
+PORTNAME= chirp
+PORTVERSION= 20230520
+CATEGORIES= comms hamradio
+PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
+DIST_SUBDIR= chirp
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= Free, open-source tool for programming your amateur radio
+WWW= https://chirp.danplanet.com/projects/chirp
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}versioningit>0:devel/py-versioningit@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyserial>0:comms/py-pyserial@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yattag>0:devel/py-yattag@${PY_FLAVOR}
+
+USES= desktop-file-utils gnome python shebangfix
+SHEBANG_GLOB= *.py
+
+USE_GITHUB= yes
+GH_ACCOUNT= kk7ds
+GH_TAGNAME= ec34ec9b7f37301c792e41eefa054a837fae59fe
+
+USE_GNOME= gtk-update-icon-cache
+
+USE_PYTHON= autoplist pep517 pytest
+
+USE_WX= 3.2
+WX_COMPS= python:run
+
+PLIST_FILES= share/applications/${PORTNAME}.desktop \
+ share/pixmaps/${PORTNAME}.png
+
+NO_ARCH= yes
+
+post-patch:
+ @${ECHO} "Version: ${PORTVERSION}" > ${WRKSRC}/PKG-INFO
+
+post-install:
+ @cd ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}/share && \
+ ${INSTALL_DATA} ${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps && \
+ ${INSTALL_DATA} ${PORTNAME}.desktop ${STAGEDIR}${DESKTOPDIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 31000
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>0:devel/py-importlib-resources@${PY_FLAVOR}
+.endif
+.if ${PYTHON_REL} < 30800
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>0:devel/py-importlib-metadata@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/chirp/distinfo b/comms/chirp/distinfo
new file mode 100644
index 000000000000..c44839d309aa
--- /dev/null
+++ b/comms/chirp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1684545928
+SHA256 (chirp/kk7ds-chirp-20230520-ec34ec9b7f37301c792e41eefa054a837fae59fe_GH0.tar.gz) = 66a8540ad1eae3f6ba165f7eb36d6d27d041abf0aa8f57d2e9d29c2d8fbda533
+SIZE (chirp/kk7ds-chirp-20230520-ec34ec9b7f37301c792e41eefa054a837fae59fe_GH0.tar.gz) = 1841501
diff --git a/comms/chirp/pkg-descr b/comms/chirp/pkg-descr
new file mode 100644
index 000000000000..e67588e8a176
--- /dev/null
+++ b/comms/chirp/pkg-descr
@@ -0,0 +1,3 @@
+CHIRP is a free, open-source tool for programming your amateur radio.
+It supports a large number of manufacturers and models, as well as
+provides a way to interface with multiple data sources and formats.