aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:11:53 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:11:53 +0000
commit0cf3172f1690031e1a6543d81f6619e5057dddd9 (patch)
tree32d3c49730f75978d58e0efcdbed2fbae01bc6de
parent90c70cc23d260f2d416acdfd1f07337a4bbe217a (diff)
downloadports-0cf3172f1690031e1a6543d81f6619e5057dddd9.tar.gz
ports-0cf3172f1690031e1a6543d81f6619e5057dddd9.zip
devel/py-shapely: Fix PORTNAME and WWW
- Bump PORTREVISION for package change It is to minimize the patch of 2.0.1 update. Upstream also changed the tarball from Shapely to shapely. Approved by: portmgr (blanket) With hat: python
-rw-r--r--cad/cura/Makefile2
-rw-r--r--devel/py-shapely/Makefile6
-rw-r--r--devel/py-trimesh/Makefile2
-rw-r--r--graphics/py-cartopy/Makefile2
-rw-r--r--graphics/py-fiona/Makefile2
-rw-r--r--graphics/py-geopandas/Makefile2
-rw-r--r--graphics/py-osmnet/Makefile2
-rw-r--r--graphics/py-rasterstats/Makefile2
-rw-r--r--graphics/qgis-ltr/Makefile2
-rw-r--r--graphics/qgis/Makefile2
-rw-r--r--misc/py-kartograph/Makefile2
-rw-r--r--misc/py-placekey/Makefile2
-rw-r--r--science/py-pycsw/Makefile2
-rw-r--r--www/py-sentinelhub/Makefile2
14 files changed, 17 insertions, 15 deletions
diff --git a/cad/cura/Makefile b/cad/cura/Makefile
index 4be9273a2dc3..24ea2c39e1a8 100644
--- a/cad/cura/Makefile
+++ b/cad/cura/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= Uranium>0,1:cad/uranium
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zeroconf>0:net/py-zeroconf@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyserial>0:comms/py-pyserial@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>0:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>0:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy-stl>0:math/py-numpy-stl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}keyring>0:security/py-keyring@${PY_FLAVOR} \
qt5-graphicaleffects>0:graphics/qt5-graphicaleffects \
diff --git a/devel/py-shapely/Makefile b/devel/py-shapely/Makefile
index 2fdae3c03847..4034ce109a8a 100644
--- a/devel/py-shapely/Makefile
+++ b/devel/py-shapely/Makefile
@@ -1,12 +1,14 @@
-PORTNAME= Shapely
+PORTNAME= shapely
PORTVERSION= 1.8.5
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Shapely-${PORTVERSION}
MAINTAINER= wen@FreeBSD.org
COMMENT= Python Package for Manipulation 2D Geospatial Geometry
-WWW= https://pypi.org/project/Shapely/
+WWW= https://pypi.org/project/shapely/
LICENSE= BSD3CLAUSE
diff --git a/devel/py-trimesh/Makefile b/devel/py-trimesh/Makefile
index 751f0d251e84..3bd601dfcb64 100644
--- a/devel/py-trimesh/Makefile
+++ b/devel/py-trimesh/Makefile
@@ -17,7 +17,7 @@ NEEDED_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyglet1>0:graphics/py-pyglet1@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>0:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>0:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rtree>0:devel/py-rtree@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}svg_path>0:graphics/py-svg.path@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sympy>0:math/py-sympy@${PY_FLAVOR} \
diff --git a/graphics/py-cartopy/Makefile b/graphics/py-cartopy/Makefile
index 9d4b654e4346..6daa8417fb93 100644
--- a/graphics/py-cartopy/Makefile
+++ b/graphics/py-cartopy/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=3.1:math/py-matplotlib@${PY_FLAV
${PYTHON_PKGNAMEPREFIX}numpy>=1.19,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyproj>=3.0.0:graphics/py-pyproj@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyshp>=2.1:devel/py-pyshp@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=1.6.4:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>=1.6.4:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.3.0:devel/py-six@${PY_FLAVOR}
USES= python:3.8+
diff --git a/graphics/py-fiona/Makefile b/graphics/py-fiona/Makefile
index 10d290708d4a..c5b9ef71292c 100644
--- a/graphics/py-fiona/Makefile
+++ b/graphics/py-fiona/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cligj>=0.4:devel/py-cligj@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}click-plugins>0:devel/py-click-plugins@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.7:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}munch>0:devel/py-munch@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>0:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>0:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gdal>0:graphics/py-gdal@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}attrs>=18.2:devel/py-attrs@${PY_FLAVOR}
LIB_DEPENDS+= libgdal.so:graphics/gdal
diff --git a/graphics/py-geopandas/Makefile b/graphics/py-geopandas/Makefile
index bdce860ffd49..c2c17dafe245 100644
--- a/graphics/py-geopandas/Makefile
+++ b/graphics/py-geopandas/Makefile
@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=1.2.18:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>=1.2.18:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Fiona>=1.0.1:graphics/py-fiona@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyproj>=1.9.3:graphics/py-pyproj@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.3.0:devel/py-six@${PY_FLAVOR}
diff --git a/graphics/py-osmnet/Makefile b/graphics/py-osmnet/Makefile
index 343332acadbc..2b39ada2d4f5 100644
--- a/graphics/py-osmnet/Makefile
+++ b/graphics/py-osmnet/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}geopandas>=0.7:graphics/py-geopandas@${PY_FL
${PYTHON_PKGNAMEPREFIX}numpy>=1.10,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>=0.23,1:math/py-pandas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.9.1:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=1.5:devel/py-shapely@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}shapely>=1.5:devel/py-shapely@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
diff --git a/graphics/py-rasterstats/Makefile b/graphics/py-rasterstats/Makefile
index beda0f87b773..95e26e6ad83c 100644
--- a/graphics/py-rasterstats/Makefile
+++ b/graphics/py-rasterstats/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}affine>=0<3.0:math/py-affine@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Fiona>=0<1.9:graphics/py-fiona@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.9,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rasterio>=1.0:graphics/py-rasterio@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=0:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>=0:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}simplejson>=0:devel/py-simplejson@${PY_FLAVOR}
USES= python:3.8+
diff --git a/graphics/qgis-ltr/Makefile b/graphics/qgis-ltr/Makefile
index 10162151599b..7bd44f298e36 100644
--- a/graphics/qgis-ltr/Makefile
+++ b/graphics/qgis-ltr/Makefile
@@ -93,7 +93,7 @@ RUN_DEPENDS= astyle:devel/astyle \
${PYTHON_PKGNAMEPREFIX}requests>=2.28.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-image>=0.19.3:graphics/py-scikit-image@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-learn>=1.1.3:science/py-scikit-learn@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=1.8.5:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>=1.8.5:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.16.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=3.7.16:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}termcolor>=2.1.0:devel/py-termcolor@${PY_FLAVOR} \
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index e213c7ac6204..558b9316bd37 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -91,7 +91,7 @@ RUN_DEPENDS= astyle:devel/astyle \
${PYTHON_PKGNAMEPREFIX}requests>=2.28.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-image>=0.19.3:graphics/py-scikit-image@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-learn>=1.1.3:science/py-scikit-learn@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=1.8.5:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>=1.8.5:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.16.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=3.7.16:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}termcolor>=2.1.0:devel/py-termcolor@${PY_FLAVOR} \
diff --git a/misc/py-kartograph/Makefile b/misc/py-kartograph/Makefile
index 05828f1c2c98..e58f747af0e9 100644
--- a/misc/py-kartograph/Makefile
+++ b/misc/py-kartograph/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argparse>0:devel/py-argparse@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyaml>0:textproc/py-pyaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pykml>0:misc/py-pykml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyproj>0:graphics/py-pyproj@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=1.0.14:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>=1.0.14:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tinycss>0:textproc/py-tinycss@${PY_FLAVOR}
USES= python:3.8+
diff --git a/misc/py-placekey/Makefile b/misc/py-placekey/Makefile
index d3b5763a1099..42bdc9e14a5d 100644
--- a/misc/py-placekey/Makefile
+++ b/misc/py-placekey/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}backoff>=0:devel/py-backoff@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}h3>=0:graphics/py-h3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ratelimiter>=0:devel/py-ratelimiter@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=0:devel/py-shapely@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}shapely>=0:devel/py-shapely@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/science/py-pycsw/Makefile b/science/py-pycsw/Makefile
index 1e52ee8b6c27..94db110d6341 100644
--- a/science/py-pycsw/Makefile
+++ b/science/py-pycsw/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}geolinks>=0:science/py-geolinks@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}OWSLib>=0:graphics/py-OWSLib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyproj>=0:graphics/py-pyproj@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=0:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>=0:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xmltodict>=0:devel/py-xmltodict@${PY_FLAVOR}
USES= cpe python:3.8+
diff --git a/www/py-sentinelhub/Makefile b/www/py-sentinelhub/Makefile
index 3539d1fb17d3..0d78def1732c 100644
--- a/www/py-sentinelhub/Makefile
+++ b/www/py-sentinelhub/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aenum>=2.1.4:devel/py-aenum@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.27.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=1.0.0:www/py-requests-oauthlib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}Shapely>=0:devel/py-shapely@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}shapely>=0:devel/py-shapely@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tifffile>=2020.9.30:graphics/py-tifffile@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tomli>=0:textproc/py-tomli@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tomli-w>=0:textproc/py-tomli-w@${PY_FLAVOR} \