aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorXavier Beaudouin <kiwi@FreeBSD.org>2025-01-13 15:00:41 +0000
committerXavier Beaudouin <kiwi@FreeBSD.org>2025-01-14 16:29:48 +0000
commit0d2aafdd1d2ad80f04969d4d7903e1963f741116 (patch)
tree916861718be58ac57ee38a0977d31e735093153f
parent05933df68ac7ae7752a8675eba10a0e0e16cfacb (diff)
comms/py-ModbusTCP: Simple Modbus/TCP client for python
This port is a simple modbus TCP client for python. A pure Python code without any extension or external module dependency Approved by: 0mp (mentor) Differential Revision: https://reviews.freebsd.org/D48417
-rw-r--r--comms/Makefile1
-rw-r--r--comms/py-ModbusTCP/Makefile24
-rw-r--r--comms/py-ModbusTCP/distinfo3
-rw-r--r--comms/py-ModbusTCP/pkg-descr2
4 files changed, 30 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index c479a42c2ce1..36269913b720 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -140,6 +140,7 @@
SUBDIR += py-libimobiledevice
SUBDIR += py-libscrc
SUBDIR += py-libusbsio
+ SUBDIR += py-ModbusTCP
SUBDIR += py-nkdfu
SUBDIR += py-pylink-square
SUBDIR += py-pymodbus
diff --git a/comms/py-ModbusTCP/Makefile b/comms/py-ModbusTCP/Makefile
new file mode 100644
index 000000000000..542e56367322
--- /dev/null
+++ b/comms/py-ModbusTCP/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= pyModbusTCP
+DISTVERSION= 0.3.0
+CATEGORIES= comms python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kiwi@FreeBSD.org
+COMMENT= Simple Modbus/TCP client library for Python
+WWW= https://github.com/sourceperl/pyModbusTCP
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.16.0:math/py-numpy@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+NO_ARCH= yes
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/comms/py-ModbusTCP/distinfo b/comms/py-ModbusTCP/distinfo
new file mode 100644
index 000000000000..25543d3141e4
--- /dev/null
+++ b/comms/py-ModbusTCP/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1736512419
+SHA256 (pyModbusTCP-0.3.0.tar.gz) = 893a4d88f6a63af21bd35b2b22061355e74005ea27fefc104e8f9bdb4ce81a04
+SIZE (pyModbusTCP-0.3.0.tar.gz) = 31478
diff --git a/comms/py-ModbusTCP/pkg-descr b/comms/py-ModbusTCP/pkg-descr
new file mode 100644
index 000000000000..60bd6538fb2c
--- /dev/null
+++ b/comms/py-ModbusTCP/pkg-descr
@@ -0,0 +1,2 @@
+A simple Modbus/TCP client library for Python. pyModbusTCP is pure Python
+code without any extension or external module dependency.