aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-01-06 09:57:15 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-01-06 09:57:15 +0000
commit0d2acd9252ea079869ac844bb42f2959f3502041 (patch)
treefc9f4223fc291d1b6c5342733d7dccd725164257
parenta65a95b7d364193612ce9fb4e4833d61568b7773 (diff)
downloadports-0d2acd9252ea079869ac844bb42f2959f3502041.tar.gz
ports-0d2acd9252ea079869ac844bb42f2959f3502041.zip
Add yadda 1.0, Yet Another Damn Delivery Agent.
Yadda - Yet Another Damn Delivery Agent is a fully featured mail delivery agent, with support for Maildir++ and softquotas. It also supports filtering, and SQL-usage. It's written entirely in Perl and uses Mail::Audit which is available from CPAN. It's compatible with RFC2033 (LMTP) and works great with postfix, and other LHLO/LMTP-fluent MTA's. Author: Jesper Noehr <jesper@noehr.org> WWW: http://code.printf.dk/~decius/yadda/ PR: 60802 Submitted by: Jesper Noehr <jesper@noehr.org>
Notes
Notes: svn path=/head/; revision=97465
-rw-r--r--mail/Makefile1
-rw-r--r--mail/yadda/Makefile31
-rw-r--r--mail/yadda/distinfo1
-rw-r--r--mail/yadda/pkg-descr9
-rw-r--r--mail/yadda/pkg-plist2
5 files changed, 44 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index bcead3bf20cc..efc291d71c5a 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -402,6 +402,7 @@
SUBDIR += xmailwatcher
SUBDIR += xpbiff
SUBDIR += xpbiff-youbin
+ SUBDIR += yadda
SUBDIR += youbin
SUBDIR += yuzu
SUBDIR += zmailer
diff --git a/mail/yadda/Makefile b/mail/yadda/Makefile
new file mode 100644
index 000000000000..d58dbddd6d08
--- /dev/null
+++ b/mail/yadda/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: yadda
+# Date created: 2004-01-01
+# Whom: Jesper Noehr <jesper@noehr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yadda
+PORTVERSION= 1.0
+CATEGORIES= mail
+MASTER_SITES= http://code.printf.dk/~decius/yadda/ \
+ http://casius.dk/mirrors/yadda/ \
+ http://yadda.salkin.dk/mirror/ \
+ http://users.cybercity.dk/~dsl22381/
+
+MAINTAINER= jesper@noehr.org
+COMMENT= Yet Another Damn Delivery Agent
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Mail/Audit.pm:${PORTSDIR}/mail/p5-Mail-Audit
+
+USE_PERL5_RUN= yes
+
+do-build:
+ ${SED} -e '1s,/usr/bin/perl,${PERL},' ${WRKSRC}/yadda \
+ > ${WRKDIR}/yadda
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/yadda ${PREFIX}/sbin
+
+.include <bsd.port.mk>
diff --git a/mail/yadda/distinfo b/mail/yadda/distinfo
new file mode 100644
index 000000000000..7d95fe2f20f0
--- /dev/null
+++ b/mail/yadda/distinfo
@@ -0,0 +1 @@
+MD5 (yadda-1.0.tar.gz) = 8a950af7b7ed7f37f4b5b1f891112c64
diff --git a/mail/yadda/pkg-descr b/mail/yadda/pkg-descr
new file mode 100644
index 000000000000..85d7865e4dfb
--- /dev/null
+++ b/mail/yadda/pkg-descr
@@ -0,0 +1,9 @@
+Yadda - Yet Another Damn Delivery Agent is a
+fully featured mail delivery agent, with support for Maildir++
+and softquotas. It also supports filtering, and SQL-usage.
+It's written entirely in Perl and uses Mail::Audit which is
+available from CPAN. It's compatible with RFC2033 (LMTP)
+and works great with postfix, and other LHLO/LMTP-fluent MTA's.
+
+Author: Jesper Noehr <jesper@noehr.org>
+WWW: http://code.printf.dk/~decius/yadda/
diff --git a/mail/yadda/pkg-plist b/mail/yadda/pkg-plist
new file mode 100644
index 000000000000..8c2d92cef25a
--- /dev/null
+++ b/mail/yadda/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+sbin/yadda