aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-12-29 03:30:13 +0000
committerWen Heping <wen@FreeBSD.org>2017-12-29 03:30:13 +0000
commit0d82c4fe625cb7da778e6e2ef2248b58cc62d370 (patch)
treeb6909054de02a721a6147a186e342c777e58e004
parentefa97484d2168edaf5ccaee8e43bef4b26c535d8 (diff)
downloadports-0d82c4fe625cb7da778e6e2ef2248b58cc62d370.tar.gz
ports-0d82c4fe625cb7da778e6e2ef2248b58cc62d370.zip
- Update to 1.0.7
- Update LICENSE PR: 223675 Submitted by: takefu@airport.fm
Notes
Notes: svn path=/head/; revision=457491
-rw-r--r--textproc/sxml/Makefile14
-rw-r--r--textproc/sxml/distinfo5
-rw-r--r--textproc/sxml/files/patch-Makefile.in18
-rw-r--r--textproc/sxml/files/patch-examples_Makefile.in11
-rw-r--r--textproc/sxml/pkg-descr5
5 files changed, 32 insertions, 21 deletions
diff --git a/textproc/sxml/Makefile b/textproc/sxml/Makefile
index 03bf81be459c..41475b5de929 100644
--- a/textproc/sxml/Makefile
+++ b/textproc/sxml/Makefile
@@ -2,23 +2,21 @@
# $FreeBSD$
PORTNAME= sxml
-PORTVERSION= 1.0.6
+PORTVERSION= 1.0.7
CATEGORIES= textproc
MASTER_SITES= http://www.MysticWALL.COM/download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= takefu@airport.fm
COMMENT= Skimpy XML parsing and grafting library for C language
-LICENSE= BSD3CLAUSE
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USES= tar:bzip2
-MAKE_JOBS_UNSAFE= yes
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsxml*.so
+do-test: build
+ cd ${BUILD_WRKSRC}/examples && ${MAKE} all
.include <bsd.port.mk>
diff --git a/textproc/sxml/distinfo b/textproc/sxml/distinfo
index 294428bd446e..5605c7cf73ba 100644
--- a/textproc/sxml/distinfo
+++ b/textproc/sxml/distinfo
@@ -1,2 +1,3 @@
-SHA256 (sxml-1.0.6.tar.bz2) = e26a960bd6c24021dd83c4da4d2a8006ed3b92e0a9ac85b17358e473000260d0
-SIZE (sxml-1.0.6.tar.bz2) = 82316
+TIMESTAMP = 1497916868
+SHA256 (sxml-1.0.7.tar.bz2) = b7ed703252976074488044e49de070bc01a9f3eff7633c772dac05f089825470
+SIZE (sxml-1.0.7.tar.bz2) = 83491
diff --git a/textproc/sxml/files/patch-Makefile.in b/textproc/sxml/files/patch-Makefile.in
index 91995c0162e1..43edbefb84fd 100644
--- a/textproc/sxml/files/patch-Makefile.in
+++ b/textproc/sxml/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig
+--- Makefile.in.orig 2010-03-26 07:56:17 UTC
+++ Makefile.in
-@@ -30,11 +30,11 @@
+@@ -30,11 +30,11 @@ CTAGS=@CTAGS@
EDITOR=@EDITOR@
INSTALL=@INSTALL@
@@ -9,12 +9,12 @@
INSTALL_DATA=@INSTALL_DATA@
DEFS= @DEFS@
--OPTS= -fforce-mem -fforce-addr -fstrength-reduce -funroll-loops -finline-functions
+-OPTS= -fforce-addr -fstrength-reduce -funroll-loops -finline-functions
+OPTS= -fstrength-reduce -funroll-loops -finline-functions
CPPFLAGS= -I@srcdir@
CFLAGS= ${DEFS} ${CPPFLAGS} ${OPTS} @CFLAGS@
-@@ -121,43 +121,43 @@
+@@ -121,43 +121,43 @@ libsxmlrpc.dylib: ${SXMLRPC_SOBJ}
install:: check-dirs install-libsxml install-libsxmlrpc
install-libsxml::
@@ -33,7 +33,7 @@
if [ -f ${SXML_SLIB} ]; then \
- ${INSTALL} ${SXML_SLIB} ${libdir}; \
- (cd ${libdir}; ${LN_S} ${SXML_SLIB} ${SXML_LIB}); \
-+ ${INSTALL} ${SXML_SLIB} ${DESTDIR}${libdir}; \
++ ${INSTALL_PROGRAM} ${SXML_SLIB} ${DESTDIR}${libdir}; \
+ (cd ${DESTDIR}${libdir}; ${LN_S} ${SXML_SLIB} ${SXML_LIB}); \
fi
if [ -f ${SXML_DYLIB} ]; then \
@@ -61,7 +61,7 @@
if [ -f ${SXMLRPC_SLIB} ]; then \
- ${INSTALL} ${SXMLRPC_SLIB} ${libdir}; \
- (cd ${libdir}; ${LN_S} ${SXMLRPC_SLIB} ${SXMLRPC_LIB}); \
-+ ${INSTALL} ${SXMLRPC_SLIB} ${DESTDIR}${libdir}; \
++ ${INSTALL_PROGRAM} ${SXMLRPC_SLIB} ${DESTDIR}${libdir}; \
+ (cd ${DESTDIR}${libdir}; ${LN_S} ${SXMLRPC_SLIB} ${SXMLRPC_LIB}); \
fi
if [ -f ${SXMLRPC_DYLIB} ]; then \
@@ -77,9 +77,9 @@
- @if [ ! -d ${prefix} ]; then ${MKDIR} ${prefix}; fi
- @if [ ! -d ${libdir} ]; then ${MKDIR} ${libdir}; fi
- @if [ ! -d ${includedir} ]; then ${MKDIR} ${includedir}; fi
-+ @if [ ! -d ${DESTDIR}${prefix} ]; then ${MKDIR} ${DESTDIR}${prefix}; fi
-+ @if [ ! -d ${DESTDIR}${libdir} ]; then ${MKDIR} ${DESTDIR}${libdir}; fi
-+ @if [ ! -d ${DESTDIR}${includedir} ]; then ${MKDIR} ${DESTDIR}${includedir}; fi
++ @if [ ! -d ${prefix} ]; then ${MKDIR} ${DESTDIR}${prefix}; fi
++ @if [ ! -d ${libdir} ]; then ${MKDIR} ${DESTDIR}${libdir}; fi
++ @if [ ! -d ${includedir} ]; then ${MKDIR} ${DESTDIR}${includedir}; fi
###############################################################################
diff --git a/textproc/sxml/files/patch-examples_Makefile.in b/textproc/sxml/files/patch-examples_Makefile.in
new file mode 100644
index 000000000000..8754201ca4df
--- /dev/null
+++ b/textproc/sxml/files/patch-examples_Makefile.in
@@ -0,0 +1,11 @@
+--- examples/Makefile.in.orig 2008-02-05 14:03:37 UTC
++++ examples/Makefile.in
+@@ -34,7 +34,7 @@ INSTALL_PROGRAM=@INSTALL_PROGRAM@ -s
+ INSTALL_DATA=@INSTALL_DATA@
+
+ DEFS= @DEFS@
+-OPTS= -fforce-mem -fforce-addr -fstrength-reduce -funroll-loops -finline-functions
++OPTS= -fstrength-reduce -funroll-loops -finline-functions
+ CPPFLAGS= -I.. -L..
+ CFLAGS= ${DEFS} ${CPPFLAGS} ${OPTS} @CFLAGS@
+
diff --git a/textproc/sxml/pkg-descr b/textproc/sxml/pkg-descr
index c3e9f78e9659..ffddabecb11e 100644
--- a/textproc/sxml/pkg-descr
+++ b/textproc/sxml/pkg-descr
@@ -1,4 +1,5 @@
-SXML is a skimpy XML parsing and grafting C library that you can use
-to read and write XML-like configuration file for your application.
+SXML is a skimpy XML parsing and grafting C library that you can use to read
+and write XML-like configuration file for your application.
+Author: Kouichi ABE (WALL) <kouichi@MysticWALL.COM>
WWW: http://www.MysticWALL.COM/software/sxml/index.html