aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-04-24 19:41:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-04-24 19:42:21 +0000
commit0dbe6a8466dd62cb74de254ecc058badcab264f5 (patch)
tree355cdd46413f51facfa073fde928146b86d01ed1
parent433ff1db763c735aba7e0f64dc9345afcd186a92 (diff)
downloadports-0dbe6a8466dd62cb74de254ecc058badcab264f5.tar.gz
ports-0dbe6a8466dd62cb74de254ecc058badcab264f5.zip
lang/plexil: Update 4.5.0-RC2 -> 4.5.0-RC3
PR: 263531
-rw-r--r--lang/plexil/Makefile15
-rw-r--r--lang/plexil/distinfo6
-rw-r--r--lang/plexil/pkg-plist12
3 files changed, 23 insertions, 10 deletions
diff --git a/lang/plexil/Makefile b/lang/plexil/Makefile
index 9855b56396a4..42e5c9289946 100644
--- a/lang/plexil/Makefile
+++ b/lang/plexil/Makefile
@@ -1,7 +1,6 @@
PORTNAME= plexil
DISTVERSION= 4.5.0
-PORTREVISION= 1
-DISTVERSIONSUFFIX= RC2
+DISTVERSIONSUFFIX= RC3
CATEGORIES= lang devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION:R}
@@ -12,14 +11,22 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/../LICENSE
USES= gmake libtool
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --disable-gantt --disable-ipc --disable-sas --disable-test-exec --disable-udp
-USE_GCC= yes # clang fails: undefined symbol: std::__1::unique_ptr
+
INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
WRKSRC_SUBDIR= src
BINARY_ALIAS= gcc=${CC}
+LDFLAGS+= -lexecinfo
+
+post-patch: # workaround for https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=263535
+ @${REINPLACE_CMD} -e 's|std::unique_ptr|std::shared_ptr|' \
+ ${WRKSRC}/value/Value.hh \
+ ${WRKSRC}/value/Value.cc
+
.include <bsd.port.mk>
diff --git a/lang/plexil/distinfo b/lang/plexil/distinfo
index b4be7c068846..7d3eae22cff1 100644
--- a/lang/plexil/distinfo
+++ b/lang/plexil/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1559856630
-SHA256 (plexil-4.5.0RC2.tar.gz) = 120fcf0e284a2deb0e15bb719da98e062f08af3a8984e2ea05bb2f5a42e338a4
-SIZE (plexil-4.5.0RC2.tar.gz) = 17029712
+TIMESTAMP = 1650828399
+SHA256 (plexil-4.5.0RC3.tar.gz) = ae7f14ca8a32a22ed8e6a335d13dcccf350eabdd127465087cd9c20601891df6
+SIZE (plexil-4.5.0RC3.tar.gz) = 17295185
diff --git a/lang/plexil/pkg-plist b/lang/plexil/pkg-plist
index 5f5a8a8cffe3..6dc5a3a7a3dd 100644
--- a/lang/plexil/pkg-plist
+++ b/lang/plexil/pkg-plist
@@ -12,15 +12,18 @@ include/ArrayVariable.hh
include/Assignable.hh
include/Assignment.hh
include/AssignmentNode.hh
+include/CachedFunction.hh
include/CachedValue.hh
include/CachedValueImpl.hh
include/ClientSocket.h
include/Command.hh
+include/CommandFunction.hh
include/CommandHandle.hh
include/CommandHandleVariable.hh
include/CommandNode.hh
include/Constant.hh
include/ConstantMacros.hh
+include/ConversionOperators.hh
include/Debug.hh
include/DebugMessage.hh
include/DummyAdapter.hh
@@ -39,7 +42,6 @@ include/Expression.hh
include/ExpressionConstants.hh
include/ExpressionFactory.hh
include/ExpressionListener.hh
-include/Expressions.hh
include/ExternalInterface.hh
include/Function.hh
include/GetValueImpl.hh
@@ -52,6 +54,7 @@ include/Launcher.hh
include/LibraryCallNode.hh
include/LinkedQueue.hh
include/ListNode.hh
+include/Listenable.hh
include/ListenerFilters.hh
include/Logging.hh
include/Lookup.hh
@@ -63,13 +66,15 @@ include/NodeConstantExpressions.hh
include/NodeConstants.hh
include/NodeFactory.hh
include/NodeFunction.hh
+include/NodeImpl.hh
include/NodeOperator.hh
include/NodeOperatorImpl.hh
+include/NodeOperators.hh
include/NodeTimepointValue.hh
include/NodeTransition.hh
include/NodeVariableMap.hh
include/NodeVariables.hh
-include/NotifierImpl.hh
+include/Notifier.hh
include/Operator.hh
include/ParserException.hh
include/PlanDebugListener.hh
@@ -79,6 +84,7 @@ include/PlexilListener.hh
include/PlexilNodeType.hh
include/PlexilSchema.hh
include/PlexilTypeTraits.hh
+include/Propagator.hh
include/QueueEntry.hh
include/RecursiveThreadMutex.hh
include/ResourceArbiterInterface.hh
@@ -104,8 +110,8 @@ include/UtilityAdapter.hh
include/Value.hh
include/ValueType.hh
include/VariableConflictSet.hh
-include/allocateCache.hh
include/bitsetUtils.hh
+include/createExpression.hh
include/lifecycle-utils.h
include/map-utils.hh
include/parseNode.hh