aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-17 21:15:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-17 21:15:40 +0000
commit0df61c84bb6ee2a02aa07290571363fba338ce1c (patch)
treef80f7699fe893654d33c3a50f85d89a487476e4e
parent20fcd2eb10cc33ff9a35bf3d67d33def40df5628 (diff)
downloadports-0df61c84bb6ee2a02aa07290571363fba338ce1c.tar.gz
ports-0df61c84bb6ee2a02aa07290571363fba338ce1c.zip
Compile Python files on installation.
PR: 59383 Submitted by: Rui Lopes <rui@ruilopes.com>
Notes
Notes: svn path=/head/; revision=94196
-rw-r--r--textproc/libxml2/Makefile7
-rw-r--r--textproc/libxml2/pkg-plist4
2 files changed, 11 insertions, 0 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 869a04ba321c..9298eea51bdb 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libxml2
PORTVERSION= 2.6.2
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.6
@@ -79,4 +80,10 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/catalog.c ${WRKSRC}/xmlcatalog.c
+.if !defined(WITHOUT_PYTHON)
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/textproc/libxml2/pkg-plist b/textproc/libxml2/pkg-plist
index adba327413bb..30e563e8199a 100644
--- a/textproc/libxml2/pkg-plist
+++ b/textproc/libxml2/pkg-plist
@@ -48,7 +48,11 @@ lib/libxml2.a
lib/libxml2.so
lib/libxml2.so.5
%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.py
+%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.pyc
+%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.pyo
%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxml2.py
+%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxml2.pyc
+%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxml2.pyo
%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxml2mod.so
libdata/pkgconfig/libxml-2.0.pc
share/aclocal/libxml.m4