aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-27 13:21:46 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-04-27 13:21:46 +0000
commit0e4708cf6b1eaa38de81ee9ff0fdf9eecfd0a452 (patch)
treeafbd47f4bd1e6c7bb8f7ca3da5f74ef56589d3a9
parentea1f1a378283c4107450456000ad15b2fb38f7bc (diff)
downloadports-0e4708cf6b1eaa38de81ee9ff0fdf9eecfd0a452.tar.gz
ports-0e4708cf6b1eaa38de81ee9ff0fdf9eecfd0a452.zip
lang/ocaml: simplify powerpc* handling
-rw-r--r--lang/ocaml/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index d4019d14ca4f..59e1453bb8f9 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -64,7 +64,7 @@ DOCS_DISTFILES= ${DISTNAME:R}-refman-html.tar.gz:docs \
.if ${ARCH} == armv6 || ${ARCH} == armv7
CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS} -meabi=5"
-.elif ${ARCH} == powerpc
+.elif ${ARCH} == powerpc || ${ARCH} == powerpc64 || ${ARCH} == powerpc64le
LLD_UNSAFE= yes
.else
CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS}"
@@ -102,11 +102,6 @@ PLIST_SUB+= PROF=""
.if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-asmcomp_power_arch.ml
-LLD_UNSAFE= yes
-.endif
-
-.if ${ARCH} == powerpc64le
-LLD_UNSAFE= yes
.endif
post-patch: